Integration with Worx Landroid mowers

Thank you for the app.I have a landroid WR105SI.1. it looks like this one is not supported ?

Adding the landroid with new hardware it can’t find any landroid.

You have logged on to your landroid account?

Martin Verbeek

I set the settings for inlog on landroid tab and put the debug mode on. See the picture.
Anything else I can try?

Ofcourse i restarted the landroid and also restarted your app…

Hello Martin,
Problem solved. Password reset and the problem was solved.

I will do some checking and let you know. Might be Monday before an answer.

Martin Verbeek

Only a good error message in the logfile if you enter a wrong password would help:-).
So far so good.

Will include that in next patch. Thanks!

1 Like

Fixed issue with failed auth message to front end in 3.1.2.

1 Like

Hello Martin,

i also have a problem with the app. i have a landroid model WR141E. firmware 3.28
i have the username and pass for the app (landroid) and it works. when i want to add it to homey i get next faults.

the log is saying "Authentication failed, invalid credentials error "etc… i have no idea because i use the same as in the worx app. can you give me some advise?

also in the log “Device not found (robotname) and the serial number.”

thanks ,greets Kevin

Martin fixed it just 1 hour ago, please take a look on [APP][PRO] Worx Landroid, Kress, LandXcape RoboMower integration - #65 by Martin_Verbeek

Hello everyone

i am trying to integrate my landroid with homey but i keep getting the message that it cannot find a device.

Here are the logs:

What should I do ?

thanks in advance

'Morning guys, Martin,

i have the same issue. Credentials are ok, but still can’t find my device, i have a WR310E

Any advice or tips?