Homey 10.2.1 and KNX-IP interface not reachable

Hi all,
I have seen that on 9th Jan 2024 my Homey Pro (early 2023) got updated to version 10.2.1 and since then I cannot control any KNX devices. All of them are unavailable with the message: Selected IP interface not found.
This is the interface I have EIB KNX IP Interface PoE (Manufacturer: EIBMARKT, N000401)
with which I could use my KNX devices from Homey.

The KNX-IP interface works from ETS where I can use it to monitor KNX BUS activity.
I tried all the workarounds/solutions I found on the forum to no avail:
restart the KNX app
restart Homey
restart the KNX-IP interface
physically moving the KNX-IP interface far from power cables
Try to adding a new KNX device (a dimmer) to make Homey discover the KNX-IP interface
Checking wifi setting for Homey: it’s 2.4GHz

I suspect the problem is with the new 10.2.1 Homey version

Is there anyone else experiencing the same problem? Any solution/workaround that works?

Thank you in advance


I have the same problem did you find a solution?

I get an answer from Athom after I opened a ticket.
Uninstall the KNX app and re-install it.
Side-effect: you lose all your defined KNX devices :frowning: , but after that and redefining the devices, it started working again.

For my part,

I have just installed the box with a full KNX installation and this is the second time that it has done this.
I restart the KNX application on Homey, wait 10 minutes and then go to any device and delete the IP address, save, then put it back and everything works.
I made this message because I had just unplugged the box and I had the problem again

I do have the same problem form time to time. I disabled automatic updates for the KNX app.
Still the problem returns sometimes.
This morning I tried the following:

  1. Choose a KNX switch which is marked with an exclamation mark.
  2. Go to settings (right hand corner at the top)
  3. Change the IP interface adress to a nonexistent value
  4. Store the value
  5. Restore the IP interface Adress to the right value
  6. Store the value .

This avoids the deleting of all KNX devices and redefining them again.


1 Like

Same problem with my Homey KNX this morning after Homey update to 10.0.9.

Did the trick on just one device change IP address, save, put back original IP address and save. Suddenly all KNX devices are back and working again.

I did have disconnects before but restarting the app was always enough. In general it has been working quite stable for years.

Any idea what happens here and why?

Same problem here. Sometimes it works for some days, some days I get the red triangles with exclamation marks twice a day. Restarting the KNX app doesn’t give any solution, restarting the homey via the settings of the homey neither. unplugging the homey for 10 seconds works.

i had the same issue.
I removed all my temperature sensors which solved the situation.
Remained stable for over a month.
Re-added sensors again today… hoping its resolved now…

I’ve tried your solution, it helps, but after a day or so, same problem.

Any long term solutions?

Not yet.
The last time I needed this “reset” is several weeks ago. So far so good. If someone would have a permanent solution I am of course interested.

I have spoken to Homey Support, they spoke with the developers, and have chosen to opensource the KNX app :tada:

I have created a PR with a possible fix for this issue:

1 Like

I’m experiencing this issue now every day. Shutting down my homey for about 15 seconds does the trick.
Unbelievable this hasn’t been fixed after 6 months.
I get more and more the feeling I’ve bought somthing on Alibaba.