Fibaro switches responsiveness


I recently bought 3 fibaro double switches and installed them in my apartment. Everything seems to work good as long as I switch 1 light group at the time. I tried making a simple flow and virtual button with toggling all lights on/off, that’s when I run into some issues. Sometimes all lights come on, sometimes 2 out of 3 come on or 1 out of 3, sometimes they come off randomly as well. Sometimes there is a huge delay between them…

What am I doing wrong? Or is this normal behavior?
Homey is about 3-4 meters away from the switches.

The problem is propably with Homey stack of commands to actuators (zwave or zigbee). Try to add delays in the flows between the switchings.

I’ve tried that, but the results are a mixed bag. Sometimes it works, sometimes it doesn’t.

I have 3 Dimmer 2’s and 3 Flood Sensors. I just deleted the 3 sensors and the responsiveness increased, however now for some reason I cannot do a reset of the flood sensors… I found people report the same issue using Homey on the here.

Also when trying to add the sensors back, the NodeID’s are skipped. So its not chronological anymore as 1, 2, 3, 4 etc. Also all of the flood sensor are Non secure now, and they were before…
They work, but appear Unreachable for some reason…

Plenty of info for all your problems in this forum, google is your friend :slight_smile:

Even with a fast controller like HC2 I never could switch all lights in the same time, so the above advice in having a delay in between each actuators in the THEN part.

That’s mostly because they were included “secure”, and it’s proven to slow down Homey, at least in my case and some others.

And why would you need to reset them for?

That’s very normal and once it reaches 232 (I think it’s 232) it will start again from 1 or use the next free node id. So there is nothing to worry about.

In the latest Fibaro app, this has been implemented by Athom, I think to overcome some of Homey’s issues with responsively and missing messages. Perhaps someone here can give you a better answer. But that’s good, unless you are worried of any security, it will make your network much faster. After I included all my Fibaro dimmer 2 and switched unsecured, the responsiviness has substantially increased.
Try this and maybe you experience the same. See this post HERE.

I agree 100 % with @danone.

As it looks like (screenshot) you only have 4 electrical devices (actors). And all devices, including the sensors, are directly connected to Homey and the actors do not repeat.
It may work that way, but I guess you are using too few actors. Z-Wave is a technology that normally builds a wireless mesh. This makes it possible for devices to find a new route if a device causes problems.

There is a known issue with Fibaro zwave-hardware and responsiveness with Homey. I’ve recently re-added all my Fibaro dimmers ‘unsecure’ instead of ‘secure’. This lowers the amount of zwave-chatter which in return seems to help with responsiveness. You can do this by selecting a Fibaro Walli-switch when adding the device. For some reason, the driver then initiates an unsecure include. It will then detect what the actual device is and make sure that devices gets added to Homey.

I wanted to reset the sensors in hopes that they will add back up as “secure”, but it seems like I’m better off keeping them “non secure” as suggested for better responsiveness. When I first added them, they were in fact “secure”, but after I removed and added them back in, they became “non secure”.

Thanks for the info! Sorry, I don’t know how to format as nicely as you do :smiley:
So I should just configure all the switches again and add them as Walli Device, which should make them “non secure”, thus improving responsiveness? I don’t really care much about the security here, they are only lights, so it’s not a big deal. If it were a smart lock or something like that, then I would be concerned.

Also, is there any way to set my own “route” for the z-wave devices? Because right now it seems like they just randomly switch between each other and choosing their own “neighbor” paths to reach Homey. And does this even matter at all?

Yes that makes sense. Sorry, I’m still learning about everything :slight_smile: I will probably reconfigure all the switches as Walli Devices so they become “non secure”.

And yes, the reason you see all of the devices go directly to Homey is because I was messing around in Developer settings, particularly the “Heal” setting, which forces the device to find a new path to Homey. Right now it looks something like this:

For now I only have 2 double dimmers, 3 flood sensors and 1 double switch.

Later one I will add 2 more dimmers, 1 more double switch, 2 rgbw controllers, 2 rollers shutters and probably a few motion and door sensors. For now I use xiaomi motion and door sensors, but I think I will switch them for z-wave fibaro devices for better mesh coverage. I was gonna cheap out a little bit by buying xiaomi, and they work just fine, but I think its better to just get everything of the same brand.

Thanks for the advice! Yes, I just read other replies and other forum threads regarding this. Interesting. I will probably end up doing that. It’s gonna be a pain in the butt getting the dimmers back out of the wall though haha :slight_smile:

By the way, since I use Homey with pretty much Fibaro exclusively, I cannot update any firmware as far as I know. Is there any workaround for this besides bringing Homecenter hub, updating everything and re adding back to Homey?

No. The devices always automatically look for the best route, but this often does not seem logical.

The second screenshot looks clearly “better” or “normal”.
With the “Heal” function the neighboring modules are requested again. Normally it is not necessary to use this function, because the modules do this themselves from time to time. If a module causes problems (e.g. not reachable) or the position is changed, then I use this possibility too. Battery operated modules like sensors have to be woken up before the “heal” process.

Battery-powered modules such as door/window sensors or motion sensors will not repeat the Z-Wave signal. So it is not really necessary.

Not really. Some years ago I started with the Fibaro HomeCenter 2 and some Fibaro modules. The door/window sensors, no matter if type 1 or 2, cause almost problems with the tamper alarm. The housing is not tight enough on some of them, so that the TMP button is not pressed properly. Meanwhile I have 6 Sensitive Strips, one Aeotec and one POPP door/window sensor. The rest are still from Fibaro.

The motion sensors from Fibaro also cause problems for me. The motion alarm is not always reseted, so that the light stays on from time to time. Meanwhile I replaced 4 Fibaro MS with NEO Coolcam MS. These are much more reliable. How high the battery consumption is, I can not say yet. I will replace the remaining Fibaro MS with NEO Coolcam as well. But beware. It seems that new series are sold at the moment, which do not work 100% with the current app.

No, a firmware update of Fibaro modules only works with a Fibaro Gateway. If the modules work properly, there is no real need to update them.
Because I still own my HC2 I can offer you to update the modules. You would only have to pay the shipping costs.

Interesting, didn’t know about battery powered devices not being able to transmit the signals. In this case I will keep my Xiaomi sensors then. When I will add more Fibaro switches and controllers, they will be in a line to the left and right to Homey, so I think that the distance will be good enough for a stable signal. I live in a 60m2 apartment, so the distances are pretty small.

It’s very nice of you to offer your HC2, but I live in Russia and shipping will be expensive and long, I have someone here I can borrow it from if I decide to update :slight_smile:

Thank you though.

You’re welcome.

Edit: This would also not work because of the different Z-Wave frequencies.

This is the link regarding the problems with the new NEO Coolcam MS: