Error "Network request failed" during test of a flow while using a delay function


I’m trying to create a flow with a variable delay that I will use to manage the engine heater for our car.
Depending on the outdoor temperature, I would like the engine heater to run for 60, 90 or 120 minutes and then turn off again.
However, when I try to create and test a simple flow for this I end up with the delay card failing with “Network request failed” and I cannot really figure out why this happens. I have tried to search in the Homey community and have performed the usual trouble shooting restart of my Homey system but have so far not been able to figure out the cause of this problem.

Below shows an example of a test I ran with a delay of 60 seconds:

If I however set a short 10 second delay via my variable all three tests scenarios run successfully.
Any help how to resolve this would be greatly appreciated.

The variable I have defined for this test scenario:

The script for the first test scenario:

The script for the second test scenario:

The results for test scenario two:

The results for test scenario three:

Don’t use the yes/no option, just “Run code with argument” like scenario 2.
Otherwise you’ll need to use this when you use result true;:

The only (odd) problem here is using the “Test run”: I also get the Network request failed error after 30s.
30s. is the default web time-out, probably to prevent endless running cards.
But, that’s the only problem in this particular case, while the flow runs fine in normal use :partying_face:
When I start it in normal mode using the “Start this flow” menu entry

It shows the expected Timeline results:
Screenshot from 2023-11-02 22-14-17

I used the same wait code as you did.