Configure Fibaro binary sensor with K2000 RFID reader

Hi all,

I’m on Homey 2.0 rc9.
My aim is to use the RFID reader in combination with Heimdall.

Tried connecting the K2000 RFID reader with the Fibaro binary sensor, but I run into an issue which I can’t resolve (because I don’t understand if/what the issue is).

I connected the Fibaro Binary sensor to the K2000 RFID reader as per diagram:

Then, I was able to pair the Binary sensor with Homey.
It now shows up in the Homey App on my android phone, but the icon shows a red exclamation mark in the top right corner.
If I long-click on the device, it says: Device is unavailable invalid_commandClass_COMMAND_CLASS_SENSOR_BINARY_for_multiChannelNodeId_1

I am able to press the “settings icon” on the top right corner, and get to advanced settings.
But it doesn’t give me anything to configure the “input types” to Normal open.

What should I do?
Any suggestions?

Where did u get that?

Athom and I are besties BFF.

… Uhhhh meant RC.9 of course :slight_smile:

1 Like

@Frans_Keeman use K2000 with Fibaro :slight_smile: Maybe he can help Poke

Sorry but i am not yet at homey 2.0 so i can’t help him

I have tried so many times and so many different things… And it works now. But don’t ask me what changed…
I rebooted homey multiple times, I restarted the fibaro app multiple times, I tried removing the device via zwave settings and re adding again, reconnected the power cables again, pushed the button more than 3 times…

Anyway now it works.
I’m already able to set the alarm based on the pincode.
Now I just need to find the RFID tags in order to set them up… I lost them some where :sweat_smile:

any update on this?