Can't reset my password

I have forgotten my password to my Homey account, but am still logged in on my mobile. When I select forgotten password and click on the link I receive via email, I am asked to log in with my current username and password. Is anyone else having the same problem?

@ Home screen, hit your avatar on the right
Hit ‘My account’

Now you can login with new credentials!

Tried your solution and still can’t reset my password. Still getting asked to sign in when I click on the Reset Password link that I get via email. Now I can’t use the app either.

Maybe you confuse “login” with “login with new pw?”
Did you even try to enter a new pw before replying here?

No, I do not. This is what it looks like when I click on the link that I receive via email. When I try to enter a new password, it says that it is incorrect.

Hmmm. But this is not the mobile app, is it?
You were talking about that:

… and now you show a browser screen.
I would never have adviced to logout from the mobile app with this info.
Although the app would ask to login after a while anyways.

The screen you show now looks like you have to enter a new pw. I don’t know what’s wrong.

Maybe Geurt @dijker can help with his expertise here?
And pls write to Support | Homey I’m quite sure they prioritize your issue.

Homey support has now confirmed that there is a bug in their system that makes it impossible to reset your password. The developers are working on a solution.

1 Like

That makes sense! Glad they responded quickly to this.

I have the same problem with my account.

@Jonathan_77 : Is your problem solved?

If so, please let me know how.