Be carrefull, "rollershutter 3" from Fibaro does not work on Homey for venetian blinds

Ok, thanks but being in S2, does this prevent sending a hex code to the roller shutter, as described in the workaround?

Yes that what I said. No hex code as it is send unsecured whereas it requires secured code send.
Flow : then set fibaro rollershutter level to 5%
It did close, did not check the routine, no time yet

Ah ok, but for me it does not work; with 1% the slats close and the blind starts to rise … we should be able to put 0.3% but it is not possible …! in addition, parameter 153 (153,1,0) : slats return to previously set position only in case of the main (Homey) controller operation!!! so when we lower the blind completely 0% (to close the slats) the slats open again. OMG HOMEY!!!

Mmm… in vera there was an option to change device parameters with a scene. I don’t see this in homey. Perhaps turn off the slat repositioning ? As there is no way to position the slats anyway. Time to copy shutter 1 controls to shutter 3 , as that is working manually in the homey app at least. I don’t get why it is so hard to implement some buttons for slat position. Slider is a difficult thing and something else. They did have an option in walli rollershutter though to select slats slider, but it got removed soon.

yes it is incomprehensible … ??? but maybe Athom Homey does not know what is a Venetian blind … ?? :sweat_smile:

But it could be that this feature would be removed if I reinclude the Walli Roller Shutter.
The problem is that Athom partially changes or even removes the device capabilities in newer firmwares. So if a feature is available or not depends on the time (state of homey firmware) when the device was included.

Example: Fibaro Roller Shutter 2 (for blinds)

Because I included my roller shutter for roller shutters in 2019, I have both a slider and up/stop/down buttons. If I would include the roller shutter today, I would only have the slider.
In SDK3 Athom has changed the requirements regarding the capabilities for roller shutter. Either slider or button, but not both at the same time.

Yes indeed. I have the same. I have Rollershutter 1+2+3+walli and rs1 is pretty much ok, with its button and slider. One rs2 has only slider. The other rs2 has buttons but no stop button and one has both slider and buttons. The walli had 2 slider but didnt work , after setting it to venetian it was gone and not working at all. Rs3 is just having a slider and this works ok, but secured S2 so no raw z-wave for controlling slats.
Mind that all require first a completed calibration run, otherwise the blind will only full open and full close. No percentage setting will work unless full calibration is done and completed the whole procedure.
I ended up putting s1&2 switches to be able to manually do the things that homey doesn’t. Its rediculous considering the time they spend on fibaro app that it still doesn’t function as it should. Updates of firmware ok, but highest priority should be working stuff , not new options or general updates unless they’re bugfixes.

1 Like

NEW WORKAROUND:
by entering a bad PIN eg: 00000 (an idea of @Da_JoJo ) during inclusion, the Fibaro “Roller Shutter3” is not in: “S2 Authenticated” but in unsecured mode !!! so we can create flows with Zwave: “send raw command”.
So by following the tutorial of @AK47 I can finally close the slats in the evening and open them in the morning with flows !!! :laughing:
In waiting that Athom will support fibaro “roller shutter 3” for Venitian blinds fully… :rage:

2 Likes

Congrats! I’ll update my workaround guide… could you please describe or reffer to step by step guide of new insecure inclusion with wrong PIN? I would like to try it on my own.

Not much more to say …! during the inclusion when the application asks to enter the PIN code (5 digits) you enter a false PIN code, for example 00000 and a few seconds later the inclusion is OK but if you go to the advanced settings you will see that the Roller shutter3 is not in S2 (authenticated) …
Thanks again for your very valuable workaround.

Nice, I just cant recall that it was asking for code… I’ll try soon. Anyway I hope athom will update device driver so we will no longer needs workarounds…

Confirmed … and I’ve updated the workardound guide.

is there a raw command for “stop” as well? i did not find one in the manual!
thanks

Looks like after yesterday Fibaro App update, Venetian blinds has native suppport by Homey… just choose the this type in Advanced settings… so no more workaround needed?

Yes finally !!! it took more than 2 years. They are not very fast at Homey
Especially since there are still bugs…
But we do have two widgets: One for raising and lowering the blind and one for the orientation of the slats, but it’s the orientation slider that has still bugs

1 Like

But I still recomend to use raw parameter config from my guide… you could fine tune lamelas trim… and then it works!