[APP][Pro] Virtual Devices - Virtual Devices to simulate 1 or more real devices

I never create flows on mobile so I guess that’s not the case here…

Ah, didn’t know I could use it that way.

I’m going to wait it out a couple of days. Yesterday, without changing anything, it suddenly worked as expected.
Lights on in the evening at sunset and NOT on in the morning at sunrise :slight_smile:

Just now realized that you are the dev of this app :roll_eyes:

Spoke too soon, this morning the lights were on again when mode changed to Sunrise. :(:disappointed_relieved:

This is sooo weird… Why did it work perfectly yesterday and now again the same problem.

Really starting to doubt myself here…

This all seems to be correct, right?

This is my device with modes ‘Sunset’ en ‘Sunrise’

This flow should turn on my outdoor lights at sunset, but they also go on at sunrise…

This flow turns on other lights outside at sunset and should turn them off at sunrise, used to work when I used Better Logic (and also worked yesterday, but not today…)

For some reasson, when when using that card in the and colum. It also triggers the modus wich the multimodus is on that right moment.

Takes me a long time to find out even got in short loop sometimes. After switching to use the logic card and the needed tag it works perfect.

@Arie_Laxed can explane it a bit more, the where issieus mention on his github about it

But that flow is just a check, so nothing should be switched at all?
@Arie_Laxed So is it a bug?

I’ll change my flows for now, hope this gets solved in the future :slight_smile:

Well, changed all my flows to use the tags, but it’s still not working as it should.
Lights didn’t turn on at sunrise so that’s good (but could just have been luck).
But the lights that had to turn off didn’t…

I just noticed Homey updated this app to version 0.8.1 which was, according to the app store, released today. But I can’t find what has changed. Github doesn’t show any changes at all.

I changed my flows back to BL and they have been working fine for days now. Must be a bug somewhere…

Am using heimdall in combination with virtual devices that represent sensors from my separate alarm system (sensor updates are transmitted to homey via X10). This all seems to work, ie I see sensor updates in Heimdall.

However, I cannot trigger off a virtual sensor. Have tried 2 ways; using the “changed” card as well as the “virtual device has changed” card. In both cases I can see the virtual device being updated in Heimdall logging but the flow does not trigger.

Any clues?


In this case it’s the process of adding a new device and a compatibility indicator for Homey v2.

Thanks, not sure if I follow. What can I do to get this working?

@pim555 I replied to Maikel.
I’ll have to investigate your issue further, when I have time.
Are you using Homey V2?
And did you create the new Homey App to create the flow?

And what about isseu, more a request #38 :wink:

@Arie_Laxed I am on 1.5.13 and the flow was created in the good old web based UI

I plan to integrate my garage drive to homey. I will use a extension module of my garage drive, that has the following options:

State: Open, Closed, InMotion
Command: Open, Close, Stop

I will use a Arduino in combination Homeyduino for communication to Homey.

The question is what kind of virtual Devices should I use?
I think I have to use at least two devices, one for the states and one for the commands?
Any ideas?


edit: I think the “window covering” with the condition up/idle/down will be the best solution?

I like virtual devices.
But Water Meter (meter_water) is missing for the virtual devices right now. Hope you will integrate that in a future update.

Without trying to rush you, do you have an estimate on when you are able to look into this?
The lights in the living room behave very strange now, but I do prefer using Virtual Devices instead of changing the flows.

Hi Maikel,

Which issue is that, because various issues pass by on this thread.

Keep in mind that my “working list” are the issues (incl enhancements) on GitHub.

I just added 2 virtual devices and the icons don’t show up, not in the app and not on the developer-site.

I don’t know if this is a bug in VD or Homey V2 since I’m also missing some other icons (but those are only missing in the app)

@Fire69 ttps://github.com/ArjanKranenburg/virtual-devices/issues/77