[APP][Pro] Tesla Smart Charger

Tesla has pulled the plug on the old authentication method. Tesla Smart Charger and the Homey Tesla app does no longer update data from the car.

Strange . Works perfect here . Also installed it on another homey and signed it in .
Also works

Tesla Smart Charger is working but the Homey Tesla App does not work for me.

But isn’t the Tesla kept awake all the time? Even when he’s standing?

When you are driving, yes, it’s alive :slight_smile:

When parked, it falls asleep after 10 minutes I think. If the “data fetch interval” is 10 minutes or lower, the Tesla will be awake all the time, and that will drain the battery.

You can use flows to set the “data fetch interval”.

1 Like

I will update the Tesla Smart Charger app in a couple of days so it will support the new authentication system. This first fix will not support MFA.


Thank you for this quick intervene.

1 Like

v. 1.0.37 should be in Homey Community Store tomorrow, with a fix for the new way of authenticating to Tesla.


Select Device settings → Maintenance Actions → Repair to repair…

NB! Multi-factor authentication is not supported.

If anyone could check that the “repair” works, that would be nice!

Yes it worked, the Tesla is recognized again.

1 Like

Thanks! Glad to hear that!

I have a new version ready soon with support for multi-factor authentication as well.

Hello, thanks for the update :slight_smile: But if I understand well, we need to disable the MFA?

Hi Sylvain,

V. 1.0.37 does not support MFA, but v. 1.0.41 coming in the Homey Community Store tomorrow do support MFA.

1 Like

Thanks balmli for your answer and your work so I’m gonna wait for it :blush:

It’s working.

1 Like

V. 1.0.41 is now in the Homey Community Store:


with support for the new authentication system, including multi-factor authentication.

Please report any issues here.

Hello balmli, I just try and it didn’t work (pin code in invalid)

It might have expired… Can you try once more ?

I tried several time, I know the code expires every 30 seconds

OK, thanks for the feedback. I will investigate.

You can try logging in without MFA, if you want.