[APP][Pro] Motion Blinds

Hi, I do not have that experience. I have to say, I do not unpower the gateway that much but when I do, it never fails to connect to Wifi.

If you look in the original Motion Blinds app at the gateway, you see a wifi strength symbol. Is that strong, or is it low? I can imagine that the gateway will go into setup mode if it isn’t able to successfully connect to Wifi. If it would not then you would be stuck, which is worse. Is it possible to put the gateway in a place that has better Wifi? the radio signal towards the curtains can also be checked and the range on that is pretty good, so you could experiment with other gateway locations.

Also, is there much interference in the 2.4Ghz wifi band in your place, and have you ever tried switching bands to find something that doe not interfere too much with neighbors or your Zigbee mesh? I admit I rarely check because most devices connect with the 5Ghz nowadays, and 2.4Ghz is notoriously bad on some channels where I live.

As to the product support: @TedTolboom is right in that Robbshop supports both me and their customers in ways that Hornbach never could/will. So it depends on how you value that support and are willing to contribute to that.

Edit: another thought: how do you unpower the gateway? Do you pull it out of the USB adapter or do you unpower the USB adapter itself? I usually unplug the gateway from the adapter. If you pull the plug on the adapter with the gateway in it, and plug in in the same way, the power may not disappear/reappear as gracefully depending on the quality of the adapter. It may be that this causes the gateway to power up/down badly. Using a different adapter may yield different results if that is the case.

Thank you for your quick answer and thoughts.
Wifi strength and power adapter doesnt seems to be the problem. Tried on multiple locations with different power sources. Even with the gateway directly plugged into the AP (usb port), it will forget its settings.

Signal interference could be a thing, thats something I could experiment with. I do have the same situation regrading the 2.4Ghz wifi band. Unfortunately many devices still do not support 5Ghz. (ESP’s, Shelly’s in my case)

I’d also try another power source considering my later addition to the above post. I think connection problems are the most likely candidate, but swapping power supplies is too easy not to try.

@Edwin_D Last weekend I installed 9 Motion blind motors and they connected perfectly with Homey. Would it be possible to also connect the remote control to Homey? I want to use flows to open and close the blinds automatically based on the light intensity outside. It would be great if it is possible to pause these flows when the blinds are opened/closed manually by using the remote.

Happy to hear the app is working well for you. And also good to hear examples of intended use and ideas for useful automations.

You can achieve what you need, but not by coupling the remote.

To start with the remote: This app links to the dongle, and the dongle connects to the blinds. The remotes also connect to the blinds, so the app cannot see the remotes directly, nor react to them.

The good news is that these blinds support 2-way communication (which is not common among RF controlled blinds I might add). So if the remote controls the blinds, Homey will notice the change of the position of the blinds. So one solution to your problem is to distinguish between expected / automated changes and manual ones.

But my experience is that if you build the automated flows right, they won’t interfere with manual control. If you use “Luminance becomes greater” or “ Luminance becomes less” (don’t know if I use the right translations) then these flows only trigger when the sun level changes from higher to lower or vice versa, which should not happen time and time again. That will happen only once when it gets dark or the sun rises.

So for example if the blinds go down, and you manually send the command to put them up again, they won’t go down again until the sun has risen again and the dusk sets in again. So no need to use anything fancy. Does that answer your needs? (If not tell me why, and I can help with other solutions too).

Edwin, thank you for your response! I am already using flows based on the light intensity. These flows are triggered by a change in light intensity within a specific bracket. If I would close them manually they would open again when there is a change within the bracket. I want to deactivate this flow if I close the blinds manually. There are more trigger events for opening/closing of the curtains and blinds to prevent the living room from heating up. If the intensity or temperature gets to high the curtains will close and reopen if conditions are met. I think I will just use a Homey connected remote. But most likely my flows could be smarter.


The solution to your problem that you have in mind is still possible. It would look something like this:

Flow “Homey close curtain”: if this flow is triggered then start timer Auto of 90 seconds, close curtain
Flow “Curtain moves”: if curtain position changes and timer Auto is not running then disable flow xxx

And then call flow “Homey close curtain” in all places where you would do so programmatically (i.e. not where the remote has done it outside of Homey). The 90 seconds is what it would maximally take for the curtain to report it’s final position. But this is rather cumbersome - true.

The whole point of my first example was: you should try to avoid flows that keep doing the same over and over within the conditions (or bracket as you called it) that you want them to. These kind of automations should aim to avoid the “computer says no” dilemma you describe by themselves if possible. The pattern is usually something like this:

Flow 1: If curtain close condition is met then close curtain, disable flow 1, enable flow 2
Flow 2: If curtain open condition is met then open curtain, disable flow 2, enable flow 1

This makes these flows trigger only once and then stop to let other automations do their work independently - without needing to be aware of other reasons to open/close. It would keep Homey more efficient too, because otherwise frequent changes in luminance would trigger your flow quite often and most likely unneeded. The only situation where this would probably not work is when you gradually close the curtains over a period of time.

I will look into the possibility to see it I can detect unexpected moves easily from within the app and create a flow trigger for it, but I guess that is equally hard to get right so I can’t promise anything.

By the way, do you control multiple blinds with one remote? If so it might be wise to set the corresponding checkbox in the advanced settings of these blinds. If the remote operates more blinds at the same time, I often see only one of them change within the app.

With the checkbox on, I will internally query the positions of the other blinds too when one of them moves. My hope is I can tie in to that mechanism to detect remote control operations. Mind you those would also trigger on control with the original Motion app. And also, I won’t see the remote action until the curtain finished moving. So if it takes 60 secs, during that period the automated flows may still interfere. Let me know if you want me to try and are willing to test it.

I just published a test version with experimental support for detecting when blinds are operated by remotes or the official Motion Blinds mobile app. It may not be the best sulition tou your problem because I can only detect the movement when the final position is reached, but I thought such a trigger might be useful still.

You can install the test version of my app (version 1.1.2 at the time of writing) here:

Edwin, thank you for your support! I have tried the test version. Somehow Homey doesn’t detect (full) position changes made with the remote or Motion app. The blinds I control with the remote have the ‘remote group’ checkbox activated. I have waited for at least 15 minutes but the position values didn’t change where changes made with Homey are updated almost immediately.

Off topic. I thought about your ‘computer says no’ comment. You are correct that a check after every light intensity change requires a lot of ‘unnecessary’ resources. The problem is that there are a lot of conditions that I want to be checked before opening the curtains (light intensity, time, weekday/weekend, alarm on/off, temperature). If one of the conditions is not met I would need a new trigger to check again at a later moment. This can probably be done at a lower frequency than now. I need some time to figure this out.

The changes should be seen shortly after the blind reached the programmed end position. If the top position is set to tight, you may not get the state back. That’s because the motor stops due to friction before the programmed position is reached. But that should not happen on any other postion.

A few questions:

  • Is it only the full position changes, or also the smaller ones?
  • Did you fill an IP address in the app settings or did you leave it blank?

Please make note of the time, use the remote to control the blinds to the lowest position, wait 15 seconds or so, use the remote to move them up again, wait another 15 secs and then create a diagnostics report from the gear icon in Settings, Apps, Motion Blinds. I’ll check to see if you receive the reports from the blinds. Send me the code you get and the time you controlled the blinds back here.

If the original motion app does not receive the state changes either, I am a bit afraid of what I (won’t) see. Based on that I can also check with a contact I have at the manufacturer.

This version is now live. For those who are still on the test channel: It is best to go to the app store and install the official version. That way you don’t stay on the test track (and maybe inadvertently start testing other changes that you did not intend).

Good morning,

I’ve got a question. I’ve got these Motion Blinds and they are fully operational via Motion APP.
I can’t find the blinds through homey.

I’ve added the “Key” under settings. Eventually i’ve added the IP-address of the device. It didn’t help! :slight_smile:

Could i be a problem i don’t have a “Pro” version of homey or are there other suggestions which i could look in to?



Hi Marco,

The Motion app should work with a Homey 2016 or 2019 just file, it doesn’t need to be a pro (it cannot work with the new Cloud version and Bridge because that does not have access to the local lan).

The Motion USB bridge and Homey need to be on the same local lan. If either one is on a guest network and/or there are isolation features in place on that network then Homey and the USB dongle cannot see each other. The Motion app is a bit different because it can also function outside the lan, so that is hard to compare.

If Homey and the Motion bridge are on the same network and they cannot see each other then we need to look deeper. Can you please execute the following steps:

  1. Go to the app, Enter the settings and check the stars are there in the Key field.
  2. Turn on complete logging and click “Save settings”.
  3. Close settings and click on the gear icon in the top right.
  4. Restart the app. Give it two minutes to initialize.
  5. Go to the pairing wizard and try to pair. If you don’t get to see the blinds:
  6. Go back to the app and the gear icon and create a diagnostics report.
  7. Post the code you get in the reply.

I can then examine the logs to see where things do not go as expected.


Thank you for your reply.

I’ve got the following code


Please let me know if there is anything I can do to troubleshoot.


Hy Marco, communication with the blinds is working as expected as far as I can tell, but somehow the pairing process refuses to select the blind for pairing. I’ll check the code later tonight to see what that could be.

Hello Edwin,

Thanks again. I noticed the “use multicast only” was checked because of “troubleshooting”. I’ve created another one just to be sure. Without this box being checked.




Ah, I see the issue. The blind is a double roller type, not a plain rollerblind according to the data I received - is that correct? I didn’t have that for testing and I now see I missed something.

I intended it to link as a venetian blind in order to use the tilt controls for finetuning the position, but I didn’t do that correctly so it seems. I removed it from the rollerblind driver but didn’t add it correctly to the venetian blind driver.

I’ll create a test version so you can see if it works as expected and we’ll be able to make sure it is all perfect.

That correct BUT I’ve added it as a “normal” version as well. That didn’t join homey either

I published a test version. Could you try to pair it as a Venetian blind and test if it works as expected? This version should alllow it to pair either as Venetian or as normal (but not at the same time).
You can install it from the link below.


I’ve got some output now :

Cannot read property ‘name’ of undefined