[APP][Pro] Heatit Controls app [v3.6.5]

I have three heatit z-trm3 thermostats.
On one of them I have an issue. Heating goes idle way before it has reached the desired temperature. If I set the temperature higher, then back to my original setpoint, heating is resumed but goes idle again after a while.
See screenshots below.
Am I missing something?

Hello, has the thermostat Sensor mode been changed recently? Or is the thermostat just installed?

Hi, thank you for your reply.
Yes, all three have recently been installed and activated. Around 48 hours.

After installation the thermostat uses a few days to calibrate the internal sensor, during this time the thermostat will be only be ON for 75% of the time.

1 Like

Ok, I see. Thank you. Guess it will work itself out then :relaxed:

Since the update to v3.4.0 the app does not seem to display the current temperature anymore, it’s stuck at 0c. After restarting only 1 of 3 thermostats displays the current temperature.

It seems to be only a display issue, since the thermostats don’t try to heat to the target temperature of (currently) 5c. Only once I set the target temp to something above ambient temp, like 25c when ambient is 20c, the thermostat will switch heating to “on”.

Anyone else experiencing the same?

Update: After a couple of app restarts, I seem to be able to read all temps again. Not sure what the problem was.

Hi, I have the Z-Smoke battery version, and after it has been added to Homey, the “Z-wave device information\secure” has an ‘x’, indicating it is not added secure. This makes it impossible for me to control other S2 secure devices using associations. Is this intended, or am I doing something wrong when I add the device to Homey?

I have tried to associate it with an Aeotec Siren 6 with no luck, assuming it is due to the lack of S2 security.

Hi, If you press the homey instead of heatit controlls when including your Z-Smoke.
The device will be added with S2 security.

1 Like

I installed a Z-relay 25A a few weeks ago, but I can’t get it to send the meter report / energy data for the connected load. It reports the accumulated energy consumed, but not current, voltage or power.

It’s included unsecure (I have also tried exclude - factory reset - re-include using the Heatit app) but no change.

Any ideas?


On my two Z-TEMP2, I can set the temperature with a hysteresis of 1° (18°, 19°, 20°…)
Can we have a set point with a precision of 0,5°?
For example, 19° in the morning, and 19,5° at noon. The setpoints are controlled by homey heating scheduler.

Thank you,

Is it possible that you add this function in homey to the Z-TRM3 thermostat in the future. Then the user can decide for themselves whether they want to use this trigger or not.

Thermostat mode : automatic/heating/cooling/off


We have seen some problems with the Z-Relay in Homey not showing voltage or current.
To show power try to set the association 1,1 in group 1 of the device. If this does not work try 1 in group 1 instead.


This is not possible as the setpoint on the device itself is operating on whole numbers.


As said earlier, this is not possible as the thermostat does not have this function, therefor it is not possible to work around or integrate the feature.

Sorry for maybe a trivial question, but how to I perform the inclusion process so that it asks for the DSK code? Want to add my ZTRM3 as insecure, but each time I run the inclusion it do not prompt for DSK and just adds them as secure. Thanks!


To include the TRM3 in security chose the homey app instead of Heatit controls when adding the device

What do yoy mean with using the Homey app instad of Heatit controls? Please elaborate.

When adding a new device you are prompted with these choices:
Heatit Controls and Homey App Refers to this.

Still no fix for the issues with Z-Relay? I’ve tried everything now when it comes to different group settings. But I still can’t get mine to show anything more than the reading for Sensor1.