[APP][Pro] Gree HVAC app

Hi Glenn,

Probably you need to update your AC’s with the latest firmware. I had the same issue and after I updated to the latest firmware everything was okay in homey.

Hi Aivus,

I have a problem with connecting my heatingpump from Gree. It can find it when I install it from Homey but after that it says it has no connection with the heating pump. My heating pump is a Gree Versaci III and after I have read that more people can connect their Gree heating pump I would love to have this also in Homey. So I hope you can and will help me out.

Hello Axeblade,

I heard that some modern Gree ACs have different encryption key inside that’s why App may not see the device.

Unfortunately, community doesn’t have solution for this for now.

If your device is showing as “offline” always it could be the case here.

In the next few months I’ll try to add additional options to configure timeouts for the devices.
It allows to increase timeouts to prevent showing device as disconnected.

1 Like


Thank you for your explanation. I know that the Versace III heating pump is released in Q1 of 2022 so that could be right that they have added a new form of encryption. I hope there will be a solution and that additional options you are going to add will help out. If you want me to test I will help out with that.

Would it be possible to not send fan speed command with on/off?
every time my homey sends on command it also edits the fan speed and removes quite function.

I see you have a property for this, why not be able to send this card?

I am one of those with a Gree that cannot read current temperature. Would it be possible to 1) Allow current temperature to be read from a different source/device, or 2) Allow the app to be controlled with @balmli ’s VThermo app?

I guess the second option would be easier(?), but I currently can’t seem to get it working.

Change request that would fix this problem: Would it be possible to add an option for an external temperature sensor? That would probably fix the issue for us not being able to read the current temperature from the HVAC.

Edit: I think I have found a workaround. At least it has been working today :slight_smile: I use VThermo with an external temp sensor to find the current temperature. Further, I created a simple flow (when set temperature in VThermo changes, then set Gree set temperature to VThermo set temperature). VThermo can then control Gree using an external temp sensor. For my part, I control VThermo through Tibber.

Update regarding my last post: Using VThermo, external temperature sensor and flows works great for controlling the AC.

However, my AC has been offline for more than 24 hours now («Your HVAC went offline. Trying to reconnect.»). Known issue? Works fine in the ewpe smart app.

Does the app support heating pump type Lomo and/or Fairy?

Can someone help me please!
I have Gree GEH18AA-K6DNA1F/O
And it’s terrible how its works. Also modulation it’s 750w newer coming down.
But sometimes it’s wrong because I didn’t never get update?? How its that possible…
Am getting notifications no firmware version??

Can someone tell me what happens?

Fairy works fine over here

@aivus Great app! And I was wondering if it is possible to add the silent option?

I have made some fine working flows with your app and most of the time we like pur ac on silent. So its kinda inconvenient to still take the remote and do it manually. Thanks for your great work!

@Niels_van_Dongen I have a ticket for this, but currently don’t have a time to work on it

Yes. Known, but have no fix :frowning:

App doesn’t send fan speed when on/off changed.

Some features require to be send with every command and will be disabled if not send. So, it could be the reason for such behaviour.

@aivus since the latest updates of homey (that had some issues with the networking part) my ac’s are not recognized by the app anymore, according to emile it could be a problem with the app. I tried to remove and reinstall them but with no success, no ac’s are found anymore. I had the same problem with other apps but this is resolved with the latest RC (except for the gree app :grimacing:). If you need some info or an diagnostic report please let me know​:+1:t2: in the homekitty app there was the same problem and got this reaction from the developer, maybe it could help with troubleshooting. @Glenn the fault was in multicast-dns, which is a module used by hap-nodejs (but likely also other modules)

@aivus i have the same issue with reconnecting the ac .
The gree app can not find any ac devices anymore😔

Update :after updating Homey pro 2023 to rc version 89 is this problem solved!

It’s not finding any airco device since the last update. So I can’t use my airco anymore in all my Homey Early 2019 Pro flows.