[APP] Husqvarna Automower Connect

:+1: :+1: That was it.
Entering the email address on the PC did the trick. Did some troubleshooting then on the phone and found that the autofill on my phone stuck a space after my email address, that was the problem. Perhaps you could filter those out when people stick in an email address?

Thanks very much for all the help!

Great news and glad i could help :slight_smile: Will add this to the top-post above and will try to add some whitespace-trim to the email field in a future version.

Please share if you get a flow or similar to work that includes the mower.

:+1: Testing a few at the moment. If they work okay I’ll post them here.

1 Like

So I’ve got the following flows at the moment:


  • Set a logic variable ‘automower_parked_due_temp’.
  • Weather app, I’m using OpenWeatherMap (OpenWeatherMap | Homey)

My Automower 310 does not have the feature where it increases/decreases the mowing time based on the grass growing rate. But in temperate climates generally grass stops growing around 5 deg C.

So my flows stop mowing when the temp drops below 5 deg C and resumes ones it gets above 6. I’ve left the gap between 5 and 6 degrees so that it doesn’t swing between ‘park’ and ‘resume’ the whole time.
It’s sending a message using Telegram in the same channel Homey sends other stuff. Handy for troubleshooting, but not necessary. I’ve also have a virtual device that states if ‘WX Override’ is active, so I can see it handily in the Homey App itself. Again not a requirement.

I found a website that publishes the actual grass growth per week (kg Dry Matter per hectare), my long term aim is to scrape that value and to adjust the mowing schedule for my robot based on the actual grass growth rate.

Works pretty well so far!

I also have the following::

It’s only sending the error code itself though. Could you adjust the app so it’s sends the ‘translation’ of the error code instead? That would be more useful. My robot is pretty reliable though, so haven’t had any errors yet.


Thanks for sharing, i am sure it can help me and others running the app.

Smart, i like it! I have a weather station connected to Homey so i will try to do something similar and create flows to park at heavy rain and low temps. And before the irrigation starts watering the lawn.

Yeah, i also have the 310 and no ‘real error’ so far… Good idea to send the ‘error text’ and i will absolutely try to add that in the next version.

Again, a big thank you for testing the app and sharing your flows!

1 Like

No worries at all, thanks for developing the app! It’s a lot faster to control through Homey than the Husqvarna app on my phone (android).

I am using the app to control my Automower 315 and it works fine. The one thing that is not working is errorcodes. Made a flow that sends me a message when the errorcode changes, but it never does. I can get warning from the Huesqvarna app (eg when outside area) but in Homey the errorcode is always zero.

1 Like

Cool, nice to hear!

Thanks for reporting. I know the “activity changes” work fine as i use that but i will try to make some test with the others this weekend. Will get back with the result and hopefully a solution.

I’m having exactly the same issue adding my automower 315 as ano_ire had above.
I’ve added both API in my app at the husqvarna group cloud developer portal and have been trying to get it in to homey using all web interfaces. Still get the ’ Cannot read property ‘homey’ of undefined’ message when trying to add the mower in my homey…or just ‘Inga nya enheter har hittats.’ Deleted my husqvarna app at the portal and did everything all over again. Have tried to renew API key at husqvarna portal but still no avail.

Any further suggestions? Husqvarna app is working as it should.

  • What solved it for ano_ire (and myself at one time) was to use the PC to enter the credentials using Homey Developer. Copy/pasting the email/password on a mobile device sometimes add a space. I think the space comes from the text-box and when you put the cursor there it can end up wrong, i will fix this in the next version.

  • Make 100% sure that connect the Husqvarna application in their developer portal to both the ‘Authentication’ and ‘Automower Connect’ APIs.

  • Make sure you are using the same credentials when logging into the Husqvarna Developer portal as you use to log into the official Husqvarna app on the mobile phone.

Yep, done all that right here on my PC but still no luck… However at some point I got the error message to change from 'Cannot read property ‘homey’ of undefined’ to ‘no new devices’. Don’t know what change that?
Changed and copied the key with web interface and checked both email and password for spaces and errors.

That indicates that it fetches the list of mowers correctly but that the list it is empty. Are you using the same email for your Husqvarna developer account as the one you use in the official Husqvarna mobile app?

Yep, same mail and password. Don’t know if it’s any help but I couldnt get it into google home either so the error seems to be on the Husky side. But the Husqvarna app works…strange…

One thing to try is to invoke the APIa manually, both the auth and mower API and see what we get in return. If you want me to try contact me via dm.

Well. Me and BufferOverflow have now investigated why it didn’t work for me and as it turns out I don’t have the Automower connect module on my ‘normal’ 315. It works with the app but you cannot use Huskys API’s to import it in homey. Sucks. But I guess I can live with using the husqvarna app.

A lesson to be learned is to investigate your potential toys better before klicking… :slight_smile:

Here is also the reply Husqvarna sent me:

Thanks for trying our developer APIs.

Automower 315 is not a cloud connected mower. That means even though you can add it to Automower Connect App, it is not connected to our backend, rather only using BLE to the app. And therefore, it is not available in developer portal.

You can always buy the Automower connect kit and use it and then it will be available in developer portal.

1 Like

And i now hade made the first sentence in the original post in this thread bold :slight_smile:

Get back soon with an Automower Connect Module installed, we are waiting. That bluetooth thing does not allow you to control it away from home if i remember correctly…

That’s a shame. The Automower Connect kit is pretty expensive, I paid around €200 or so I think a good while ago.

I bought it since my my 310 is a couple of years old and is ‘complete stupid, i.e. not smart’. So there were no other options for me to control it except manually. If you can spare the money though it can be really handy. Although it only gets stuck maybe a few times a year. Once we were away for 3 months and left the automower to do it’s thing. So when we were away it got stuck and I got a warning on my phone. I texted the neighbours’ kid to go over and he got it going again.
Came back to a perfectly mown lawn after my holidays :grinning:

It is pretty steep. But it does include both a GPS and GSM module but even more importantly it includes the necessary mobile-network traffic costs for some years. This solution works for big areas without need for BLE or WIFI coverage.

I guess the other option Husqvarna could make it ‘cloud enabled’ would be some kind of indoor/outdoor gateway module like the Gardena version uses. But that would also cost some money.

Hello. I have strange error in the app. I have two Automower connected and added to homey. One is allways showing “error gjetting mower status.” Which one Who is showing the error seems to alternate throughout the Day. It is either not possible to send commands to the mower with an error.

I sort of debugged this by myself, by shifting the polling by on minute, such that the two mowers dont poll at det same time. The error message is no gone, but i still cant send park command to the two mowers, only the first is parked, even though i have delayed the command by 5 minutes. Delt Flow | Homey

Edit: It looks like it only sends commands to the automower that was last polled :confused: