Aeotec 6in1 sensor secure zwave plus, how?

I just received a new aeotec 6in1 sensor and i added it to Homey, this went without any problems.

But when i look in the settings of the device i noticed that the zwave is not secure.
There is also no option to enable this.

I got also a second sensor of this brand and type, but that sensor is secure, in the settings the secure option is checked.

Anyone an idea how do i enable the secure option on a zwave device, this sensor support this option, but i cannot find any option to enable/use this.

If the maximum security level that the sensor permits is S0 then Homey no longer uses that as it proved unreliable and slow for many people. S0 security needs more data to be transmitted. The app developer could implement a setting to re-enable S0 but that is not advised. I’d rather consider moving S0 devices to unsecure if it is not a door lock or something like that.