Homey v 2.2.0 mit Kameraunterstützung

Versuch mal so http://IP:PORT/snapshot.cgi?user=xxxxx&pwd=yyyy ohne Benutzer und PW vor der IP

Habe ich alles schon durch.

Und noch viel schlimmer, um ganz sicher zu gehen, daß die Experimenteinstellung nicht auf das FW update von heute angekündigt einwirkt, habe ich die Pro mal komplett zurück gesetzt.
Macht besonders Freude da keine Backps ab 2.xx möglich. Das ist für mich wirklich ein Unding.
Bei ca. 60 Geräten alles neu, auch schon diverse Flows, da kommt Freude auf.
Aber Fakt ist, wenn Experimente nicht aktiviert, fehlt die Kamera unter Homey.
Also ist das noch die Beta.
Ich fang also nochmal vom Urschleim an, aber als erstes mit der Kamera.
Wird sich nur nicht viel geändert haben…

Richtig genau wie vor, die Rücksetzung hätte ich mir sparen können.

PS: Ohne USR/PW davor läufts auch auf Ipad, Mac etc. nicht, es muß doppelt dastehen.

Ja, steht auch so in den Release notes:

Richtig erkannt!

Habe ich Dich jetzt richtig verstanden?
Deine URL funktioniert im beliebigen Browser nur nicht beim homey beim hinzufügen einer Virtuellen Kamera, richtig?!

Zu 1. da müßte ich meine Mail nochmal lesen, hab sie leider schon gelöscht.
Vielleicht überlesen, aber bin mir eigentlich ziemlich sicher, auch egal jetzt.

Habe alle Geräte schon wieder installiert, flinker Bube halt.
Nur die Flows sind natürlich weg, aber so lernt man beim wiederholen, hat auch was.

Die URL funktionieren auf allen Apple Geräten, nicht auf Homey

Hab kein direktes Windowsgerät mehr,
nur noch paar Virtuelle Maschinen bei Anfall von Wahnsinn oder Ebikeeinstellung.
W10 ist zu hoch für mich, bin nach XP, dem einzig Wahren ausgestiegen.

Wie ist denn die Fehlermeldung die du beim hinzufügen der IP Kamera bekommst?

failed, reason: Parse Error.

Jetzt kam bei wiederholter Eingabe Could not find that Pair Session.

Wechselt sich ab.

“Could not find that pair session” hat jetzt nicht mit der Kamera zu tun. Ist zwar auchn Fehler aber hier nicht relevant.

Irgendwo muss der Parse Error herkommen. Ich denke bei der Validierung des JPEG Bilds läuft was schief.

Das Schwierigste ist die richtige URL heraus zu finden. Jede Kamera kocht da ihr eigenes Süppchen. Sogar innerhalb eines Herstellers gibt es Unterschiede.
Es gibt nur wenige Hersteller, die den String in der Bedienungsanleitung dokumentieren.
Es geht nur HTTP oder HTTPS. RSTP auf Port 554 funktioniert noch nicht.
Bitte mal das hier probieren:

http://Benutzername:Passwort@192.178.178.31/tmpfs/auto.jpg
Natürlich mit eurer IP überschreiben.

Edit:
Lasst uns doch einen Thread öffnen, wo kompatible Kameras mit der funktionierenden URL gepostet werden können. Der Chef des Threads soll im ersten Post die eintrudelnden Meldungen zusammenfassen. Ich hab leider zu wenig Zeit dazu.

1 Like

Eigentlich sind die Kameras sehr ausgabefreudig, habe damit bisher nirgendwo Probleme gehabt, auch Linux, Android, selbst mit dem alten XP egal welche Software es kommt immer was raus, rtsp sowieso, VLC und irgendwelche Kamerabetrachter…


Das war eine der ersten URL die ich probiert habe.
Der Pfad ist richtig, bis auf den falschen Port.

Gibts so einen Fred nicht schon?
Ich habe ja vor Anfrage schon gesucht, da war sowas, hab mirs nur nicht gemerkt wo.
Und jetzt bin ich erstmal mit alles neu beschäftigt.
Ich suche aber nochmal.
Gerade im englischen Forum gefunden, da hat auch ein Nutzer exakt das gleiche Problem.
Muß also was grundsätzliches sein.

Und noch einer: hab mich also doch nicht verlesen.
Lex

5h

So, if I read the announcement right, this is an officially released function, not an experimental thingie. It also states I can pick a camera brand. The experimental option just asks for a URL, that’s it.

Hier noch eine interessante Seite falls noch nicht bekannt:

https://public-camera.com/en/how-to-connect-ipcamera.html

Einen hab ich noch:
Was muß unter Experimente alles aktiviert sein.
Habe nur VD aktiv.
Nicht daß das mit den anderen beiden Schaltern verknüpft ist.

was noch dringend von den homey Entwicklern realisiert werden sollte, ist eine Vollbildansicht des Bildes bzw. Zoom-Möglichkeit… das ist mehr als mini im Smartphone :slight_smile:

1 Like

Meine VSTAR Kameras (7816) laufen definitiv nicht auf dem Homey,
obwohl unter Safari der Pfad korrekt ist und ein Bild angezeigt wird.
Dafür läuft eine motorische Domkamera.
Nur nützt mir das Bild nun rein gar nichts, höchstens zum lernen.
Zumindest zeigt sie ein Bild an, aber das auch nur tagsüber.
Abends findet Homey die Kamera nicht mehr. Steht zwar immer noch in der Geräteliste,
aber es werden keine Daten gefunden, obwohl sie definitiv von überall her aufgerufen werden kann.
In Flows nicht einsetzbar weil dort gar auftaucht. Scheint wohl noch sehr Beta zu sein.

Ich habe mir eine günstige Ctronic-Kamera bei Amazon gekauft. Unerwartet gutes Bild und schönes dezentes design. Funktioniert einwandfrei mit homey, Synology und HomeKit(Homebridge)

der link für das Bild:
http://USER:PASSWORD@IP-DER_CAM/tmpfs/auto.jpg

und der RTSP-Stream für Synology oder HomeKit:
rtsp://USER:PASSWORD@IP-DER_CAM/11

und hier das Kameramodel:

Hallo @Maik, habe gerade gesehen, dass die Cam auch einen Ethernetanschluss hat? Kann die darüber auch PoE, weißt Du das?

Das weiß ich leider nicht, ich schaue heute Abend mal in die Anleitung. Auf Amazon steht nichts. Ich glaube aber nicht, sonst würde es in der Produktbeschreibung stehen, ist ja ein super Feature !

@Tino leider kein PoE.

Was ich aber bei der Suche entdeckt habe: Farbige Nachtsicht… das sieht abgefahren aus

Wo kann ich das finden?
Meine Kameras machen zwar ein 1A S/W Bild, aber dafür laufen sie nicht unter Homey.
Deshalb suche ich Ersatz und farbige Nachtsicht wäre dann auch nicht schlecht.

In der Ctronics App auf die Cam klicken und dann auf die Glühbirne :bulb: klicken. Dann Color auswählen.

Danke, dann brauch ich erstmal so ein Dingens

@Maik

Schade, Cam ist für den Preis ganz gut, aber nach dem heutigen Regen, hat meine Cam jetzt schon den Geist aufgegeben :thinking:
Ich war froh, als ich das Kabel durch das gebohrte Loch in der Wand gefädelt hatte :man_facepalming:t3:
Also, Austauschgerät ordern und nochmal…

LG

Uhh, na hoffentlich ist es nur ein Montags-Gerät gewesen. Ich habe 3 davon ums Haus positioniert, allerdings sind sie alle tatsächlich überdacht. Eine nur ca. 40cm aber reicht wohl.

Berichte mal ob’s mit dem Austauschgerät besser läuft.