Heimdall - Let Homey watch over your home

Ok, read your post again and now understand what you want. You want the house always armed when away but if a sensor is breached already when arming the house you want it to be ignored.

Could possibly also be solved but will be more complex. Perhaps do a check like I do and if windows X is opened set a variable to Yes and then in the Alarm Flow you have add an “and” parameter that this value has to be set to “No” for the alarm actions to take place.

Haven’t tested and could be other things that makes this not working properly , you might get a bunch of logg messages from Heimdall that the alarm has been breached.

@Tomm have you actually tested that situation because it should work like you desire.
The Alarm State will be triggered when a sensor’s state changes while a Surveillance Mode is active, not when a sensor is already ‘active’ (in this case opened) when the Surveillance Mode is set.
So, when the window is open when Heimdall is armed the Alarm State will not be activated, you may be warned a windows is open, but that’s configurable. Only until that windows is closed and opened again the Alarm State will be activated.

When I check my log I see that it actually happened. Surveillance mode activated at 10:17:53 and alarm is activated at 10:18:21. When i simulate i leave the house nothing happens.
Any thoughts why this could have happend once?

02-09-2019 10:18:51.696 Ingeschakeld Heimdall Alarm is geactiveerd. Klepraam Voorzijde: Geopend
02-09-2019 10:18:51.550 Ingeschakeld Heimdall Alarm is geactiveerd. Klepraam Voorzijde: Geopend
02-09-2019 10:18:22.547 Ingeschakeld Heimdall Alarm activatie is uitgesteld: 20 seconden.
02-09-2019 10:18:22.547 Ingeschakeld Heimdall Klepraam Voorzijde in Woonkamer activeerde Alarm.
02-09-2019 10:18:21.898 Ingeschakeld Heimdall Alarm activatie is uitgesteld: 20 seconden.
02-09-2019 10:18:21.898 Ingeschakeld Heimdall Klepraam Voorzijde in Woonkamer activeerde Alarm.
02-09-2019 10:18:05.725 Uitgeschakeld Apparaat check Aqara Wireless switch is gereed
02-09-2019 10:18:05.493 Uitgeschakeld Apparaat check Aqara Vibration Sensor is gereed
02-09-2019 10:18:05.284 Uitgeschakeld Apparaat check Koelkast is gereed
02-09-2019 10:18:04.912 Uitgeschakeld Apparaat check Raam Slaapkamer is gereed
02-09-2019 10:18:04.821 Uitgeschakeld Apparaat check Klepraam Voorzijde is gereed
02-09-2019 10:18:04.737 Uitgeschakeld Apparaat check Over is gereed
02-09-2019 10:18:04.653 Uitgeschakeld Apparaat check Badkamerlamp is gereed
02-09-2019 10:18:04.278 Uitgeschakeld Apparaat check MultiSensor is gereed
02-09-2019 10:18:03.680 Uitgeschakeld Apparaat check Rookmelder is gereed
02-09-2019 10:18:03.402 Uitgeschakeld Apparaat check Rookmelder is gereed
02-09-2019 10:18:03.258 Uitgeschakeld Apparaat check Lamp naast de bank is gereed
02-09-2019 10:18:03.104 Uitgeschakeld Apparaat check Lamp in de hal is gereed
02-09-2019 10:18:02.964 Uitgeschakeld Apparaat check Lamp op de overloop is gereed
02-09-2019 10:17:53.321 Uitgeschakeld Flowkaart Toezicht mode wordt ingeschakeld over 0 seconden.
02-09-2019 10:17:53.614 Ingeschakeld Flowkaart Toezicht mode is ingeschakeld

The code that writes that logline is part of the function that get’s triggered by a state change of a sensor. So my conclusion is that the sensor send a report the state changed. As far as I know sensors will only send a report when their state changes, not on a regular interval announce their state to the controller.

And since i can’t reproduce the problem I am gonna thank you both (@DaneedeKruyff and @Borgen) for your help and let’s hope it was a one time error.

Hi All,

I want to make a pre alarm check. but I think its not workin. I followed this link Wat is mis met deze flow in heimdall

What do I miss here.

Thanks,

It looks ok to me but if it isn’t working there are some steps to try where is goes wrong.
First make the flow as simple as possible; remove the condition (And…) and replace the Telegram card with a inbuild notification card and test that. If that test is succesfull try adding the other cards to see where it goes wrong.

I tried what you suggested. The logical card is not working. Its a local tag… its not getting the word Geopend. What tag can i use

The local tag is the one to use. What message does it show in the notification? With what type of sensor are you testing this?

Now I have I like this.

I want to check my window/door sensor (Neo Coolcam)

In de Heimdall app I also checked this option 48

It checks on partial alarm and full alarm right ?

What does the notification say when you use this flow

The Pre-Arming Check (Inschakelcontrole) setting is ok, the check will be performed when selecting either the Armed or Partially Armed Surveillance Mode

@DaneedeKruyff, sorry if this has been asked before, this topic is getting large :slight_smile:. My Galaxy alarm had a “Looptest” feature and I was wondering if that could also be added to Heimdall. Upon activating this looptest mode it should simply fire an event with preferably the zone and sensor tag that activated.

That way we could set Heimdall to looptest mode, walk around the house, open and close door, windows, wave at motion detectors etc. and have Homey / Chromecast devices say “Sensor active in …” so you would have an easy way to test all sensors, without it triggering the alarm or needing to rewire the flows for this purpose.

Another question I have is about the 24 hour check for sensors. I have lots of sensors that don’t open, close or detect motion within 24 hours and they now all raise those alerts, but I actually want to use this to see if the sensors still function. I enabled the “wake up” interval on these sensors to wake up at least every 12 hours. I was hoping this would signal a “I’m still here” to Heimdall, indicating that the sensor is still “present”, but this does not seem to work. Would it be possible to take those wakeup events into account?

1 Like

Hi Arjan,

If I understand it correctly you’d like to arm the system to check all sensors without triggering the alarm? I think I can make that work, have to think how to implement that as the Surveilance Mode only has three possibilities. Think it has to be an additional switch in the settings to be able to use this. Will have to make sure Heimdall doesn’t remain in this mode for ever so it should revert to normal operation after some time…

Heimdall takes the last communication timestamp from the devices for that, however, when a device wakes up at its wake-up interval it will check it’s sensors but will only send a report to Homey when a value has crosses a threshold.
This works well for temperatures and humidity, but will do nothing for a contact sensor or motion sensor, it will simple not send a report (to save battery) so the last communication timestamp will not change.

Thanks, and yes, it is a separate test mode and it would make sense to have this “Testloop” added to the surveillance as you will not be testing sensors while the alarm is (partially) armed. It’s a bit like the event you already have that can trigger on sensors while the alarm is active. It simply raises each time a sensor is triggered. A new flow that is only active within this test mode would be great.

We could quickly test all sensors with that and I could also use it when I’m at home alone to be alerted as soon as anyone enters the house, without all the alarms firing.

Too bad that there is no better way to check the sensors. If they don’t notify Homey it will indeed be hard for Heimdall. That would make the looptest even more wanted, so we can do a periodic test our self :slight_smile:

Just realised Heimdall already offers functionality to check your sensors in realtime. Go to the apps settings, open the Devices tab and the State sub tab. Walk around the house, wave at the sensors and open the doors/windows and you’ll see their state change in realtime, even for sensors that are not included in any of the Surveillance Modes

1 Like

Tnx, I knew of that and it is great, but it is not capable of triggering a flow. On a flow I could Google tts it to all of the speakers and that would be nice. But you are right, I could just as well walk around with my mobile and check the app while testing.

@DaneedeKruyff, I have a problem with the Heimdall app that happens randomly. I hope that this is the right place to bring up this issue…
I use a Popp keypad to arm and disarm and it works fine most of the times. However, sometimes (maybe once a week) this problem happens:

  • The alarm countdown starts when a motion sensor is triggered when entering the main entrance
  • I enter the correct code on the keypad
  • The alarm is not disarmed and the countdown is still active
  • The alarm is activated and the siren starts
  • About 20 seconds later the alarm is disarmed - by the flow that I triggered 20 seconds earlier!

Dashboard:

Seems like the disarm flow is delayed.
Have you seen or heard about this problem before?
If not, how can I troubleshoot this issue?
Can the problem be the Heimdall app or the actual Homey?

Hello Harald, This is the right place to discuss Heimdall :slight_smile:

I have not seen any reports that the changing of the Surveillance Mode was delayed, it happens instantly on using the Surveillance Mode Switch or the flow card.

Can you post a screenshot of the flow you use to set the Surveillance Mode to Disarmed?
How did you determine the flow actually fired 20 seconds earlier?
How is the CPU usage on your Homey?
How is the Memory usage on your Homey?

Many thanks for the quick reply! :slight_smile:

This my flow to set the Surveillance Mode to Disarmed:

In the screenshot from my original post (I could not get the whole line in the screenshot) you can see:
12:44:19.006 Armed Heimdall Alarm is activated.
12:44:41.055 Disarmed Flowcard Surveillance mode is disarmed

So, about 22 seconds after the alarm is activated, it is disarmed. I entered the correct pincode during countdown of the alarm.

The CPU looks good. I didn’t check the CPU when the problem happended (will do that if the problem occurs again). At the moment the CPU is:
Last minute: 37%
Last 5 minutes: 23%
Last 15 minutes: 14%

This is my current memory usage:

The flow looks ok. I don’t think the cause of the delay is in Heimdall or your flows, but somehow the disarming on the keypad is not processed in realtime in Homey. This can be because either the CPU is overloaded, too much memory in use or a delay in the Z-wave network.
You can add a notification card to the flow to get a notification on when the flow is actually executed, I suggest using Pushover for that.