[APP][Pro] Heatit Controls app [v3.6.5]

I have just bought 2 Z-Water units and a bunch ot Z-Temp2 thermostats.
I don’t know if this is related to Vidar’s problem above.
The Z-Temp2 work fine when controlled from Homey. They change setpoint just fine, but when I change the setpoint on the Z-Temp2 itself it doesn’t get updated on Homey. Furthermore, Z-Temp2 doesn’t report the current temerature to Homey.
If I restart the Heatit app, the setpoint and temp is updated, but then it stops reporting back to Homey once more…

The Z-Water units doesn’t seem to report the status of the relay ports either. In Homey, all of them seems to be turned on, but in reality they are all turned off…

Right now, for testing purposes, Homey, Z-Temp2 and Z-Water are in the same room. Alle within 2 meters of each other.

Good morning. Any idea on the update of the app? I’m waiting to update Homey because it will break some Heatit controls as described above. Thanks!

i’m also waiting for an update on the relay to be able to use power metering.

1 Like

I’m also looking to get the Heatit Z-wave Single Relay working. Hope you can do this soon.

1 Like

I have one ztrm3 waiting to be installed.

Can anyone confirm can that device still be added and all measurements working?

I have one installed long time ago but got that installed as unsecure so its working.

I see S2 security may be related to some problems: I would very much like to add the Heat-it z-push 4 unsecure, as with S2 security I am not able to set associations to my dimmers. If adding devices unsecure is not an option, I would very much like that the settings would provide an option to send associations to other than Homey are sent unsecure.

@HeatitControlsAB any update on this?


The thermostat still works with all measurements.

No update yet on the integration.

On this?


We’ve not been able to confirm this as we do not have a Homey with thermostats included before the update but according to Vidar (HeatIt App - #19 by Vidar) you can factory reset the devices and re-include the devices and they’ll work again.

This reset was just a short term solution to get thermostats online again. I still have issues with the thermostats going offline or frezing. Then I need to power off the thermostats or sometimes remove them from homey and reconnect. In some situations I need to reset the thermostat and set everything up again. I still have big issues with Z-Wave equipment going offline or freezing.
I can also see the same as bjornb mentioned further up, that equipment that gets problems are reported to use a route with not existing equipment.
There is a need for HeatIt to investigate this further.

1 Like

An update from my side: my Z-TRM3 has been working fine for weeks now included unsecure as mentioned above.


Im trying to include a z-push button 4, when pairing homey shows both green checkmarks, I then get the error message (freely translated from norwegian): no compatible homey-app found for this device. It has been added as a simple Z-wave device. The device have ID 124. I have heatit app v2.7.1, and homey firmware 7.1.4. I have tried to include with a distance of 3cm to homey. I have tried with two different z-push button 4. I presume its the same error as @ThomasV. Are you looking into this @HeatitControlsAB?

1 Like

Hi, if you could check the manufacturer ID of the generic device for me?

Hi, it’s 773. I took a screenshot of all the settings if that helps. That’s a quick response!

1 Like

Hi. One of my thermostats notified Homey about an empty battery. I changed the batteries but the notification is still there. Also after 48 hours. It doesn’t get updated. Is this a bug? In the advanced settings under the Z-Wave information the battery is marked with a cross, not a check. But that’s strange since Homey did notify me of the empty battery.


Excatly the same with one of my thermostats. The batteries that came with it lasted for maybe one month. Now after a battery change, the battery still shows 1 percent. Homey has been rebooted, and the app has been restarted…

1 Like

I have exactly the same issue as ole-nord. Yesterday I purchased two new Heatit controllers. 8-button and 4 button. Both is recognized as unknown. I have an older 8-button that is recognized correctly (I disconnected it and re-included it for test purpose. Attached is the screenshot for both the 8-buttons, The ID 109 is the older, working one, the ID 110 is the new one not recognized

Is it possible to include Z-trm3 as unsecure?

I have one Z-trm3 that worked flawless for a year until two weeks ago. Removed and readded it multiple times, but it lose contact with homey after a few hours. I unsuccessfully tried to change association group 1 from 1.1 to 1 and then back to 1.1 again. Also tried to reset the thermostat, but its still losing contact with homey after a few hours.

I have another z-trm3 thats work perfectly, and the only difference seems to be that this are added like unsecure.