[APP][Pro&Cloud] Shelly

The address range was the same. homey never gave a fixed IP. I have set up other fixed IP addresses. for shelly 1 and changed them in the Homey app, I found that if I turn off Coap in the app it is better

This is not a proper solution for your case, change it back. Either re-pair your devices or go into the webinterface of each device and change the CoIoT settings (under Internet & Security > Advanced > CoIoT peer) to match your new Homey IP.

Thank you. I’ll check back later. good job by the way. I have been following the development of the application from the beginning

Used the Search function? :wink:
https://community.homey.app/search?context=topic&context_id=765&q=Fix%20flows&skip_context=true

ah, I thought it was a post in this topic somewhere (specifically for Shelly) but it’s a dedicated topic, tnx.

Hi,

I really need some help. I have three Shelly H&T that I try to connect to my Shelly Pro. As always the process starts with connecting to wifi and connecting to Shelly Cloud. This is no problem at all. But I just cannot connect with the Shelly App in Homey. They dont even show up in the first stage and I cannot add them by IP.

Contacted Shelly support and they said this is normal as the Shelly H&T just wakes up to report.
My H&T are powered by USB not batteries so they should wake up every ten minutes or so.

But I know there are users out there that actually succeeded in connecting to H&T - how did you do it? :slight_smile:

Are these Shelly Plus H&T or the old Shelly H&T first generation? Did you follow the instructions and have woken up the device by pressing the wake button inside? And what is the error when you try to manually pair them?

Hi, thanks for your response. I got them visible in Homey after using the wake button - thanks for pointing me to that solution. However, after a few minutes I get the red triangle and Ehostunreachable error message. I suspect this is by design as even USB connected units sleeps, wakes up, sends data, sleeps. But I am too new to understand how to get this to work with Homey?

There is a setting in the H&T where you can set it to USB powered.
Its in the shell app or in the website of the device.

Hi, yes, I have set it to USB powered, this makes the H/T to wake up every ten minutes or so, but still they are not usable in Homey. I think this design related, but I am hoping for a workaround. :grinning:

Hi all,

First off, I have a bunch of Shelly devices and this app is a lifesaver! One of the best Homey implementations for me personally. All my devices were on the old device drivers before (which are now deprecated). And I’ve recently put them all on the shiny new device driver without any problems. Took a while because I have way too many, but they seem to work faster now? Might just be in my head.

Anyway, recently I’m having an obscure issue with the 2 Shelly 1L’s I have at home. Every time they reboot, they also automatically trigger all their connected inputs, not once but twice (with 2 seconds in between). See attachment below to check out what this looks like in Homey device history (happens on every reboot without fault).

Luck would have it that both these devices are in bedrooms. It does not happen very often, but this means that sometimes the lights randomly turn on and off while sleeping, spooky. I also have this cool flow where two presses within 3 seconds on a switch above our bed either wakes up the house or puts the house to sleep. The above issue has resulted in being brutally awakened at around 7 on a weekend by lights turning on, music starting to play and our roller shutter opening. Fun when it happens once, but I’d like to avoid this in the future.

I might be very wrong but I’m almost positive it’s because of the new driver. Mainly because before (with the deprecated drivers for the Shelly 1L’s) this was not an issue. Also because my Shelly 1’s and my Shelly 1 plus do not seem to have this problem, they can reboot all they want and they do not make any of their inputs switch on/off.

If it helps, these are my Shelly 1L /settings:

{"device":{"type":"SHSW-L","mac":"84CCA8A7AF2B","hostname":"shelly1l-84CCA8A7AF2B","num_inputs":2,"num_outputs":1,"num_meters":1},"wifi_ap":{"enabled":false,"ssid":"shelly1l-84CCA8A7AF2B","key":""},"wifi_sta":{"enabled":true,"ssid":"WiFi-SJ-HA","ipv4_method":"static","ip":"192.168.0.83","gw":"192.168.0.1","mask":"255.255.255.0","dns":null},"wifi_sta1":{"enabled":false,"ssid":null,"ipv4_method":"dhcp","ip":null,"gw":null,"mask":null,"dns":null},"ap_roaming":{"enabled":false,"threshold":-60},"mqtt": {"enable":false,"server":"192.168.33.3:1883","user":"","id":"shelly1l-84CCA8A7AF2B","reconnect_timeout_max":60.000000,"reconnect_timeout_min":2.000000,"clean_session":true,"keep_alive":60,"max_qos":0,"retain":false,"update_period":30},"coiot": {"enabled":true,"update_period":15,"peer":"192.168.0.192:5683"},"sntp":{"server":"time.google.com","enabled":true},"login":{"enabled":false,"unprotected":false,"username":"admin"},"pin_code":"x@@&!T","name":"Licht slaapkamer","fw":"20221027-091704/v1.12.1-ga9117d3","factory_reset_from_switch":true,"discoverable":false,"build_info":{"build_id":"20221027-091704/v1.12.1-ga9117d3","build_timestamp":"2022-10-27T09:17:04Z","build_version":"1.0"},"cloud":{"enabled":false,"connected":false},"timezone":"Europe/Brussels","lat":51.035000,"lng":4.484210,"tzautodetect":true,"tz_utc_offset":3600,"tz_dst":false,"tz_dst_auto":true,"time":"10:55","unixtime":1667728525,"led_status_disable":false,"debug_enable":false,"allow_cross_origin":false,"actions":{"active":false,"names":["btn1_on_url","btn1_off_url","btn1_longpush_url","btn1_shortpush_url","btn2_on_url","btn2_off_url","btn2_longpush_url","btn2_shortpush_url","out_on_url","out_off_url"]},"hwinfo":{"hw_revision":"prod-202010", "batch_id":0},"mode" :"relay","longpush_time":800,"power":-1,"relays":[{"name":null,"appliance_type":"General","ison":true,"has_timer":false,"default_state":"on","btn1_type":"detached","btn1_reverse":0,"btn2_type":"detached","btn2_reverse":0,"swap_inputs":false,"auto_on":0.00,"auto_off":0.00,"schedule":false,"schedule_rules":[]}],"eco_mode_enabled":true}

And as an added note, they both use an (older) bypass installed at the light and they are both set to “detached” (not sure if any of that matters). Maybe it’s a wiring or a Shelly 1L breakage/software issue, but then I would have to be very unlucky to suddenly have it happen with two devices in the exact same way.

I might be missing something obvious, but can anyone point me in the right direction? Can anyone else with a Shelly 1L reproduce this issue, or am I the only one that is having this problem? I have no clue how I can fix this besides trying to work around it with a flow in Homey or checking the wiring/replacing the Shelly 1L’s, so any ideas are appreciated.

Thanks for the help!

I highly doubt it although it’s the natural response to blame the app. The code to register input events has not changed. The same code is used for the deprecated drivers as well as your Shelly 1 devices that do not show this behaviour. Sounds unlikely this would only and only just now affect the Shelly 1L. Sounds more like some strange behaviour on the Shelly 1L firmware.

1 Like

Thank you for the fast response! Sorry, been looking all over for a cause, I am a bit desperate, was not looking to blame the app. It’s worked mostly flawlessly, so thanks for all the hard work you’ve put in already.

So your guess is a 1L firmware issue, sounds reasonable. I was under the impression that the firmware for the 1 and the 1L is exactly the same, but I might (again) be wrong. I guess I’ll try Shelly support and see what they say, it does not seem normal to me that a power cycle would so neatly trigger the inputs on one device but not on a nearly identical other device.

If anyone with a 1L at home can provide some feedback, I’d love to hear if you’re having the same problem or not, so I can rule out some kind of crappy installation or hardware/software failure on my side.

Thanks for your input and sorry again.

@Phuturist Long story short, I found someone with a 1L who was not having this issue. Surprise surprise, they were still on older firmware. So you were 100% right: A downgrade to firmware 20220209-092839/v1.11.8-g8c7bb8d fixed this issue for both my shelly 1L’s. So it’s a Shelly 1L 20221027-091704/v1.12.1-ga9117d3 firmware issue like you said. Hopefully this message helps someone with the same problem. In the mean time I’m opening a ticket with Shelly support so they can fix it. Thanks again for all your help!!!

1 Like

I’ve an issue with the “Action Events” for the Shelly i4 DC. I’m not able to trigger any of the action events, doesn’t matter if single push, double push or long push. A normal “button on” flow does work as expected. Should I see the action events in the device log? Or how can I troubleshoot the issue :-)?

Did you try changing the device or channel type from switch to button of visa versa?

No I did not, but you were 100% correct, switching from “switch” to “button” was the clue. It does work now. I’ve seen the option when I was installing the i4 but I didn’t get the difference between them. Afterwards it’s always clear ;-). Thanks a lot and I really appreciate your work!

Hi,

If this has been solved before, please point me in the right direction.

Shelly has once turned the output off (slått av) by itself, when it should have been on.
The state of it was on and should have been on until my flow set’s it to off.

This could be a problem for me and I need to understand why this happened.

You can see the rest of the time it is acting as it should and does what the flow says.

image

Tried searching but could not get a clear answer.
Looking to buy Shelly plug S to keep track of consumed energy. Can anyone please confirm if the Shelly plug S reports power usage accurate to homey. Preferably with usage of KWH per day?

It does