[APP][Pro&Cloud] Shelly

Homey Pro (Early 2019) v7.2.0

Pairing finds all plug s devices, I choose the one I want to pair, choose default icon and then I get Error: not aupported

Have rebooted Homey

This can not be the exact error. I need it letter by letter.

I get a popup saying… Error: Not supported

Nice, never seen that before and it’s not coming from the Shelly app. This is something you should report to Athom support. Perhaps they can identify the issue. Feel free to send me a diagnostic report though. Perhaps it contains something useful.

Diagnostics: 9b143891-4ab4-443b-bd91-474631a2aef5

Anyone else having issues with Shelly Plugs?

I have a bunch of them and they all stopped responding to on/off commands a few days ago

Problem seems to be solved :open_mouth:

I updated Homey to latest version (8 something) and now all seems well

Hmmm, I probably know why. The error shown by Athom is not very descriptive in indentifying this though. But I’ll add a version constraint with the next update to avoid this for other people not on the latest version of Homey firmware.

I have around 30 mixed Shelly units and a homey Pro that been working flawless about one year. After the big update when they nearly not been working at all. Some Dimmer 2 seem to work fine bu most of the 1L, 3EM and PlugS can read all values but can’t be controlled from homey. Tried replacing them with the new module. Before 8.0.5 they did not work at all. After 8.0.5 they working sometimes. Often not after a restart but then I open the Shelly app, turn them off and on, then it works. But most of the PlugS, one 1L and one Dimmer 2 cant be added with the message below.

ID for error report: b7ecc6f3-0f46-4af2-bcd7-43fca4f236d6

All are working perfect from Shelly app and web interface. Latest firmware. Eco mode is disabled and they are mounted around 3-6m from the AP.

Can you point me in any direction of what I could try?



Next problem


These are networking issues. Out of my hands. Homeys networking stack is just flaky at times. Rebooting Homey seems to help.

This error originates in the oath2 authentication module from Athom. Restarting the app will probably fix it but I’m not sure if that’s possible on cloud. You could force this by installing the test version of the app (and go back to the live version). You are aware the Homey Cloud is still beta and issues like this can occur right.

As I said they been working flawless for one year and no problem at all from web interface or Shelly app. So must be something with the homey? Tried rebooting about 100 times the last two weeks…
I have no idea what I could try more.

I know this is not a question for you, but will we ever see the end of the beta?

I dont know either. You could try the networking troubleshoot guide from the first post and see if you can identify what’s going on.

Cant tell, I still get lots of crash reports all caused by Homey Cloud and not my app. It seems Athom still needs needs to do a lot of work to make it truly stable.

(post deleted by author)

(post deleted by author)

(post deleted by author)


Having some trouble with the new driver. I have got a lot of shellys and they have all been added using the old individual unit drivers. When I removed one of my shelly plugs and tried to add it again using the new driver get stuck. First I get a loooong list of all the shelly units I already have in homey with no way of telling them apart. When I just take the first unit in the list, I get the following error:

Any help appreciated!

And here is the list of devices. Not easy to know what is what.

That doesn’t look good indeed. It should be a list with devices model with IP addresses. The fact that it’s not is related to that error but I’m not sure yet what is causing it. On what version your Homey and what version of the app are you using?

Another thing to try is install the test version of the app (version 3.11.2) and send me a diagnostic report after trying to pair your devices.

I just started 2 “shelly plus 1” buy in May. That communicates perfectly with homey. But I find that these devices are in alarm “This type of device may not be supported in the future” is this really the case?. Best regards