Add Z-Wave device non-secure?

Do you mean that it is possible with the official Fibaro app by adding the Walli device?

In this way I include the Fibaro Motion Sensor (Z-Wave Plus) unsecure instead of secure: :grinning:
But not by adding Walli Device, only selected the Walli Device.

The result if you select the Fibaro Motion Sensor:

And here the result if you select the Fibaro Walli Switch:


Please keep in mind, the apps original developer has tested the device to work properly based on the released settings. In this was you are overriding one of the main Z-wave settings and potentially the devices behavior…

This seems to be the BEST WORKAROUND for this problem, thanks for sharing! :smile: :+1:

1 Like

It’s a bit of a long-shot since your post about the secure/insecure z-wave devices is a year old, but I give it a go!
I struggled a lot with the secure pairing option since it gave a lot of network traffic leading to unreliable devices. Pairing all devices not-secure fixed that for the most part.
Now I get to the point, only two devices that are still secure are my two Danalocks. The trouble is that they work véry unreliable on Z-wave.
Practically all devices have an error-rate of 0% to 2%, but the Danalocks are at 9% and 11%! This means that roughly 1 in every 10 commands are not received by the lock. For a light that could be “ok”, but for a lock that’s problematic!! I invested in these locks to:
A. Don’t take a key with me when I leave the house
B. Never forget to close a door since they’ll close automatically both at night or when everybody’s gone.

I should be able to trust Homey/Danalock to lock my door every time Not ‘every now and then’. I’m pretty convinced that this problem comes with the secure pairing!
How are your experiences with these locks? Especially with their reliability.

Thanks a lot!

Does this trick also work with the Dimmer2?

It works with all Z-Wave devices as long unsecure is supported by the device itself.

Three questions:

  1. Is it possible to change this from secure to non-secure? (My guess is “no”)
  2. If the above is indeed no, is there any easy way to remove and then re-add with the new files?
  3. Will the modified apps still receive updates when the developer make changes? (My guess is “no”)


No need for adapted app. Just uninstall your (Fibaro) device and then re-add as a Walli Switch. It automatically changes to the correct device, but then insecure.

I tried this with one of my qubino devices today, but it seems it doesn’t work for those. Either the new beta version of homey isn’t fooled by it or the qubino doesn’t function as non-secure.

This method still works even on 5.0.1 FW. It’s works with ALL z-wave devices.
You doing something wrong.

Just wanted to add that this worked for me too today. After doing some last migrations from Fibaro HC2 to Homey, i had some associations issues. After the workaround, Dimmer 2 was added un-secure and associations worked as they should.

My case was with Fibaro Dimmer 2 and Wall-C (ZME_WALLC-S)

Fibaro app v.3.0.14
Z-Wave.Me v.0.4.2
Homey v.6.1.0

Unfortunately the “add as Walli” trick no longer works with V7 firmware. Does anyone know of a device that adds the proper flag to disable S2 security?

If I understand it correctly, it‘s only possible with Authenticated S2 devices when you enter the pin 00000 instead of the original pin.
I didn’t tried it myself yet.

1 Like

I wasn’t asked for a pin: the pairing process on the outside was exactly the same as before and the developer page shows S2 (unauthenticated).

This was an information from @Caseda on Slack:

Crisis as my whole network is unsecure due to use of associations…

Apps have been totally rewritten I noticed before they all seemed to diasppear from Github.

Includesecure=false isn`t working with CLI installed apps either.

Can confirm that devices that ask for DSK, you can just enter 00000 (at least tested on one device)

I put in a feature request for [REQUEST] User selectable Z-wave security levels in order for associations to work, hopefully if more people like it Athom will take notice. Any attempts I tried to create Walli like workaround have failed so far. Seems there is no flag to prevent S2 security for newly paired devices.


For devices that ask a pin, enter 00000 for unsecure. For devices that do not: there is now a new solution:

1 Like

I have a Homey controlled by Google Home and especially controlling grouped devices are causing problems where I have to retry on/off commands several times.. .