Add Z-Wave device non-secure?

No need for adapted app. Just uninstall your (Fibaro) device and then re-add as a Walli Switch. It automatically changes to the correct device, but then insecure.

I tried this with one of my qubino devices today, but it seems it doesn’t work for those. Either the new beta version of homey isn’t fooled by it or the qubino doesn’t function as non-secure.

This method still works even on 5.0.1 FW. It’s works with ALL z-wave devices.
You doing something wrong.

Just wanted to add that this worked for me too today. After doing some last migrations from Fibaro HC2 to Homey, i had some associations issues. After the workaround, Dimmer 2 was added un-secure and associations worked as they should.

My case was with Fibaro Dimmer 2 and Wall-C (ZME_WALLC-S)

Fibaro app v.3.0.14
Z-Wave.Me v.0.4.2
Homey v.6.1.0

Unfortunately the “add as Walli” trick no longer works with V7 firmware. Does anyone know of a device that adds the proper flag to disable S2 security?

If I understand it correctly, it‘s only possible with Authenticated S2 devices when you enter the pin 00000 instead of the original pin.
I didn’t tried it myself yet.

1 Like

I wasn’t asked for a pin: the pairing process on the outside was exactly the same as before and the developer page shows S2 (unauthenticated).

This was an information from @Caseda on Slack:

Crisis as my whole network is unsecure due to use of associations…

Apps have been totally rewritten I noticed before they all seemed to diasppear from Github.

Includesecure=false isn`t working with CLI installed apps either.

Can confirm that devices that ask for DSK, you can just enter 00000 (at least tested on one device)

I put in a feature request for [REQUEST] User selectable Z-wave security levels in order for associations to work, hopefully if more people like it Athom will take notice. Any attempts I tried to create Walli like workaround have failed so far. Seems there is no flag to prevent S2 security for newly paired devices.


For devices that ask a pin, enter 00000 for unsecure. For devices that do not: there is now a new solution:

1 Like

I have a Homey controlled by Google Home and especially controlling grouped devices are causing problems where I have to retry on/off commands several times.. .