Add Z-Wave device non-secure?

Like Caseda says, there should be explained in the manual how to do that.
With Aeotec f.i. you can press the device button a 2nd time after you pressed it for including. The 2nd press will force adding it secure.

Curious where you got that information from.
If a device is secure (and the controller can handle it) it will include secure no matter what, this is one of the rules the zwave alliance put into the secure protocol.
You can only “force” unsecure inclusion.

From my experience the thermostat plays along with what the controller says.

Ex 1: FutureHome (Norwegian) zwave hub, included secure with pin code on the thermostat typed in the app for this controller. Everything ok for 24h, then thermostat lost connection with hub.

Ex 2: FutureHome (Norwegian) zwave hub, included NON-secure with the thermostat. Everything ok for several weeks (until I bought Homey Pro).

Ex 3: Homey Pro zwave hub, included secure withOUT pin code, I belive the thermostat told the Homey the twin, I did not type anything. Everything ok for 12-36h, then thermostat lost connection with hub.

Homey does not support security v2 fully yet (the code you are referring to), so it is included as partial security v2 (acts then as security v1).

But as explained before, if is it not in the manual of the device (like aeotec has 2 different amount of z-button pushes to include either secure or unsecure), you will have to contact athom to ask for that feature so homey then forces the inclusion of the device as unsecure.
Or let them fix the issue of losing the connection after some time.

You’re right, I meant with Aeotec, not Fibaro. Mixed some things up.
But it is like i mentioned, 1 press for non-secure (standard), 2 press for secure.

I just downloaded the Telldus app from GitHub and added "includeSecure": false, and insalled the app with CLI.
So now my Telldus Mini plugs are non secure. Will see if I can do the same with the Fibaro app. I have one plug and one Dimmer 2.

These devices are both a Telldus Mini plugs. I have only readded one of them.

Did the same thing with the Fibaro app. Now I only have my Danalock as secure, which also should be secure. :slight_smile:


Where should that be added? Maybe i will try to do this with my V2 Coolcam plugs. The new versions automatically add as secure and i don’t want that…

I have added the line above the


It seems to vary in what file that line is from app to app.

Should be in the Z-wave object; position is not relevant. Have updated the Heatit app to resolve the issues with S2 security…

Ok. I looked how Athom did it for sensors in their Fibaro app. Guess that if you have devices that should be added as secure and non secure you have to add the line for each different device?
I don’t know much about this so please, be gentle in your reply if I’m wrong. :wink:

Thank you so much. After doing this for the FGT-001 (Fibaro Heat Controlers) they finally stay online. While included as secure device they would go offline all the time. Now when I added them as unsecure devices they work as they should.

I tried this “trick” in the Neo Coolcam app and it works fine. Now the new V2 plugs are added as unsecured instead of secure. They are much more reliable now and generate way less communication.

In the file app.json I added ““includeSecure”: false,” under the the “id”: “NAS-WR01ZE”, section just before the line with “learnmode”:

1 Like

How you do non secure with these?

Do anyone have an instruction on how to modify fx the Telldus app to accept non secure communications?
I am not a programmer and know very little about CLI… :slight_smile:

  1. Go to GitHub and download the project (Clone or download -> Download ZIP).

  2. Unzip the downloaded project and open app.json in a text editor. I use Atom.

  3. At line 481, add "includeSecure": false,.

  4. For the installation of your modification, follow the excellent guide from @HansieNL.

Good luck and ask if you need/want more info.

EDIT This instructions is for the Telldus mini. If you need to include another device as non secure, make the modification in the same file but in the section in the file for that specific device.


Fantastic, thank you very much! I will definitively give it a go…
Anyone else experiencing problems same as mine?
I have a Homey controlled by Google Home and especially controlling grouped devices are causing problems where I have to retry on/off commands several times.
Maybe I am wrong assuming the root problem is because of the secure option for my devices?

I can not really follow the discussion Secure / Unsecure!

Does that mean the homey has problems with secure included devices? Half of my 90 Z-Wave devices are secure!

But I can not find any problems?

If you don’t have/experience any problems, do nothing then. :slight_smile:

I done this to the fibaro app, installed fine. Now trying with Robb smart, getting this error. Just added the unsecure add to z-wave products of course. Anyone understands why?

C:\Users\Ryv\Downloads\nl.ROBBshop.ROBB-smarrt-master\nl.ROBBshop.ROBB-smarrt-master>homey app install
✓ Pre-processing app…
Error in app.json:
SyntaxError: Unexpected token � in JSON at position 22665

edit: Same error with me.zwave app. In fibaro I put it in before “learnmode”, some other explanation where it should be put if that is the problem?