Xiaomi Mi Roborock S50 vacuum cleaner token

That’s great. Thanks for your response.

I use Roomba and solved such a problem with reinstalling the application.

Thx jolerius! Awesome app, I got the token in no time at all. =)

The link cannot be opened. is it a guide or apk file?

Its a google drive link. Maybe u have to have a google account

Tack ändå. Det löste sig. Hittade en annan modifierad APK och fick fram token.

Med vänlig hälsning

I’m thinking of buying a roborock s50/s55. Does it still work with Homey 2.0?

Modified app to find the token:

You do not need to be on the “china mainland” server.

1 Like

Thanks @Jan_Peeters! Very easy with the app!

I hope to receive my S50 this week. I believe you guys are users

What would you recommend, after receiving my robot:
First have it connected with the standard Xiaomi App, so I can get used to it?
Or, just get the token with the modified app (great!) and connect it to Homey?


If You are not in a hurry to get it connected to Homey, just start using it with the standard app. Figure out the Home automation stuff later.

1 Like

Thanks @MbenzNo !

I am a Roborock user too, and very happy with the cleaner. Also connected to Homey, but actualy I don’t have any flows yet for it. Has anyone a good user case what to automate?

-edit- we have cats, so I don’t want the Roborock drive around when we are not home. (search on youtub for ‘roomba dog poop’ and you understand why)

Return to dock when bot is cleaning and somebody comes home.

Start cleaning as soon as the house is not occupied

When does the token change? I added the modified app to phone A (my old phone), added it to Homey with the token I got from the app. Tested it from Homey and it worked like a charm. Then I added the Mi Home app to my other phone and now Homey does not see it anymore.

How do I use the official (and thus updatable) app AND connect the Roborock to Homey? It’s a pretty nifty device, the vacuum, cleans better than I had expected.

Edit: according to this, the token should be readable in a logfile using the original android app. I haven’t been able to find a folder named Smarthome on my phone though.

Edit 2: reinstalled the modified apk tp check the token, it’s still the same, but when I try to connect Homey it says " device might be destroyed :rofl:
I just restarted the Mi Home app on Homey and now I was able to connect the Roborock again.

Check the ip-adress of the vacuum. Mine sometimes changes IP.

Continuing the discussion from Xiaomi Mi Roborock S50 vacuum cleaner token:

web based https://account.xiaomi.com
under personal info go to personal data rights
request personal data file
a few days later you will receive in your mailbox a message with a zip file

Dear Customer,

Your personal data file of Smart Home is ready. Please find the attachment in this email.

For security reasons, the file is encrypted. You will receive the key in another email, Subject: Important information from Xiaomi. Please check your inbox later.

Xiaomi Security and Privacy Committee

The zip file contains the token and mac of all your registered products (in my case Robovac and all my Yeelights) file sg_user_device_data (sg if your on Singapore server)

1 Like

Pretty cool, I’ll test this and if it works I’ll add it as one of the options for retrieving the token.

So, it took me quite a while last weekend to figure this out, while the solution can actually be REALLY simple when using an Android device:

Step 1: Download version 5.4.49 of the Mi Home app from an APK mirror site and install on your phone
Step 2: Login, select server (whatever you like, EU also works) and add the S50 to your account
Step 3: Using a file browser on your device, go to the SmartHome/logs/plug_DeviceManager folder and open the TXT file
Step 4: Look for the token in that file, it’s somewhere at the bottom
Step 5: Do your thing on Homey to ensure the token you extracted works/is correct
Step 6: Upgrade the Mi Home app to the latest version