Tuya has officially joined the “Talks With Homey” program

YW.
I found it already, but I just never opened that screen apparently :grimacing:

Did you try the workaround anyways (it’s free of charge :crazy_face: )?

Apparently no…

Tried ‘Switch region’?

yes, but China doesn’t work, and I’m pretty sure I’m on international…

I never saw that screen. No you’d not select China. Is International the only other option?
I’d also recommend to file an issue @ https://github.com/athombv/com.tuya/issues/new

Peter,

It is precisely with the commands below that things go wrong:

I can log in to Homey:

But when I then try to execute the commands below, I only get error messages. Apparently my knowledge is too limited and something else needs to be done, but I have no idea how.

I’ve tried different ways, but I only get error messages. I also tried installing the app from a local directory, but this won’t work either.

With regard,

Ron Moné

Verzonden: maandag 8 juli 2024 19:53





|

Peter_Kawa Regular
July 8

|

  • | - |

Ron,

Create a new issue here (one for each device seems logical)

Peter_Kawa:

Issues can be reported here: https://github.com/athombv/com.tuya/issues

There’s a guide present in the new issue template

I’ll quote it here fyc:

To request a new device, please run the Tuya app locally using Homey CLI.

$ git clone [git@github.com:athombv/com.tuya.git](mailto:git@github.com:athombv/com.tuya.git)
$ cd com.tuya
$ homey app run 

Then pair a ‘Light’, even if your device is not a light. Watch the logging closely for Device: and copy-paste the JSON in this issue.

Without this information, we cannot add support for your device, and the issue will be closed.

For example:

2024-06-06T14:11:59.852Z [log] [Homey:xxxxxx] [ManagerDrivers] [Driver:light] Device: {"active_time":1717491339,"biz_type":0,"category":"dj","create_time":1717491339,"icon":"smart/icon/bay1582725542891RIK5/42feb5d93f5e13800cf2ade23ea49459.png","id":"xxxxxx","ip":"xxxxxx","lat":"52.25","local_key":"xxxxx","lon":"6.3","model":"SH.63.204","name":"G95 Gold","online":true,"owner_id":"xxxxx","product_id":"xxxxxx","product_name":"G95 Gold","status":[{"code":"switch_led","value":true},{"code":"work_mode","value":"white"},{"code":"bright_value_v2","value":223},{"code":"temp_value_v2","value":0},{"code":"scene_data_v2","value":"{\"scene_num\":1,\"scene_units\":[{\"bright\":200,\"h\":0,\"s\":0,\"temperature\":0,\"unit_change_mode\":\"static\",\"unit_gradient_duration\":13,\"unit_switch_duration\":14,\"v\":0}]}"},{"code":"countdown_1","value":0},{"code":"control_data","value":""},{"code":"remote_switch","value":true}],"sub":false,"time_zone":"+02:00","uid":"xxxxxx","update_time":1717671377,"uuid":"xxxxxx"}

Finally, please link to more information about the device, e.g. the manufacturer’s website.

You can also download the app

  • Direct Link here

  • Unzip the downloaded zip file

  • then open a cmd screen and change directory to the unpacked tuya.com-master directory
    cd /path/to/tuya.com-master

  • And then:
    homey app run

Will energy consumption being added for Smartplugs? This is visible in my Tuya app, but not in this app.

Should be available in the first stable release :wink:

1 Like

Is there any way to change the setting in the cloud project that is created when linking the tuya account? I have an aircon which gives me some options for flows when used a “other” device.
But it´s missing a few. I have my own project for the tuya cloud app and in the project I can change the settings for the device in the Configure Control Instruction Mode to be DP Instruction which gives me all options available…

Already running 1.0 stable version but no energy consumption visible. I will try again installing this version again as I installed it directly and did not remove the testversion first. Maybe something is going wrong here. Thanks for the update!

In my case after installing 1.0 a lot wasn’t responding. Restarted the Homey and everything seems to be fine.

Using stable 1.0
Cannot authentify when trying to add device when you are supposed to open the authentication for Tuya api
Get the message : {“success”:false,“message”:“OAuth2 Session Already Used”}

Will there also be coming support for roller blinds / curtains motors like a roller shutter Roller shutter with string

I get a similar message @Christopher_Charpent when using “my.homey.app”:

image

When using the mobile app, I log-in and agree to the terms to share information with Homey, it says I can close the window and the app still “spins the wheel” for Log-in to Tuya.

As a information, i use Smartlife.

@Doekse , there has to be a bug somewhere. I have tried on the latest “experimental” and now the “Stable” 1.0.0, same experience.

1 Like

Had the exact same problem

I’m also having problems logging in.
with the Android app I am able to connect to Smart Life and receive messages now you can close this window, but if I close the browser the app remains waiting for the connection. if I use the browser app I get the message that something went wrong and that’s it. Anyone have any suggestions? I tried with different browsers, in private mode and not, but nothing changes

I had the same issue. A reboot of the Tuya app solved it.

I have tried reboot of both the app and Homey, before I made the post.

Update: still not visible at my side. Anybody else where this is working?