Ring image grabber problem

hello i have a problem with the ring doorbell app v2.1.1.
if I use the Ring image grabber trigger and action card I get an error message
( invalid_response 401 {“error”:“not authorized”} )
what am i doing wrong i have purchased a ring protection plan.
my homey software version is 2.4.0-rc3

Just a few seconds search would have you give the answer.

Its not possible at this moment and not sure it ever wil be possible.

Also i believe read something in the past (months) on slack that athom had contact with them. But not 100% sure

I have a Ring Pro and have the same error

So what does this mean:

Changelog 2.1.1:

  • Ring grabber bugfixes

Changelog 2.1.0:

  • Added Ring image grabber trigger and action card

Well it looks like they blocked the API: https://github.com/denniedegroot/com.ring/issues/18

BUT there is a fix:

It seems they just found out a few hours ago on how the pictures are being made available after the ring change a few months ago


On the bottom they are now able to grab the pictures

Good find, if it really could work. But did you contact the devolper of the ring app with the info you just found

I thought the original developer has abandoned the project, or at least, he wasn’t using Homey anymore, or didn’t own a Ring device anymore.

This is very unfortunate because I really like both homey and ring, also bought a Ring device with lights and alarm, but this isn’t supported by the Ring app on homey. Hopefully someone else can fork the app, but wouldn’t know how to get this going.

So can we (or I) take over the project so we create a new package? Not sure how many people are waiting for this…


I really would like you to do so, but I don’t know how that could happen. Maybe e-mail him through git?
If there is something new, we could install it through CLI as long als he doens’t reply or push it to the app store.

I can clone the repository and start with that I guess. Only problem is time and currently on vacation after that I will have a look.


No worries, there is no real pressure on my side besides wanting to take full advantage of the product. Could also send you a few beers to express my appreciation.

I would love an update! I can also pay with alcohol to show my eternal gratitude

1 Like

Just wondering if this is still being worked on

Still want to, but no time. I can just clone it (the repository) and make adjustments but I can’t make it available in the store because I am not the owner. The only option could be you install it manually through the CLI. But long story short there is not newer version yet.

That’s no problem, installing is easy through cli :wink:

I hope you’ll find the time, it would make some of us very happy :blush:

And installing through the CLI isn’t a problem, and after it works maybe you can publish it as a spinoff of the original


I think @denniedegroot is happy to receive a Pull Request on Github and will merge it so het can publish it to the app store.

Ofcourse I will gladly receive a pull request and merge it.

As for the inactivity, here are some reasons:

  • I don’t own any Ring device anymore so I can’t test anything. (Still looking for testers for my battery fix…)
  • Ring keeps changing their API, this is really annoying because you have to reverse engineer everything.
  • Some community members have expressed the non working image grabber in such a way that I completly lost interest to implement this currently.

To bad you don’t own a Ring anymore, I’m still very happy with it (it’s a Pro though, so no battery to test your fix). It’s indeed a pain in the ass they keep changing the API, I’m still happy with the work you did in the past and glad you didn’t abandon the app.
And I understand the frustration you have with users who think it is their right to get support for a free app someone developed in their spare time, I’ve had my share of them too :frowning: It almost made me stop working on Heimdall and homeydash.com at one point but decided I didn’t want to let those F*ckrs spoil it for the rest who do appreciate the effort.


Own two Ring devices, but none with battery, so can’t test that. The ring pro does however report a battery even though it is connected with a wire. What is it you need to test with it?

Changing API’s is super annoying… but unfortunately lot’s of companies do that, but still I get your frustration.

It would be great if this could be updated, I have the Wired ring stick up cam so cannot test the battery either.

All work very much appreciated