Ring Doorbell and Camera support for Homey

For me, there is no difference. My HP2023 is not restarting automaticly. I tried both, restart the HP after failing notifications (no difference).
When after reauthentication the notifications stopped again, my HP was running several days. I can’t find any trigger yet…

1 Like

No, I haven’t been rebooting regularly, and not in the last week.

Hi @DaneedeKruyff i am using Ring app since quite some time.
I have the app also involved in one of my flows so that when someone rings my doorbell my sonos reproduces a sound together with my alexa speakers.
When i test the flow in homey, the sonos speakers and alexa speakers both work and reproduce expected sounds. however, when i actually ring my doorbell only my alexa devices reproduce sounds and noting comes out of the sonos one.
Any advice you could kindly give me to resolve this issue? Thanks
This is the flow

Did you already try to add an error notification (the bottom of the card) to the Sonos card?

Hi @DidierVU I think i added an error card (which i guess it is a card that it is triggered in case the main card goes to error)…as per picture.
When i triggered the door bell i did not get any error notification

This seems to suggest that the sonos card is not in error…i think!

Just as an update to this one.
I tried to have the lights blinking too by removing the Date & Time card and the lights do not blink.
Basically this all flow does not work anymore and the reason why I hear Alexa is only because Alexa is connected to Ring via Alexa app and it is used as a chime to Ring…other than that nothing on this flow is working.

Apparently the Ring app stopped working 2 days ago as per screenshot and no other flow based on any other ring device i have at home works.

I have also already restarted both Homey and the Ring app several times and revocked and re-granted access to ring app.

The Ring devices in Homey all appear to be responsive but actually they do not work in flows.

Is someone able to help? Thanks

Unfortunately Ring has made a, for now unknown, change to how their API works.
Please read this post: Ring Doorbell and Camera support for Homey - #98 by DaneedeKruyff

The developers of the ring-client-api which the Ring Doorbell and Camera app for Homey uses, are aware and looking into creating a fix.

Ring offers no support for third party integrations, so it’s impossible to say when this is fixed.

Great thanks, i tried your steps and now it is working again!
Let’s see for how long it will last but I also would like to take this chance to thank you and your team for all the incredible work you do on this app!!! SUPER APPRECIATED!

Looking forward to the final fix. We will stay in touch!!

1 Like

Thank you, but there’s no team behind me :wink: the ring-client-api is a node module that’s developed by others and is available for everyone to use. I just integrated it in the Ring app for Homey because maintaining the code that was previously used to communicate with the Ring API was to much work to maintain.

1 Like

For everybody that is (or was) experiencing the problem that notifications stop working, can you please answer these questions:
(please send me a PM with the answers)

  1. When did you first notice the problem?
  2. Did you remove the devices at Ring* and re-authenticate, if so, did this work and for how long?
  3. What devices do you have?
  4. What region/country are you located in?
  5. Do you have a Ring subscription?

* please see:

Unfortunately the creaters of the ring-client-api are not experiencing these problems so it’s very hard for them to troubleshoot. Your answers to these questions will help pinpointing the cause of the problems.

1: about 3 weekse ago
2: yes. It worked for about one day
3: Ring pro 2
4: Netherlands
5: yes, at the moment trial subscription

  1. One week ago
  2. I followed your steps and it worked for half day and then stopped working again
  3. I have a ring doorbell pro 2 and 3 indoor cam (all wired)
  4. I am located in Germany/Europe
  5. I have a ring subscription

It looks like there’s a fix for the problems with the notifications. It’s currently being tested by other users of the ring-client-api.
Unfortunately I can’t test it with the Ring Doorbell and Cameras App because I’m on vacation.
I’ll keep following the issue on Github and keep you informed.
For users that are interested, it’s this this topic: Push notifications stop after ~24 hours · Issue #1218 · dgreif/ring · GitHub


Great news - please keep up posted!! Thanks a lot

Hi there, I just recently bought a Ring Chime (2nd gen) to connect to homey, mainly to receive a sound notification when my Aqara door sensor is triggered. The flow card of play sound does not seem to work for the Chime.

I,m on the new Homey Pro (2023), is this a known issue and any possible fixes?

Device shows this: (This device has no capabilities)

@DaneedeKruyff looks like when homey reboots it’s stopped working ….

Seen that too, could you please answer these questions

I didn’t notice your post earlier, sorry for that.
The flow should work on Homey Pro Early 2023, at least it worked when I added the option to choose the desired sound on an earlier firmware version. Unfortunately I can’t test it right now.

  • Could you please restart the Ring app, and next run the flow that should ring the Chime.
  • After that please send a Diagnostics Report from the app.
  • Also, please share a screenshot from your flow (easiest to use https://my.homey.app for that)

No problem, I read your on a vacation :slight_smile:

I restarted the app and ran the flow below:

First got the network request failed and then another error showwing: “Object object”

Diagnostic report: 113b13b4-981a-4cbf-a0bb-f7a0441983d3

Hope might see an easy fix, if not enjoy your holiday and let me know afterwards please :sunglasses:

The “Object object” and “Network request failed” have nothing to do with the app, that’s just Homey’s web client, if you force refresh those errors will disappear. (At least for a while).

I can see nothing wrong in the log and that flow also looks fine to me so I’m not sure why it isn’t working for you. I’ve just tested it at my Homey and there it works.

  • How many chimes do you have?
  • Have you set up multiple locations in you Ring account?