Remotec Technology App (v.2.2.4)

Hi Ted,

The thermostat is available in EU, US and AU versions.

I do appreciate that you have time constraints though. Hopefully someone can get this going.

Thanks

Luke

Hi,

I would say ZXT-120 works perfectly. My AC though have 4 levels of Fan speed (Quite, Low, Medium, High). By default ZXT-120 allows me to start L,M or H. Is it possible to configure an additional level that I can control through the device?

Best Regards,
Vladimir

Hello,

I am a new user of Homey (migrated from Vera).

I managed to connect ZXT-120 to Homey, but my AC unit is not supported out of the box.

Therefore I need to “teach” ZXT some basic commands through “learning” process and, unfortunately, I cannot figure out how to do it in a Homey app.

I did learning on Vera, so, in principle, I know what the manual says about it. But I cannot find a way on Homey to initiate and support the learning process.

Can somebody help?

@Myk I have never had to teach IR codes as I was lucky enough to have my aircon listed in the manual.

It should be possible to do this in Homey by writing into the “raw configuration parameters”.
On your ZXT-120 icon, click the spanner (up right corner) and then expand the “Raw Configuration Parameters”. You have to write ID,SIZE,VALUE; where ID=parameter, SIZE= size in bytes and VALUE=parameter value. (don’t forget the commas and no spaces)
Then look in the manual and enter the desired parameter and value.
For example the first step is to have the ZXT-120 enter the learning mode.

Write: 27,1,0 and hit “Save settings”
The manual does not say anything about the SIZE. But it should be 1 byte as I could not see any value bigger than 255.
And so on… write and save.

I would suggest to have the ZXT-120 on USB power while doing this learning.

Let us know how you go.

P.S. You’ve mentioned that you did this in Vera. Then the ZXT-120 should have kept the learned commands. Unless you reset the unit.

Thanks for you advise.

I will try it tonight.

ZXT did not want to connect to Homey until I reset. So, all commands are forgotten.

How did you go with teaching the IR commands?

For the ZXT-120 and ZXT-600 users, please be aware of the following limitation of the 2.0.0 app:

Minor app update uploaded today to the app store, waiting for approval

Hello i have buy this remotec scenemaster zrc-90eu and it Will not include in homey have try with old homey 1.5.13 not working and now try then 2.0 for homey releases not working get ”status cannot destructure properts ’wakeupinterval’ of’ undefined’ or’ ’null’

I have a remotec zr 90. Problem it has many buttons. Tried to solve it this way. Anyone with other ideas for the buttons. So far I like it and wife and children are serious happy with it.

I received a crashlog (unkown from whom), causing a crash of the app trying to use the ‘Set Fan “SWING” mode’ action card. Thanks, this issue has been fixed in v2.2.4.

Just uploaded to the app store (waiting for approval)

Can I add a +1 to this please!!

Sorry, just noticed your question. Actually, I did not manage to teach it on a previous version. But on 2.0, learning works.

I am having an issue with zxt-120 operations.

I am using my AC only for heating. I start it through Homey in “Heat 22C” mode every morning. However, if the current temperature is above 22C, the AC starts cooling instead of just going idle.

The same happens if the ambient temperature goes above 22C over the day, it switches to cooling instead.

This does not happen if I launch using a remote.

The ZXT was programmed using learning procedure, not code library.

Does anyone know how to stop the AC going into the cooling mode and sticking to heat only?

It looks like your Remotec starts the air con into auto-mode.
An air con has usually several modes like cooling, heating, dehumidifier, auto, etc.
When you power on from a remote, that remote sends all the commands at once, for example 22 Celsius, heat, fan low, louver swivel and so on.
You need to get your Remotec to at least send the temperature and the mode, for example 22 and heat. Once this is done, it should not switch to cooling unless told otherwise.

I use my air con for cooling only and here are the THEN cards for one of my flows:

I put few seconds delay in between the operations just for peace of mind.

Hope this helps…

Hi have a question regarding this app and google home integration.

it seems that when you have a google home and you add homey to google homey all devices are also present in google home.
Also the remotec app regarding Airco control.

But there is an issue…

I can set by voice control the temperature but it seems to be impossible to start the airco itself, it only reqonizes the remotec app as a thermostat not as an airco.

Dunno if the app needs to be updated or setting must be changed,

Does anyone have an idea if it is possible to use voice control using google home to control my airco’s using the remotec app?

@B3rt this is an issue within Homey ('s Google Home implementation).

In the Google Home implementation the default capabilities, like target_temperature are linked to the Google home API, in such a way that when you talk to Google to set the right temperature, the Google command is translated back to the command needed to change the device’s setpoint…

This is working when for the devices the default capabilities are used. BTW this also holds for Alexa and Apple homekit implementation.

For setting the thermostat mode (including on / off), this does not work since the default thermostat_mode capability is not supporting all required options for the device. Since we as developers can’t overrule / extend the different modes (requested by many developers), we are forced to create a custom capability… which is not linked in the Google Home / Alexa / Apple Homekit implementation.

Athom (@weejewel) is aware of this issue, but it would help if you could file an issue report on the Google Home implementation to raise this topic on Athom’s agenda.

To contain this issue, you could check to create a virtual thermostat / device which will be linked to the Remotec thermostat.

@TedTolboom thx.

I will contact athom for this and try the suggested virtual thermostat option.

Does anyone have an idea how i can turn off the airco using google home?

I installed virtual rhermostat and linked it to the remotec device, added a command if temp is set the airco should be set to the correct mode, this works fine.

But was thinking how do i turn it off?

Hi @B3rt, use a virtual switch (there an experiment of homey, so need to be switched on in the settings first) then add an virtual switch and make a flow when this switch is triggerd to fire up the AC. switches are supported bij Google Home intergration of homey so you will be able to tell google turn on the airco (airco is the virtual switch its name)