Problem with Sonos after upgrade to 6.2.1

I did get an upgrade of Sonos app to 6.2.1 yesterday.
After that i cant control Sonos .
Som actions in my flow are ok when testing (volume up/down), but most is failing
When trying to turn on / off I get “ERROR_RESOURCE_GONE”

Anyone else with same problems?

2 Likes

Contact the developer, support info (if provided for) is present at the bottom of the app page

.
It has occorred before, maybe a solution is present in the search results

1 Like

I had to reconnect to the sonos favorites in the flows , I use the radio stations in favorites. Did not see the errors, have the old S1 still.

Remove all the SONOS and re-add them and setup your flows again, this is the only way I had the same issue.

same here, ended up removing the sonos app and unlinking it too… then started again… i only have 9 units…

Did you all contact Athom? Because it seems definitely to be a bug in the new app version. I‘m still on v6.1.3.

No Athom is not doing anything on these issues, multiple times reported issues always resolved them myself.

Running 6.2.1 > All works fine. No Problems. Only made Update.

I asked on Slack, but no news until now. So I’m still on 6.1.3 because I don’t want to repair all the flows.

1 Like

Same problem here, already removed the app and reinstalled it, no luck. I’m also able to control the volume but can’t start a Sonos favorite (Error_recource_gone)

I did remove the players for SONOS S1, and nowonly control S2, that works.
It seems like the mix for S1 and S2 created some issues.

I’m on 6.2.1 with S1 devices only. No problems at all!

Maybe it could be the mix S1/S2

@Ernst and @Henning_Lensberg, would you please contact support?
I have not received any further information from Athom.

I have been in contact with support, they was not able to help!

1 Like

I disconnected my S1 device like @lenning_lensberg suggested. After that I reinstalled the Sonos App on my Homey and everything works again. I haven’t tried to add my S1 device to Homey but it is working through the S1 app

Because the problems seem to occur only with S1 speakers, but I have only S2 speakers, I just installed the version v6.2.1. Everything worked without any problems.

Any updates? I have s1 and s2, on the latest Sonos verspin and want to update Homey to newest firmware.