Philips Air Purifiers & Humidifier app

ok , let me check that on my 2019 one. 5680 version. But I guess you set it 1st to manually by changing the speed, after that is works. I will check that and maybe making it a 2 step process

Hi Edwin,
thank you for checking. I cannot set it to manual mode in the app, it always returns to the previous mode. Perhaps therein lies the problem?

for my 2019 5680 model it gives me a ping that it worked. I guess they don’t support this and the firmware is different.

yep when I change the speed , it auto sets it to manual from General. Too bad Philips is not really doing updates. . Does it work from the air matters app.

I guess with the 23 version it worked fine.
I have a flow, that checks if my girlfriend is present and sets the Philips to silent mode from the allergic mode. This is not working anymore, I guess it stopped working with the update (or was there a firmware update by Philips?).
Do you have any clue, how to reinstall the old version of the app?
Thank you so much for your support and effort!

that helps, let me check v23 vs now

@Ton_Modderman found the flow issue on coap devices , only activated it for the purifier and not on the combi,

@Xador added manual 1st to the change speed action or flow.

can you test this version https://homey.app/nl-nl/app/com.athom.philipsair/Philips-Air/test/

Hi Edwin,

Thank you, I will try it and report back on Monday.

Have a great weekend!

OK, that’s clear. But is it possible that you can solve the problem on the combi device (2-1)

oh @Ton_Modderman still did not work for you? I added the combi to the flow actions. Let me re-test it.

Hi Edwin,
Sorry, I wasn’t able to test the flow earlier.
But, great news. The action in the flow works perfectly.
Both on the AC2889 AND on the AC3829 (Combi Device)
So thanks for your support

Hi Edwin,
Now this all works for me I have left one suggestion for the next version.
Can you add some other flow actions.

  • Changing the humidity
  • Display mode
    I would be very greatfull
    Thanks

Hi Edwin,

Thank you so much for your great support!!!

I tried the test version at the weekend and today the 26 official release.

The problem is still there (with both versions). The purifier will not change to manual mode via the app (by selecting the purifier mode “manual mode” or trying to change the fan speed). It can only be turned on by pressing the speed mode button at the purifier.

Can you check one last time?

wow, how technical are you .

we can try this to see the error on your console/terminal.

maybe we can install node, install the homey npm see https://apps-sdk-v2.developer.athom.com/tutorial-Getting%20Started.html

download my github repo https://github.com/biemond/com.athom.philipsair
extract and do

  • homey login
  • homey app run from my directory.

you will see all the output

Hi Edwin,

thanks again!!!

I will send you the log tomorrow.

I have an AC2889 Purifier model 2020
Both the App as the (action) Flow works perfectly.
Accordingly the Philips manual the device has 3 Purifier mode: General - Allergen and Bacteria (no manual mode)
But changing the Fan speed change the Purifier to a manual mode. That’s correct because you have manually change the device through changing the Fan Speed (manually on the device self or in the App or in a Flow)
So I have tested both my devices (AC2889 and AC3829, both 2020) and there are no problems.
Maybe the problem is only on a 2019 model.

Hi I got the AC3829/10 model (2019] and added it to my iot wifi network. I can add the ip in the app but when checking it says not able to get shared secret. Do Homey and the Philips unit need to be in the exact same subnet?

Update: selecting purifier 2020 makes it working although the unit shows as AC3829/10 1.4.0

Homey sits in 192.168.1.x and the air unit in 192.168.20.x

Same here , 2019 and I have homey and the air in my iot vlan but I opened http (2019) between these 2 devices, nothing more is required.

So I guess you have the late model of 2019, which use coap on some port. Or you got this coap firmware. keep the 2020 version. I think they switched around nov 2019 or so

Thanks @Edwin_Biemond

Does anyone known which android app comes along with the Philips air.
For Apple it is “Air Matters” but that seems to end up with a deadlink in Google Play store.