NodOn App (Stable: v3.0.1)

NodOn Z-wave app

This app adds support for Z-Wave devices made by NodOn.
NodOn Logo


Athom app-store
Github repository

Supported devices:

NodOn Micro Smart Plug

Micro Smart Plug
A wall plug that can be switch on or off, and measures the power usage of the connected device(s).


  • Turn On / Off
  • Measure Power (Wattage (W))
  • Measure Energie (KiloWatt/hour (kWh))

NodOn Smart Plug

Smart Plug
A wall plug that can switch on or off a big load (3000W), but of course also smaller loads.


  • Turn On / Off

NodOn Octan Remote

Octan Remote
A remote with magnetic holder, with 4 buttons that can activate several scenes and/or devices.


  • Battery Level
  • Scene Triggers:
    • Single Press
    • Double Press
    • Press and Hold (1x or every second)
    • Release Hold
  • Sequences (Software based)

NodOn Soft Remote

Soft Remote
A remote with a (soft) silicon skin that can handle a tumble, with 4 buttons that can activate several scenes and/or devices.


  • Battery Level
  • Scene Triggers:
    • Single Press
    • Double Press
    • Press and Hold (1x or every second)
    • Release Hold
  • Sequences (Software based)

NodOn Wall Switch

Wall Switch
A battery operated wall switch, with 2 switches (and separate up and down directions) that can activate several scenes and/or devices.


  • Battery Level
  • Scene Triggers:
    • Single Press
    • Double Press
    • Press and Hold (1x or every second)
    • Release Hold
  • Sequences (Software based)

Supported Languages:

  • English
  • Dutch (Nederlands)


Any requests or questions you can contact me on this Forum or on Slack
If possible, please report issues on Github.


The 2 remotes and wall switch offer the ability to create sequences of the button presses.
This means the amount of different triggers you can have is theoratically infinite.
This is software based, so the longer the sequence, the more prone it is to not trigger that particular flow (Homey might miss a button press).
You can create a sequence in the flow card by chaining the button numbers (left to right, top to bottom) with a comma ( , ) or semicolon ( ; ) in between the buttons.
Example: 1,3 for the sequence top left, then bottom left.


v3.0.1 (stable):

  • Re-write to SDKv3
  • Additional changes:
    • Changed the “hold” trigger to every second, instead of 5 times a second to keep Homey from disabling that flow card immediately
    • Updated all icons to be more clear
    • Added a Reset Meter maintenance action
    • Updated all images to make them more consistent
    • Minor stability improvements


  • Add battery types to the appropriate battery devices.


  • Fix the app crashing when triggering on “power lost”.
  • Fix all icons not showing in the app.
  • Update meshdriver


  • Visual improvements for Homey V2 (still need to do icons) - Update meshdriver


This app add only Z-wave devices, and not any of the other wireless technologies like EnOcean.


If you appreciate this app, contribute to future development by making a paypal contribution

1 Like

Thanks for the app! It worked great until recently. My Octan remote stopped working. Unpaired and uninstalled the app, but now I am unable to add the remote to homey. It says “identified as a controller” and then “Something went wrong”.

did you check your battery level?

Had the same last week, 3 new wall switches. first 2 no problem, the 3 one keeps given the same result as @Thomas mention. Identified as controller, and then something went wrong. After 5/6 time removing it and adding again it worked.

Thanks for the reply. Will check the battery and report back.

4 posts were split to a new topic: Which device to use for zwave range extention

Had today a nodon wall switch doing nothing any more. Battery checked with multimeter, is stil full. Removed it from homey. Resulting in a unknown node. No remove option (guess the known bug)

Try to add it again, but never got the swich in inclution mode again. (Switch 1 and 2 , and the short 1) not working. Its working when doing switch 1 and 2, and then shortly 3.

Homey says find node and then something wrong. Going to zwave settings remove device… not working as it should. Its say removed when 1 and 2 at the same time, and short switch 3.

Tried a couple of times but got now 3 unknown nodes.

@Caseda ever heard of this?

Stil on homey 1.5

i don’t even know what the 1+2 hold then press 3 does as that isn’t in the manual.
try resetting the device internally and try again, might be that your device just died.

Edit: just found out what it does (just sending the NIF), but that won’t include the device in homey though.

Thks for fast answer. I already did reset everything, nothing works. leave the battery out for the night and try again tommorow. But think you right that the device good be broken. Already send a mail to the shop. Its just a month old.

Include a new one and no problems so must be the device its self

thks again

Solved :arrow_up::arrow_up::arrow_up: bit suprissed but its was a battery isseu, did test it with a multimeter (2.85 v) tought that was good. Leave bat out 24h and tried again. Today its was start including but then it not going further in the procces, so came to conclussion maybe i was wrong, so did changed it and yup no problems​:smiley::ok_hand:

1 Like

You were right. Had to change the battery. It now works as expected. Thsnk you!

1 Like

I have 2 Nodon Z-wave wall remotes which are both within 4-5 metres of an Everspring wall socket but the Nodons are routed directly to the Homey which is about 7 metres away on the floor below. They constantly become unresponsive or unreachable but do work after a delay (sometimes a long delay) so I am assuming that the distance from Nodons to Homey is just on the limit.

I have tried to use the heal option within Homey Developer but always seem to get a “REQUEST_NEIGHBOR_UPDATE_FAILED” response therefore no change to the routing occurs.

Any ideas?

@Caseda ^^

While the heal button being there for battery devices, and some people say it helps.
A heal command renews the internal table of neighbouring devices in the device you heal.
A battery device doesn’t have such a table, so a heal command won’t do anything, even if it would succeed to be send by Homey.

A heal command works only on mains powered devices, so if you want to improve routing, you’ll have to target all mains powered devices nearby the device.
Then wake up (press a button) on the NodOn device, so all mains powered devices nearby that are renewing their table know that NodOn device is a neighbour.

If you still really want to try and renew the table in the nodon, you’ll have to wake up any battery device to be able to send the heal command at all, a batttery device is asleep 99% of the time so won’t listen to any commands to save battery

1 Like

I have a NodOn Soft Remote.
In Advanced Settings, I try to set the “mode buttons 1&3” and “mode buttons 2&4” to Single Button Control, but when trying to save the settings I get a time-out. I rebooted Homey already.
What do I do wrong?

Do you wake up the remote just before saving the settings? Like mentioned in the app’s description.

1 Like

Thanks, that did the trick!

Hello, I cannot register my brand new Wall Switch, I’m following the procedure (Hold both UP button for 4 seconds, then Press Upper-Left), but nothing happens.
However When I Hold the same buttons then presss Lower-Left, I can go to step 2, then doing the same leads to Adding device, then Something went wrong, please try again later.
Could you please help ?

When including the homey app says. Press both upper buttons till the led blink then press the left upper button.

Secondly, i know those devices (have them myself) need good full batteries, even when you messure them with a meter and think they good, a brand new one could work.

What a great controller!
But i don’t sww how i can use button 1 for lights on, and button 3 for light off (just an example).

2 and 4 i manage to separate due to “logic” but not 1 and 3.

Any ideas?