Lightwave Smart Series (generation 2) (Release 2.0.5, Test 3.1.0)

Thank you let me know if you want me to try anything or send any more logs

One thing which is a very small chance, if you had polling switched on with a large number of devices, it might have been blocking your account due to too many requests.
With polling switched off it will register a Webhook for each capability so you get push notifications. The app restricts the rate at which it registers the Webhooks so it doesn’t exceed any rate limits so it can take several minutes to start up, but once it’s running there is very little traffic and it’s response to events is very quick.

I’ve turned off the polling after you asked me to, it is normally off though, only turned it on to see if it would make any difference

1 Like

I have tried the app on my dev Homey and it worked fine. Now gone back to my normal Homey and that is still working as well. So I have no idea why yours is not working. Everything points to it being a bad refresh or access token.

Thank you for looking into it, it’s really strange just gone into the config again and it doesn’t have the refresh token displayed so got a new one, put that in went out to test a light, it turned on but didn’t register as on, so went back in the token was the old one, so updated it and tested by turning off the same light which worked but again it didn’t register it as off, having looked at it again it’s now registered it as off. Make me wonder if there is something with my actual homey

With the number of devices you have, it could take several minutes to register all the Webhooks when you enter a new token. If you monitor the log you will see it registering them, providing it has managed to connect.