Aqara & Xiaomi Smart Home - Zigbee App (v1.6.0)

Thank you for your reply. Didn’t know that there is a difference if you have it in the first statement or in the second (AND-statement). I will just move them around and have it first. Thank you!

1 Like

@TedTolboom I received the FP1 and did an interview

 "ids": {
    "modelId": "lumi.motion.ac01",
    "manufacturerName": ""
  },
  "endpoints": {
    "endpointDescriptors": [
      {
        "endpointId": 1,
        "applicationProfileId": 260,
        "applicationDeviceId": 65520,
        "applicationDeviceVersion": 0,
        "_reserved1": 0,
        "inputClusters": [
          0,
          3,
          64704
        ],
        "outputClusters": [
          3,
          25
        ]
      }
    ],
    "endpoints": {
      "1": {
        "clusters": {
          "basic": {
            "attributes": [
              {
                "acl": [
                  "readable"
                ],
                "id": 0,
                "name": "zclVersion",
                "value": 3
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 1,
                "name": "appVersion",
                "value": 54
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 2,
                "name": "stackVersion",
                "value": 2
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 3,
                "name": "hwVersion",
                "value": 1
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 4,
                "name": "manufacturerName",
                "value": "aqara"
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 5,
                "name": "modelId",
                "value": "lumi.motion.ac01"
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 6,
                "name": "dateCode",
                "value": "20210121"
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 7,
                "name": "powerSource",
                "value": "dc"
              },
              {
                "acl": [
                  "readable"
                ],
                "id": 13
              }
            ],
            "commandsGenerated": [],
            "commandsReceived": [
              "factoryReset"
            ]
          },
          "identify": {
            "attributes": [
              {
                "acl": [
                  "readable"
                ],
                "id": 0
              }
            ],
            "commandsGenerated": [
              0
            ],
            "commandsReceived": [
              0,
              1,
              64
            ]
          }
        },
        "bindings": {
          "identify": {
            "attributes": [
              {
                "acl": [
                  "readable"
                ],
                "id": 0
              }
            ],
            "commandsGenerated": [
              0
            ],
            "commandsReceived": [
              0,
              1,
              64
            ]
          },
          "ota": {}
        }
      }
    }
  }

I don’t have the device myself and know from experience that adding an Aqara device based on interview data will not yield a working and lasting implementation. I can only rely on capturing the communication between the device and the Aqara hub…

Hey Ted,

I understand, still thinking, is there a way to get the information you need from the Zigbee home automation plugin of HA ?

It seems to be supported from version 2022.7
link to github: https://github.com/home-assistant/core/tree/dev/homeassistant/components/zha

found something in here https://github.com/home-assistant/core/blob/42d7f2a3b29fcb1e24bdde26546ff6120a9185db/homeassistant/components/zha/core/channels/manufacturerspecific.py

Thanks for thinking along… off course I am using multiple (even shared closed) sources while implementing a new device.

But I also need to take into account the large user base (25000+ Installs), expecting full functionality once support for a device is added. From that perspective it is one of my app development fundamentals to only add support for devices when I have tested the device myself…

I will add support for the FP1 (ordered), but to manage expectations it will be fourth in line: Aqara E1 roller shutter, P1 motion sensor, Aqara E1 curtain motor (all released in EU sales area) and then the FP1 motion sensor.

In the meantime I am following with other developers and Aqara development which FP1 features are considered stable enough to integrate in Homey’s app…

10 Likes

Give me a heads up if you want someone to beta test the E1 roller shutter - not that I expect you to remember it, but…if you do, I don’t mind it if mine resets or something :slight_smile:

3 Likes

Same for P1 sensors i have 3 of them, if you need someone to test or instant test with direct chat tell me.
I have a lot of nerves cause im Application Manager :slight_smile:

1 Like

Hi @TedTolboom, I had 3 Aquara/Honeywell smoke detectors working fine in the app. One of them broke down, so I ordered a new one (at least that is what I thought). I now have a new “Aquara Smoke Alarm Detector Sensor JY-GZ-01AQ Zigbee 3.0” which is not recognised by the app.
Are there any plans to add this device?
Thanks, Jeroen

Hi Tom,

In the attachment you can see two Aqara motion sensors (AMS-6 and AMS-7)

I deleted both of these 10 days ago and added them again because she no longer responded. AMS-7 suddenly stops responding after 7 days (AMS-6 still working). AMS-7 is linked through Node 10. This node is 1 meter away and controls many other devices that work flawlessly; e.g. node 1 (beweging voordeur). This is an EndDivice from Ikea that has been working for a year without any problems. I don’t think it’s a router issue.

Sincerely,

Freek Smits

47 Zigbee devices exceeds what Athom recommends for a stable network.

I have more devices then you and it’s stable , but seeing your setup, you didn’t (re) create ZigBee network correctly - best you can do, reset ZigBee, add routers first and then endpoints. But anyway, it’s not related to the Aqara thread unfortunately as developer can’t influence it.

But it is still strange that I only have problems with the Aqara sensors. The Zigbee motion sensors from Lidl (4 x) and Ikea (1x) work without any problems

@TedTolboom Will you be adding support for the Aqara A100 door lock?

Hi Ted, welcome back. I hope everything is OK with you and your loved ones.

Do you own the Aqara water flood sensor?

Else I’d like to buy one for you so you hopefully can find out why the battery status is not updated when you have time for that.

From the start untill the battery is dead, the sensor reports a 100% battery. I have 8 of these. All the same behaviour.

I’ve read others that have this issue too. There’s a topic about this on the forum.

If the sensor is used with the Aqara hub then the battery level is reported correct according to owners of a hub. Xiaomi support also confirmed battery report is supported by this sensor.

Please let me know if i can help in any way troubleshooting.

Thanks alot

Not sure yet. This version will not be the version of the smoke detector that Aqara will be releasing towards the European region (which will be certified). I am not sure about the differences, the popularity of this version and therefore doubt to invest in the device to have it available to verify the implementation…

Yes, I have the device.
I will check the battery reporting of this device. It is based on a proprietary protocol, so Xiaomi support indicating that it does support it, doesn’t mean that it is known how to use this with other controllers…

Ted,

Ah OK prop. protocol.
Well I hope you can find the issue. At least thanx for taking the time to look at this issue.

Great to hear you own the device.
Then I’ll add this to your donation so you can buy yourself a larger beer :wink:

Regards David.

Thanks Ted. Makes perfect sense.

@TedTolboom Aqara released a new product, a curtain motor.
Wil this also be supported in Homey?

https://www.aqara.com/en/product/curtain-driver-e1

1 Like

Tedtolboom says: I will add support for the FP1 (ordered), but to manage expectations it will be fourth in line: Aqara E1 roller shutter, P1 motion sensor, Aqara E1 curtain motor (all released in EU sales area) and then the FP1 motion sensor.

4 Likes