Aqara & Xiaomi Smart Home - Zigbee App (v1.6.0 | TEST v1.7.0)

Hi Ted, welcome back. I hope everything is OK with you and your loved ones.

Do you own the Aqara water flood sensor?

Else I’d like to buy one for you so you hopefully can find out why the battery status is not updated when you have time for that.

From the start untill the battery is dead, the sensor reports a 100% battery. I have 8 of these. All the same behaviour.

I’ve read others that have this issue too. There’s a topic about this on the forum.

If the sensor is used with the Aqara hub then the battery level is reported correct according to owners of a hub. Xiaomi support also confirmed battery report is supported by this sensor.

Please let me know if i can help in any way troubleshooting.

Thanks alot

Not sure yet. This version will not be the version of the smoke detector that Aqara will be releasing towards the European region (which will be certified). I am not sure about the differences, the popularity of this version and therefore doubt to invest in the device to have it available to verify the implementation…

Yes, I have the device.
I will check the battery reporting of this device. It is based on a proprietary protocol, so Xiaomi support indicating that it does support it, doesn’t mean that it is known how to use this with other controllers…


Ah OK prop. protocol.
Well I hope you can find the issue. At least thanx for taking the time to look at this issue.

Great to hear you own the device.
Then I’ll add this to your donation so you can buy yourself a larger beer :wink:

Regards David.

Thanks Ted. Makes perfect sense.

@TedTolboom Aqara released a new product, a curtain motor.
Wil this also be supported in Homey?

1 Like

Tedtolboom says: I will add support for the FP1 (ordered), but to manage expectations it will be fourth in line: Aqara E1 roller shutter, P1 motion sensor, Aqara E1 curtain motor (all released in EU sales area) and then the FP1 motion sensor.


Hey @TedTolboom really glad to see you are back in the game. Had me worried for a “second”. :slight_smile:

Pls, if you could give couple of minutes to the lower issue. I had some strange behavior with aqara bulb witch made me reset ZigBee network. After that I cannot re-add Aqara temperature sensor anymore. All the other ZigBee devices including multiple Aqara passed normally. Any chance you have some tip or suggestion?

Aquara temperature and humidity sensor dont pair with Homey · Issue #270 · TedTolboom/com.xiaomi-mi-zigbee · GitHub

EDIT: After second battery change I was able to re-include the sensor. I did immediately changed the battery but that didn’t help. Out of frustration I tried 3rd battery just now and was able to include it. Possibly 2nd battery, even though new, was in packaging for too long and deteriorated. I don’t know what to say but I was able to include it again, battery or not related. Possibly something was changed in the meantime but I doubt it.

Just received mine an hour ago !!

2 weeks earlier then expected/promised. :smile:

It works fine, in home assistant only Deconz. :wink:

I will test it the next few day but now still detecting me behind my monitor only typing and so almost not moving at all !

Will keep you updated how fine it works in my living room.

Tonight I’m not at home, sadly must go to a birthday party. :weary:
I’d rather stayed homer and tested.

By the way : ditch the accompanied/supplied usb power adapter: mine but also the one from a german youtube reviewer appered faulty. :rage:

If it keeps working so well I might order another FP1 one already in the weekend for my bedroom.

Although I heard that the CEO of Aqrara /Xiaomi already announce the FP2 ! :upside_down_face:

1 Like

Need help with a weird issue.

I have a H1 Wall Double Switch (with Neutral) with one button wired to a fan, and the other button left unwired.

I used homey to create a flow for the other button - when on, open curtain motors. When off, close curtain motors.

It seems to work fine at the point of pressing the switch to control the curtains (sometimes I have to press more than once if the curtain/switch states don’t match due to curtains being controlled via mobile app).

However, I noticed that when I use the switch to open the curtains, after a random period of time, the curtains would close on their own. In the device log it would just show that curtains were “Turned off - by Aqara & Xiaomi Zigbee”

To be clear, this only happens when using the unconnected side of the H1 wall switch to activate the flow. Opening the curtains directly via app would keep the curtains open until I close them.

I’m not sure if this is related to the fact that my curtain motors are operated in reverse commands (open command to close, vice versa) but I’d appreciate any help in diagnosing this problem.

Do all your other ZigBee devices continue to work normally? And can you include ZigBee devices other than your Aqara temperature sensor again?
I also had some strange behaviors like this a while back, and finally nothing was working any more. Here is what the solution was. I specify that doing a ZigBee network reset is useless if you are affected by the same problem as me.

Aside of that small “thingy” whole zigbee network is quite decent and stable. Everything is OK except I cannot seem to find a way how to add that last piece of the puzzle back in.

Even before zigbee reset in the old network I removed it and couldn’t get it back in. Then I did reset and again the same issue. Othe devices were normally joined and normally working. O_o

Does anybody have an issue that Aqara EU plug (SP-EUC01) not reporting measure and meter power?

Yes, we all have the same issue. @TedTolboom , the app owner, is aware about that and should publish a new app version in few weeks (already available in test mode)

It should fix the issues with the Aqara H1 switches reporting the wrong state

1 Like

Hi @TedTolboom, thanks a lot for your hard work on this app! Looking forward to the FP1 support, and hopefully the periodic disconnect issue with Aqara devices can be resolved at some point. Thanks again and keep up the great work!

1 Like

Hi @TedTolboom , I have installed the test 1.4.2 app and the Aqara H1 switches (with neutral wire) are now working perfectly. The lamp will now remain on.
The lamp is not directly in the Homey, but is switched via the Hue gateway. thanks

I have a H1 wall switch that is randomly leaving the zigbee network (2nd time in 4 days now). Is there anyway I can try to get it back onto the network without removing and re-adding the device?

Also, what are the possible causes of this? I have plenty of switches connected and only this one particular switch is leaving the network.

Hi All,

I have an issue with adding the Aqara Vibration Sensor. After clicking the “install” button I press the button on the sensor for 5 seconds. A message appears that it is searching for the device. After some time an error appears: “The device doesn’t respond anymore and couldn’t be added, try again”.

I’ve already tried:

  • Holding it closer to Homey (within 1 meter)
  • Restarting Homey via the App
  • Restarting by disconnecting from power for 10 minutes

Nothing helps… Any ideas here?

After you press the button for 5 seconds and the LED blinks then you have to press the button every 2 or 3 seconds to keep the device awake.
This keeps the device awake so it can be found by Homey.

1 Like

@Mike1233 Yes, that did the trick. Thanks!

@Wouterr nice to hear that it is working now.