Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1)

If i do a Zigbee reset, wil all the zigbee devices being removed ?

Yes, you will have to add them back to Homey again, and fix any flows that depended on the “old” devices.

I could use the Xiaomi Smart plug (EU) for my new cheap cheap zigbee Smart plug from lIdel, they are named SILVERCREST HG06337. They appear as Unknown zigbe unit but work flawlessly! Its nice to be able to use the plug without the gateway from lidel.

This part is for Xiaomi devices…check out below app to get the right drivers etc (not generic device as you got added now)

I had similar problems on firmware V5 RC38. Then My Homey died and I sent it for repair. A week later I got a replacement unit from Athom. Restored a backup, got firmware V5 RC46. Routers reconnected, most aqara sensors did not. For instance, door sensors would send alarm once, and never go back to normal state. Reconnecting them (without remove) resulted in “device left the Zigbee network”, but no luck reconnecting anything. Removing them myself worked, but nothing reconnected. Firmware V5 RC47 came the same day, no difference.

Then, after a Zigbee reset, it seems like Athom switched from chanel 11 to chanel 14. All routers connected in seconds, in their intended place. As did the Aqara battery stuff. All at first try, none of them needed a 2 second wakeup press as they did before. There was one hickup, maybe after adding about 30 devices, I had trouble reconnecting again. A Homey PTP and an hour waiting later it went back to reconnecting as usual.

So on firmware V4 and Zigbee channel 11, I needed to place new stuff near Homey in order for them to pair at all. Most stuff took numerous attempts to be seen at pairing. Now on V5 RC 47 with a Zigbee refresh and chanel 14, my network is more stable than ever, routes are way more natural and pairing is a breeze.

Repairing flows, especially the ones with numerous tags was a pain. Even more so because missing tags do not report as broken flows. Fixing this is fastest in the online flow editor, which allows tag copy/past and faster search.

I am not sure Athom can do anything to the firmware that will fix a bad mesh. Also, I get the feeling channel 11 is a bad default for Zigbee because wifi routers tend to crowd that channel too, and you can’t force your neighbors to go to a different channel with that. I’m not sure what helped more, a better mesh or a different channel, but I’m happy now nonetheless.

I am not so sure most users will appreciate the network reset though.

2 Likes

I just receiver 2 Aqara TH sensors, which I could connect without problems, so that’s great :slight_smile:

Also received a Mi (?) light sensor, but when I try to add this it only adds as a Basic Zigbee device. What am I doing wrong?

They are my first Zigbee devices.

The productnumber on the batterylid matches the number described in the topicstart GZCGQ01LM. When I check the settings in Homey (for the Unknown Zigbee Device) it says: productID lumi.sen_ill.mgl01

This forum topic is about the zigbee devices connected directly to homey.

For qustions about the gateway app please check this Topic

Can you indicate which option you choose while including the light sensor?

  1. Connect your device > Homey > Zigbee
  2. Connect your device > Aqara / Xiaomi Zigbee app > light sensor

There is a issue where the manufacturer ID is not captured during inclusion by using option 1. and therefore not match is found with the right driver (based on manufacturer ID and product ID).

Can you try if the problem is resolved while using option 2.? In this case a missing manufacturer ID is filled in since you already indicated it to be this device.

I also have a problem with the aqara light sensor.
Option 2 doesn’t work, I get " No homey app found to support this device".

Option 2.

Didn’t even know there was an option like 1 (it’s my first Zigbee device), but I tried it also just now: nothing happens at all when I put the sensor in pairing mode and follow option 1
However, I now have the same problem with option 2: nothing happens when I put the device in pairing mode. I was able to add it earlier though

edit: I had to reset my Homey, apparently something was stuck in de Zigbee part (when I checked my Homey Developer).

Now I can also add the Light sensor with option 1, but the result is the same (Unknown Zigbee device) (same result when trying option 2)

Hello
I’m trying to add an Occupancy Sensor (RTCGQ01LM) on my Homey Pro without success.
After long press until the blue light flashes 3 times I press reset button regularly.
But after long time I have message “délai d’ajout d’un appareil expiré” (time limit for adding an item has elapsed)
Same result:

  • directly with Zigbee on Homey
  • or with Aqara & Xiaomi Zigbee App

I tried to add it on Xiaomi Gateway directly and it works.
Actually I have 18 nodes Zigbee
Do you have an idea ?
Thanks you

How many of those are router devices?

Hi @robertklep
Only 1 actually.
I will to add a Smart Socket plug.
Is it the solution ?

It might be, you’re really close to the 20-device limit.

Indeed.
What would be the solution?

Adding more router devices, although you may run into a catch-22 situation where you cannot add new router devices because you’ve hit the limit. In that case, you’re going to have to remove existing devices first before you can add the routers.

OK thanks :slight_smile:
Smart Socket plug is a router device ?
Do you have example of router devices ?

Almost all permanently powered devices (smart sockets, smart bulbs, IKEA repeater) are router devices.

1 Like

Inevitably, IKEA repeater is not sold in France :wink:

The Aqara smart plug is also an repeater:

2 Likes