Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1)

@KvM:
Yes, you need to upgrade to the latest v5 RC first.
If the Aqara app is not automatically updated, you can do so afterwards. In my case all my devices were up and running after that. Flows too.

But no guarantee; it is still a testversion and Homey v5 is still a RC too. My guess is that it will work though. Make sure you know what you’re doing.

Also make sure all your other apps are v5 (SDK3) ready.

I’m aware of the beta status, and checked all my apps, thanks for the heads up nevertheless.

Gonna try tonight or this weekend to upgrade, thanks!

1 Like

@TedTolboom what a tremendous work you did upgrading the sdk. I scrolled down the commits on GitHub, it looks to me that it’s huge. Thanks so much. I noticed a bug in the battery status of the light sensor and made an issue on GitHub. Even after remove and re-adding the sensor and also a reboot didn’t solve the issue.

Thanks. It was a bit more work than the 20-30 hours as mentioned before, also because we needed to complete part of Athom’s Zigbee implementation (Zigbee-Clusters), hence I missed my own target date.

In the various Zigbee apps a lot of work has been put in by the different community developers, like @kasteleman, @johan_bendz, @h3rman @prj_84 and @dpanet, in great collaboration with each other; sharing problems fixes and solutions! So without their mental support, the update wouldn’t have been there…

13 Likes

Working like a charm. Thank you :pray:

1 Like

24 posts were merged into an existing topic: Zigbee routing and 20 devices (directly connected) hardware limit

Deep respect for all the hard work @TedTolboom.

Just to be sure: the app itself is still in test and only via GitHub available? Or is the app already via the ‘normal’ route available?

You can use this link.

You both are referring to Zigbee apps right and not all other apps ?

  • Zigbee apps need to use SDK3 with homey v5
  • Other apps (not zigbee) needs SDK2 or higher to work with homey v5
  • SDK1 apps stop functioning with homey v5

Please tell me if I wrote something wrong

How can I check which SDK an app is on? So I know if I still use some old SDK1 apps.

Aqara Wireless Switch Singel (2018)
If i do a long press nothing happens.

I try to uninstall one and then install it again. But if I select “A scene has been activated” and select objects, then a black image with the text “No results” appear, here I could before select long press and double press.
Now I can only select the option “A button has been pressed”

I hope there is a solution to this?




I try to uninstall one and then install it again

Today i added my xiaomi sensors and it seems to look perfect. My old flows are working when added a new card with the device. See picture

After that i tried to add more of my sensors (door and window, wireless switch) but i can’t. There is no respons when i hold the button on the sensor for 3 second. Strange, because i added the same devices earlyer and all of them are working.

This screen appear and stays till i close it.

Do you have any ideas?

1 Like

It’s the same for me!
Could paired with Aqara Wireless Switch Single (2018)
But then I can neither pair any Aqara device or hue device?
Tried to shut down Homey and restart. Nothing helps!
:sleepy:

Plus one for me

1 Like

Hm, I have Aqara Wireless Switches and two days ago I did pair about 5 other Hue devices flawlessly. How many Zigbee devices you have and how many routers ?

@TedTolboom Many thanx for your efforts. Wireless switches and humidity sensors working fine.

Indeed Ted, but the second wireless switch cannot be added. It seems that i can’t add any devices anymore. The 5 that i added are working perfect!

1 Like

I also tried to restart the aquara app, but no result.

1 Like

Maybe a reset of the zigbee network?

Thanks for reporting: will be fixed in version 1.0.1

@Hans-Jochen_Nissen, @Ton_van_Rijnsoever, @Patrick_van_der_Meer, like @Sharkys already suggested, can you check how many Zigbee devices you have included and how many of them are EndDevices or Routers?

Can you share the requested information on this issue at: https://github.com/TedTolboom/com.xiaomi-mi-zigbee/issues/222

Please do note that inclusion is handled outside the (Aqara) app environment.
I’ll use this information to check with Athom where the issue is originating.

3 Likes