Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1 - TEST: v1.4.2)

You do not need to take off the sensors, they can be opened to change the battery.

Only pull the white part!

Hi All,

Since a couple of days my aqara remote switch double does not work anymore. A friend is experiencing the same problem. I’ve tried re-adding it, which works fine but still the device is unoperable and homey has rebooted a couple of times but still nothing. Any ideas on how to fix this?


The message says i cannot operate the device.

That is correct, you can’t. In english it says: “No available controls” and “This device has no available controls for display”. Which makes somewhat more sense.

This doesn’t mean you can’t use the device, it simply means that in the device driver there is no capability to switch it on or off via the device page. You can only operate it by adding it as a trigger to a flow.

And, if you already had a flow for it, removing and re-adding makes the device unknown to that flow. So the flow is unusable until you repair it by removing the old card (without device now) and add a card with the “new” device…

Sorry for the misunderstanding I never looked at that message before because the device was always working in flows. For some reason the device stopped working, when i press a button nothing happens, homey does not seem to receive the commands sent by the switch. After deleting and adding the device back to homey I also updated the flows but still nothing happens.

Well, there are numerous reports of problems with Zigbee devices the last week. Most of them likely related to the max number of Zigbee devices, but not with 100% certainty. Could be you suffer from that also.

I havent read all the threads on those issues but there are currently 10 Zigbee devices connected. the other zigbee devices all work fine and the pairing of the switch also works perfectly. The strange thing is a friend of mine with even less devices is experiencing the same problems.

Also the problems started at the exact same moment.

I also cannot remove the device in the homey app. When I try to do so, I get the following message:

status.could_not_find_zigbee_shepherd_device

When I try to use the switch, the two Led’s at the bottom are flashing 2 times, after the single initial flash that confirm a press of a button.

If that is the case after you removed it from Homey, then that is likely because it is not connected to any controller anymore. My (connected) switches only blink once on pressing a button. I assume they are the same, I have the WXKG02LM.

I’m using the WXKG02LM as well. after reading a little about the zigbee mesh network I think I have 3 routers and 7 endpoints (battery controlled devices). if I’m correct you can put 20 endpoints behind a router so I dont think this should be an issue

Normally it shouldn’t, but with the current Zigbee implementation Athom only guarantees 10 to 15 devices in total.

It should only blink once. But it does to additional blinks now …

Also, I can’t remove it. It’s still a device in my homey app with a red symbol in the corner. When I try to remove it I get the message posted above.

Also because I’m not living in the house where I want to implement the devices yet, I have only the switch controlling one zigbee bulb, 2 action RF sockets and a hue hub.

I will remove my door sensors later this evening to rule out the max nr of connected devices issue.

Do a PtP of Homey and then try to remove again. Most of the time that works.
Then the next time, first do the PtP before removal, sometimes it might just all work fine again.

From another topic (i know you can read Dutch so i share it :stuck_out_tongue:)

hi all,

i still cant pair my Aqara sensors to my homey.
I already opened a thread on Github (https://github.com/TedTolboom/com.xiaomi-mi-zigbee/issues/150), but not much response there so i will try my luck here :slight_smile:.

Just purchased 2 Xiaomi/aqara temperature/humidity sensors.
both wont pair with the homey app. They both blink 3 times as required by the app but after that nothing happens.

I tried reinstalling the app and restarting homey but no succes.
I tried keeping the sensors awake while trying to connect but also no succes.
It keeps only showing the install instructions screen and after that the time out screen.

Homey Pro (early 2019)
Homey version 2.1.1
App version 2.2.1.299
node.js versie v8.12.0

Mi zigbee app v0.5.5

I also tried the Door and window sensors, they have the same issue.
Also tried the sensors on a older Homey (early 2016) from a family member, here all the sensors pair without any problems. All the software versions (homey and the mi zigbee app) are exactly the same as on my homey pro.

Hope @TedTolboom or someone else has an idea.

1 Like

I never did remove the switch because homey wouldn’t let me. PtP didnt work. Holding the buttons to go in discover more also had no effect on the removal attempt.

I have reinstalled the app, added the device and now it’s working again. Nakkie040 his devices started working out of nowhere, so that’s awesome but also weird…

Als all good that this is happening in a test environment, but I’m planning on using at least 10 different aqara devices. Can’t go making every flow over every time one device calls it a day xD

That may be, but the fact is that you held the buttons to start the removal. And despite the fact that Homey didn’t remove it, it did reset the switch itself and thus removing any association with a controller. That is why the led blinks more than once, it indicates that there is no association present in the device.

Mhmmm… still huge issues now since weeks as the temp sensors and the contact sensors just don’t report nor update their values. Ted, as you didn’t address this or answered via GitHub, is it possible to get an update here on how work is progressing?
The sensors are absolutely useless unfortunately - I mean yeah, it’s the cheapest sensors on the market and yeah, it’s just like choosing VW or eating Tuna; we deserve all the bad errors and instabilities due to choosing this stuff that is produced on the back of 12 yr old employees (meaning the area managers); but - it’s be nice to get the stuff working anyhow :face_with_hand_over_mouth::man_shrugging:

For those who cann’t remove the devices:

try to link them again, it will give you a duplicate device error, now you can unlink it.

This always works for me.

2 Likes

You are aware that many people have similar problems at the moment? And that it looks like it is related to the number of devices that Homey support (max 10 to 15 in total) or Homey memory leak problems?
There are people who got it working again by doing a PtP (Pull the Plug for 15 minutes), some after removing some less used Zigbee devices.

I think this is an assumption on your side. I have seen no proof this is true, I have seen proof it is not true.

1 Like