Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1 - TEST: v1.4.2)

Hello to Ted and All,
I have updates to teh experimental version and also to the test version of this app.
All works great exect the Light sensor, this on keeps telling, zigbee device clould not initialize.
I already try to include it again but it dit not work, homey say, this device is already included.

Some advice would be great!

THX!!!

!

1 Like

I second that, just was planning to raise the same issue / question. I included all aqara devices and everything works as expected (thanks @TedTolboom!) except for the Light Sensor. I excluded and included again but direct after it’s working again it stops.

1 Like

First delete the Light sensor and then add it again
You may have to fix your flow afterwards

@cautje and @Martijn_Hoogenbosch, my Xiaomi light sensor works perfectly. Even connecting without any problems.

1 Like

I am looking into the issue… it is likely related to a initialization after the initial one…
So when new included, it will be fine. When the app is restarted afterwards (including updating the app), it will fail. Fix will be included in the next update

2 Likes

I don’t want to start another general zigbee discussion, but my experience about adding zigbee devices to Homey is that it’s way more stable, especially Aqara devices, if you add them at the very position where they’re supposed to be rather than including them close to Homey, for further comments see Zigbee routing and 20 devices (directly connected) hardware limit. The inclusion advice when pairing (at least with v4.2) is that you should keep the devices close to Homey. Maybe it’s time to change that advice, @TedTolboom?

1 Like

That was my experience to! With no restart. It stays fine

I have not restarted Homey since my upgrade to V5 and Aqara & Xiaomi Smart Home - Zigbee App Test: v1.0.1

Thnx for the great app!

I still have some isseus that some devices won’t respond always I need to reboot homey then.

Still no routing visible after 5 days (have 4 routers and 14 end devices)

Also see this in my timeline from 2 devices.

It happened to me when i restarted the app, didnot restart homey to

Can anyone confirm me if Aqara wireless wall switch ( WXKG07LM) works well with this app? It is pretty similar with the “WXKG02LM” but just to prevent me from placing an order for a product that might not work.
Thank you.

The Aqara D1 series (wireless) switches is not yet supported, but will be working with the next update…

3 Likes

Thank you for the quick answer, I’ll wait then.

I have been following the work you’ve been doing, I just want to say, excellent progress and thank you for all your efforts in developing this app that is useful to so many of us!

Since I’m not an “expert” i just wait for the stable homey v5 and your app as well.

Once again thank you :ok_hand:

I have resolved the issue and can now add all devices. What have I done?

  1. reset zigbee network
  2. go to Ikea and buy a Zigbee lamp and signal repeater.
  3. added both devices (powered) to homey.
  4. add all (end point/battery) devices again (Temp senser, motion sensor, Wireless switch etc)

After this everything worked and I saw no limit with adding devices.

Probably adding 1 powered device would have been enough.

In any case, I am completely happy again! Thanks for all the work. I switched off experimental updates now!! :slight_smile:

1 Like

Sorry if this topic already have been handled here, but the forum turned quite busy the last week. :slight_smile:
The update worked very well for me, but I have some questions regarding a very few of my devices. They cannot show the mesh routes:

Some tried to just re-add them without removing them, this will actually remove the old device and add a new one, that also needs to be added to the flows they were connected to. No worries, I can do this. But since there are so many bright people here, I figure that I can at least ask the question. Is there any other way to just include the devices in the network?
They do work as they did with 4.2.0, but it doesn’t look good. :slight_smile:

@TedTolboom

Hi Ted,

If I can contribute in anyway to add the new Aqara D1 switches? I have received the D1 wireless light switches single and dual rocker. Single rocker = WXKG06LM and the dual rocker = WXKG07LM

Let me know.

Regards,

Dennis

1 Like

Give it time (some say it can take up to 9 days) or remove / connect. Both are valid options, the latter has more impact.

And yes, has been handled like a dozen times already. But no worries.

1 Like

Thanks @Martijn_Hoogenbosch. Yeah, I have seen that it can take several days to get the graphics updated, but I was a bit uncertain if that exact scenario was applicable for me since most aqara devices were updated in the list. I was worried that something was faulty with just these devices.

But then I know, I will let time pass and have it solved automagically. :slight_smile:

The answer for that is 4 or 5 comments above

I have removed the light senson and added it again but still the same, cant initialize.
In the developper overview i can see the mesch of this device.

I will wait for the next release.