Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1 - TEST: v1.4.2)

Just updated to V5.0.0.34 RC and Ted’s 1.0.1 Aqara & Xiaomi Smart Home - Zigbee App
Out of the 43 zigbee devices 41 are added without issues. 2 TRÅDFRI lightbulbs are not responding (yet)

All Aqara and Xiaomi devices where added. Just 2 with a little “push” :innocent:

@TedTolboom Great job!! :+1:t2: :+1:t2: :+1:t2: :clap:t2: :clap:t2: :clap:t2:

Notices sofar: Zigbee mesh is quicker and more responsive!!! :grin:

1 Like

I have the same problem. I was able to remove some devices and add them again wwith speed of light compared to the past. But suddenly Im not able to add any other device. Did reboot, PTP but no success.

@TedTolboom battery status is ok after the fix! Thnx!

Past this in Request frame:
//Get SDK version of Apps - SDK v2 and higher needed for Homey firmware 5.x
Homey.apps.getApps().then(f => Object.values(f).reduce((r,b)=>Object.assign(r, {[b.name]:b.sdk}), {}));

Klick RUN

Result: “Google Chromecast” : int 2
Meaning: int 2 = SDK 2

2 Likes

@TedTolboom, I think I have found a workaround. I reset the zigbee network and then added some routers first. Then I was able to add all EndDevices. So problem solved for me.
Everything works fine, many thanks

A post was merged into an existing topic: Zigbee routing and 20 devices (directly connected) hardware limit

I’m drawing the line here guys…

I’ll ask the mods to split the more generic Zigbee discussion from this app topic; it is informing (and deserves it’s own topic).

Let’s get back on topic: me! :grin:

… a well, also the Aqara app…

17 Likes

Thx TED, great work. Waiting for Develco update now :), see u in 3 weeks.

@TedTolboom, I am not able to connect the Aqara Wireless Mini Switch.
I have already made several attempts (+20) (reset, press longer than 3 seconds, press again and again after the 3 seconds, change the battery, etc.). Unfortunately without success. I already reported this on GitHub #223.
And yes, the switch was close enough (< 2 cm). To connect a Xiaomi Light Sensor was no problem.

Today I tried to connect the Switch to the ConBee II USB stick again. This worked without problems on the first try. Adding the switch via the deCONZ App to Homey also worked without problems.

Does anyone else have problems to connect the switch?

I also have problems to connect all my aqara motion sensors…none of them I can connect…anybody else the same problem?

1 Like

Can I ask you a question, @Ted?
I just re-added the Double Relay to be used in the new way (2 separate devices) after upgrading to v5rc34 and installing your app v1.0.1. All well and they function great, but I noticed one thing:

Only one of the “devices” shows the energy usage. The other “device” lacks this view. The first one shows the energy usage of the second “device” when being ised. Is this a limitation of the new integration or is something wrong or not implemented yet here?

This way it seems the first device has used energy, when in fact, it was the second device.
The outputs of the relay are two different devices, which can be switched on/off separately. So in my opinion, there should be a view for energy usage on both “devices” too, not?

Wasn’t planning to do the upstairs floor today, but because this remark I did it anyway. Reason for this, I have 1 motion sensor there from Aqara and after a couple of tries, it did work. I think i’ve tried 4 times before it connected, but no, not the same problem.

I have problem with ZigBee subdevices. Aqara Wall Switch Double (LN) new version - right switch stops to work with timeout, but left works fine. Old driver works fine with two buttons always. I think we have some troubles with new athom`s zigbee realisation. And there is difficult to add new devices, i agree.

If I would have the opportunity to implement it also for the second switch (separately), I would have done it. In fact the relay only reports one (combined) power-level…

@Ivan_Ryzhik can you create an issue on GH with a more extensive description of the issue:

  • which specific Aqara Wall Switch Double (LN) are you using (Zigbee productID)?
  • send and share the apps diagnostics report; it should show the specific error which is causing the timeout.

Ah, I see. Pity… Bad inplementation by Aqara then… :frowning:
Thanks for answering, Ted!

Dear Ted,

Thank you for your great work. I loved using your app for some years (then up to 20 devices) and hope to start loving it again with even more devices. At the moment I’m experiencing issues with nearly all Aqara Zigbee devices becoming unresponsive after a few minutes to a few hours. I added the requested info in a github issue.

Tried so far: restart Homey, restart Aqara app, re-adding devices, waking devices, adding devices in a different order, removing and adding devices, nearly restarted the Zigbee network - however I don’t want to loose all insights data.

Thank you for your support! Any advice by anyone,that can help me solve this issue is greatly appreciated.

It’s not a software but rather a hardware issue.

Currently on 5.0,o rc 34.
Philips Hue 2.0.7.

  • Door/Window sensor (MCCGQ01LM) (contact alarm)
    After 5 sensors i cant add more.

I do know that it can take a while or even days in order to Homey to sort out the mesh network. I have some xiaomi/aqara devices, mostly end devices that have their routing clear.

But most devices are not. Is it just a waiting game or can this be forced/triggered manually?

I tried to “interview” these devices, that works fine in reality but have a question mark in this list. I get these messages
image
and then
image

But I really really like the new meshing. Great work @TedTolboom