[APP][Pro] Xiaomi Mi Home App for WiFi devices

Perfect!
I had a spare one, but it is dead :sleepy:
(Couldn’t report sooner, currently travellding)

1 Like

The Homey zigbee is dodgy at best.

Even on the old version I never had the issues that others reported to be fair. With the new homey it’s super responsive and have yet to get a miss on sensors. Have you tried the new homey?

Seems we have a deal.

2 Likes

I have 50+ devices.
WAF below par.

Same amount but no issues. Maybe the issue is not with Homey but with the wife?! :stuck_out_tongue:

1 Like

Thanks for taking over @Phuturist much appreciated! Great work upgrading to SDK3.
if i may come with a request, it is to get support for Roborock vacuums / mops, uses the Xiaomi app and token, none of the ones in the app right now, do supports the Roborocks S7 at least native, the “advance vacuum” does indeed read out battery and other data including current status, but cant be started / controlled.

The “original” Roborock app has been abandoned and have not been updated in years, so i doubt that it will ever be updated to SDK3. It works fine for the new models as of this message, just cannot be installed on the 2023 pro models, due to SDK2. :slight_smile:

No question, no bug (I think), just an observation :wink:

In the Homey Aqara App I have a couple of Aqara Wireless Mini Switches. It that App they look like this :

And are identified in that App as:

I removed one of these buttons from that App (and Homey) and added it to the Xiaomi Gateway and the Xiaomi Mi Home App successfully.
In Homey it identifies as:

And now my point :wink:

In the situation with the direct connection to Homey via the aqara App, in the flows it was possible to select 1 to 4 times clicking:

Added via the Gateway to Homey that is not possible. The following options are given:
Schermafbeelding 2023-03-16 om 15.52.07

Checking with the Xiaomi Gateway itself, I found out that that also does not have the option to use 3x and 4x pressing…

How did @TedTolboom get these buttons to allow 3x en 4x pressing functionality in Homey if the original ecosystem does not even facilitate this??? (he called it ‘scenes’ btw).

The double wireless switch (wxkg02lm) does not show any action flow cards. I posted an issue on Github.

1 Like

I added my Roborock S5 Max with this APP by choosing “Geavandceerde Vacuum Cleaner (WIFI)” inserted my IP and Token and voila. Full control at the moment and also all “warnings” are shown

I get a handshake timeout error after a while


This is not something that can be solved in the app and is a consequence of using an unofficial API. This could happen when multiple integration try and read out the device. Do you have it paired through other apps or even integrations as well? And make sure you close the smartphone app when not in use.

1 Like

2023-03-17 - v3.1.14 - TEST

Development has been transferred to a new developer. This release is a complete rewrite of the app including many breaking changes. The app has been fully rewritten using SDK3 and has been tested with Homey Pro 2023 to make it futureproof. This new version also merged the devices from the Mi Homey community app. Some previously paired devices might continu to work but please re-pair your devices and/or fix your flows before reporting any issue. If the issue persists after re-pair please report it on the community forum or Github.

I have just published a new test version to the test channel of the app store and I’m looking for people to properly test this version as it will contain bugs. As the release also contains breaking changes the only way to properly test it if you encounter an issue is by re-pairing the device and/or fix your flows and test if the issues still persists. If so, please report it here or preferably on Github .

If you want to go back to the live version you will have to re-pair and/or fix your flows again as both versions are not fully back- and forwards compatible.

Updates in 3.1.14

  • Possibly support vacuum model Roborock S7 MaxV Ultra (roborock.vacuum.a27)
  • Small fixes in the available modes for the generic humidifier and purifier driver
  • Fix for setting mode on deerma.humidifier.jsq
  • Possible fix for setting led through flow for humidifier and purifier
  • Fix for trigger cards not being available on Aqara Wireless Wall Double Switch (lumi.86sw2)

The test version can be installed through this link: Xiaomi Mi Home | Homey

Please consider donating if you appreciate the free time I put into this.

3 Likes

Tested it but does now work, i tried all models but the device is just flickering from not connected to connected in 5 sec steps, commands are ignored

Have you shared diag. code from the app ?

I’m aware, this model is not supported (for now). You can track possible future progress in this Github issue: Support for dmaker.fan.p15 · Issue #166 · jghaanstra/com.xiaomi-miio · GitHub

Hello everyone and thank you for the update on this.

I was actually going here to ask if the "Aqara Scene Panel S1E Smart Switch Touch Control” (Product Model:CJPKGO1LM) might be considered to be added - but I now realize that there are many other things to be prioritized and of course the support to @Phuturist .

There are things that I have to figure out… as if this token thingie is the reason my Roborock looses connection from time to time since my Google Home is connected to it as well. But I will get back to it once I get the HP2023 setup and have tested it for a while. :slight_smile:

Kudos for your work! :+1:

hp2023

2 Likes

You can still register a feature request on Github so it wont dissapear of the radar. But, I already had a quick look at this device. I cant find anything on support through the unofficial miio API. For me being able to add devices (if actually supported I would need one of these:

  • Access to the physical device (users would need to send me a device)
  • Some other library that already integrated the device which shows it’s parameters
  • The user that requests the integration supplies me with the parameters of the device, usually by sniffing network communication of the device. How this is done is described here.

Keep an eye on this on version 3.1.x. When it happens, send me a diagnostic report and I might be able to tell more on what is going on.

Thanx for the donation, much appreciated … :pray:

Hi Everyone :slight_smile:

I’m new in this platform, and I just bought a new HP2023 yet.
I have only one Xiaomi device yet, but i cannot integrate with this APP.

I tried to read everything, i collected a lot of informations, but i still can’t add my device.
I hope, somebody can help me here :slight_smile:

So:
My device is a Xiaomi Mi Robot Vacuum-Mop 2 Ultra
model name: dreame.vacuum.p2150a

I found an app on github (the app’s name: “Get Mi Home Device Token”), so i know the IP address and the token as well for adding.

At the first time, i Could add the device, but i get a warning sign immediately, so i removed, and tried again.
at the second time, i cannot add the device (i tried all the 5 vacuum cleaner category). if i put the “test connection” button a get a warn

Do anyone has any idea to solve this?

Thank yaou so much :slight_smile:
Tamas

This model isnt supported by the app (yet). The warning on pairing screenshot suggests a wrong token as well though.

If you would like to see this model supported in the future you can submit a feature request on Github and it might be added somewhere in the future.