[APP][Pro] Xiaomi Mi Home App for WiFi devices

Please read the instructions in the app description. It’s all there in as much jip and janneke taal as possible. It’s also mentioned that you need some technical skills to use this app. As Xiaomi does not officialy support third party devices talking to the Xiaomi devices it’s not gonna get more user friendly than this I’m afraid.

1 Like

v2.8.2 - 2018-09-05

  • FIX: fixed bug with return to dock action card for Vacuum Cleaner
  • FIX: fixed where the Vacuum Cleaner always shows as charging even thought the battery is full
  • IMPROVEMENT: better error catching in polling mechanism for miio devices
  • UPDATE: removed support for Philips Eyecare since there is a bug in the miio library for this device (see https://github.com/aholstenson/miio/issues/145)

Roborock S50: Most functions work now (especially since todays release) but I still get “Could not complete call to service” on all commands. Is something wrong with my config or is this a known issue?

This is a known issue: https://github.com/jghaanstra/com.xiaomi-miio/issues/27

The app keeps on crashing; any possibility to do a downgrade?
I have been searching to find the app.zip for the cli installation method, but cannot find the 2.8.0 anywhere.
Any chance you would share this?

All releases can be found here: https://github.com/jghaanstra/com.xiaomi-miio/releases

But please share some more info. Which devices are you using, are you trying to do something when it crashes and if it crashes do you see something about it in the log? And would you be willing to run a version with extra logging from command line. Just downgrading will get us nowhere.

I just did the downgrade and it works perfectly again.
Basically, whenever I tried to connect to whatever Zigbee node, the app crashed.
I did send you (??) a few crash dumps through my Homey.

But this app is for Xiaomi WiFi devices, nothing Zigbee related?!? I did recieve some crash logs though, I’m looking at them now but cant really explain what is going on. Do you have a gateway, a vacuum cleaner and a Yeelight?

I ment of course: “WiFi-node”

I have two MiDesk lights, a robot cleaner and a gateway connected.

The crash logs look random and even in parts of the code that where not changed with version 2.8.2. Thusfar you also seem to be the only one having issues while 2.8.2 has been available for a couple of days. So I’m not sure where to look for causes. Could you try running version 2.8.2 from CLI and see if that spits out more information on what is going on.

I’ll try this later.
Does the 2.8.2 app, when installed through CLI, send more info in appcrash?

Since a couple of days the apps keeps crashing about once a day…
dont know if it has to do with the updates of the app or the updates of Homey that came recently…
others having issues as well?

Could you send the log from the apps page. And also let me know what devices you have.

Log sent, (8aaad0f9-1167-41d5-b1a4-adb683438374)

at the moment i only use 5 xiaomi color lightbulbs

According to this log there is an issue connecting with a Xiaomi power plug. Have you added this device as well?

2018-09-19 16:35:55 [log] [ManagerDrivers] [mi-power-plug] [0] { Error: Could not connect to device, handshake timeout at Timeout.handshakeTimeout.setTimeout [as _onTimeout]

I’ve been having crashes on the app the past few months
Not frequent but maybe every few weeks. Latest one yesterday…

Everything else seems fine and restarting the app works
Says that crash logs are sent to the dev so are you able to take a look at all?

According to these crashlogs they are connection issues. These are not always handled correctly by either the miio library or my own wrapper. With release 2.8.3 I have made changes in my wrapper that hopefully reduce the errors but they wont be gone completely.

Thanks for checking.
That makes sense in at least the latest case, as my router decided to go into a self diagnosis mode for some reason

I did run round and ‘reset’ all the lights afterwards and worked okay with Alexa after that… It wasn’t actually til the day after that I noticed the app has crashed

Would be great if (I guess inevitable occasional) loss of WiFi didn’t crash the app

Out of interest, is it loss of INTERNET or loss of WiFi that causes the issue? I might be able to reduce the issues by moving the bulbs to my WiFi extension network instead…

yes, i have a powerplug set as device as well, but havent connected it for a long time, the crashes started only recently, but i’ll remove the device, to see if it helps.

The connection between Homey and a WiFi miio device is on the local network (LAN). It would still work if your router has disconnected from your provider but the WiFi and LAN are still operational. If WiFi is down than Homey wont be able to reach any miio device resulting in a disconnect (and in some cases a crash of the app).