[APP][Pro] Xiaomi Mi Home App for WiFi devices

Same problem here :frowning:

Do you have a stable internet connection? I have had the same error but it was definitely due to my internet connection.

Have been trying (for hours… >.<) but ended up with pairing the device and didn’t have any issues from that moment on.

1 Like

Can you confirm that it works with the s5 Max? My wifi/internet connections is fine. I use a tp-link deco mesh system. I can control my S5 Max with the windows roborock app so connection should not be an isseue. Why is the developer @Maxmudjon not replying in this topic? I simple yes or no "it should work "would be fine

Yes, that’s me. :slight_smile: He already responded that he will add it.
I also had another suggestion to implement a different library (node-mihome instead of miio) since that one is still supported and more up-to-date. I hope he will switch, but I suppose that takes a lot more time to do.


From what I understand I need a gateway in order to make the Zigbee devices work. Is this correct?

If you want to use this app: yes.
If you do not have a gateway, use:

:+1: Big thanks!

I still have the same that the S5 MAX does not connect to the APP

Please, is compatible also Xiaomi Robot Vacuum Cleaner S6 Pure? Thanks.

thank you for such a great app. Is there support for Xiaomi mi hub version 2? I have a problem connecting. I paste the correct IP and token and nothing happens (no change) or send me info that IP is wrong. Any idea how to connect?
Thanks for any help


do you finally find a solution to control the Xiaomi ring bell with homey ?

No, unfortunately not. Still works pretty good though. Don’t buy the newer model, that doesn’t work at all. Thought that one would be handy because it’s rechargeable, but I only get a notification in like 1 out of 50 times it should register motion or the door being rang. Piece of garbage.

I just noticed yesterdays update and now I am able to add the Air Purifier Pro V7! Great!

Still no luck in connecting this vaccuum cleaner S5 Max. Is there something i have to wait for? Or sell it and take a device that is compatible? So annoying .Token is correct still no connection with homey.

Try the MiHomey app, with CLI install.

In this app, there are more different versions of the Robot. You just might get lucky. No guarantees though…

Your S5 robot isn’t listed as a supported device for this app:
(see first post: Xiaomi Mi Home App for WiFi devices)
"Xiaomi Robot Vacuum Cleaner V1 and V2/S50, S6"

Trying to connect your toothbrush would have led to the same result…

1 Like

Is there a possible way to add the S5 Max to homey.
Could you please add the vacuum cleaner?


Is it possible to use this app if I want to use the Roborock app instead of the Mi Home app on my phone?

Is this possible to add ?
Mi Smart Space Heater

I’m thinking thesame. I’m trying the homey especially to get rid of the other hubs, to only have 1 device.

I have the tokens and IP’s of the downlights now that they’re connected to my WiFi, but connection is problematic. Same method seems to work for Home Assistant, so I think I’m close… but not quite there.

I’m getting ‘handshake timeout’ problem every time. Might be the ID philips.light.downlight because I think this uses philips.light.bulb… right?

Hi guys, what about Xiaomi Mi Air Purifier 3H? I’ve got the token via miio tool for mac, but I’m not able to connect it to my Homey with the message like: “token might be incorrect” and after the some time it has started fails with “timeout after 30000ms”. Does anybody know how to resolve this issue?

The miio output:
Device ID: (hidden)
Model info: zhimi.airpurifier.mb3
Token: (hidden) via auto-token
Support: At least generic

(hidden) - means by me

1 Like