[APP][Pro] - We Connect / myAudi / MyŠKODA / My SEAT

Hi Martijn,

The option Audi Etron 2021 or newer does not work.

As I see it, the code of the app is based on the instance of IObroker. Within that, for my 2019 Etron, only the ‘Audi’ option works and not the ‘Audi Etron’ option. For instance “tombox” made the climatisationv3 following my findings for the 2019 Etron in the Audi option.

How can I help to resolve this?

Is it possible to have a “charging started/stopped” “when” flow card? Thanks!

Hey @Sweetlake

Yes the app is based on IObroker. Good to now that the E-tron option doesn’t work.
What you can do:

Enable debug in the device settings in Homey.

Try to update and start climatisation for example and after that send me a diagnostic report.

You can send one via the mobile Homey app:

More - apps - myAudi - settings wheel right top - send diagnostic report

@braekk see 2nd card:

image

This is for Audi, but all apps are the same :wink:

Can’t find that under “when” flow cards for my E Up. Maybe not possible with the E Up?

Hereby the code for the diagnostic report

f9118ccd-f0a0-4d83-b6a2-ff0cca206997

@Sweetlake Thanks for your report

From what I see in the logs, looks like there’s a login issue. Can you try to update your username and password in the device settings? and see if that resolves something?

Hi Martijn,

That solved the issue.

The strange thing is that the first time the connection is established and the data is retrieved, then I entered the same password again and it works again.

Thanks for helping me out.

1 Like

Hi @martijnpoppen

Could it be possible to add charging power to one of the variables available. VW ID car. Pretty please with sugar on top :wink:

@peltsi51 yes will add that in future updates. Working on some new features in the background :wink:

2 Likes

Hi Martijn,

just to give you some updates on climatisation button being always on - the remaining climat. time went to 0 only once, it’s majority of the time still on 10min - actually I have never seen any other value, except of 0 once, which is strange.
So everytime I would like to launch climatisation, I have to turn off and turn on - bot sure if it sends command twice but somehow it works.

First of al thanks for making this great app!
I followed the topic for months waiting for a release :wink:
But, I’m running into an issue…

I own an Enyaq, so installed the Skoda version. First connection worked just fine.
But I can’t seem to get updates over time. Only refreshes once and then freezes for forever, even when forcing a refresh. Data in de original Skoda app updates just fine (no connection issues on the Skoda/Car part).

Only stable way to get data is to remove and add my password again. In that last case all data updates within 10 seconds guaranteed. Any idea what could be the issue?

Diagnostics: b22d1429-6580-40c7-91ce-eab6be26d3c9

@RNLDNKP Thanks

Yes correct. The Enyaq is not working as expected. I’m investigating it. Was a bit limited in time for Homey last weeks. Hopefully I can pick it up this week

1 Like

No problem. There’s more in life than Homey :slight_smile:
If there’s anything I can do to help you, just ask.

1 Like

@martijnpoppen just as a side note the range (in KM) has not updated for 24 days. (Golf GTE 2016)
Let me know if you require a log.

1 Like

Have just got my Enyaq and experience the same issue :blush:, but really glad when I saw this thread and that you are aware of it! Grate work! Will do a donate when is working! :ok_hand:

1 Like