[APP][Pro] We Connect / myAudi / MyŠKODA / My SEAT / My Cupra

@Jan-Feijen thanks a lot for you donation! appreciated.

Can you enable debug in the device settings (in homey) and send a new report after that. It will create some more logging which should make clear whats going on.

One question though, does your car use a S-PIN? If yes then that would be a way to identify what type you should select during pairng :stuck_out_tongue:

Hi Martijn,

I’ve enabled debug. I assume I need to retry the actions so you can seem them in the logs, anything in particular so you can debug?

I think I’ve a S-Pin. During verification of myaudi account 2 years ago I had to enter a pin. So I think that is my S-Pin. Also when I installed your myaudi app yesterday I had to enter it to lock/unlock the car. Which worked fine when entered.
But I entered it when trying to lock/unclock but NOT during installing the app. Maybe that would have helped during pairing?
An other observation: when installing your app yesterday with the ‘audi’ option the app recognised the type of my car. Which didn’t happen when installing the app with the ‘e-tron’ option.

Hi Martijn,

I did some testing with debug on.
This is the report: 19610677-1f5d-43d8-8966-ac61046563f7

Lock/unlock work fine.
Start/stop charging, climate, etc. don’t do anything.
Tested with buttons and via flows.

BR Jan

1 Like

fe33498c-0ba1-4bd0-b1ab-e94888962fa7

Not sure what I do wrong here. The device status is not correct. The battery is actually charged and plugged in.

1 Like

@JaccoH can you enable debug in the device settings and send a new report after that?

72f100bc-a927-4c3c-a9bb-c3c9fae72200

There you go.

Thanks @JaccoH

Seems like the same issue as @Jan-Feijen experienced.

Will check the API, probably something has changed (again )

2 Likes

New app update (TEST: 1.15.6) vw

Changelog:

  • FIX: update library

New app update (TEST: 1.15.6) Audi

Changelog:

  • FIX: update library

New app update (TEST: 1.15.6) Skoda

Changelog:

  • FIX: update library

New app update (TEST: 1.15.6) Seat

Changelog:

  • FIX: update library

New app update (TEST: 1.15.6) Cupra

Changelog:

  • FIX: update library


If you find any issues, send a report via the mobile homey app

More - apps - AppName - settings wheel right top - send diagnostic report (put your email in the input field to make it easier)




You can install the TEST version by clicking the link above and press install

Don’t want to be part of this TEST version? Install the LIVE version → vwAudiSkodaSeatCupra

1 Like

@Jan-Feijen @JaccoH Updated the library. Can you have a look at the test version above?

Hi @Bug
Sorry didn’t reply yet to your message :stuck_out_tongue:

Congrats on the Golf 8 GTE. Really nice. Can say the Golf 8 is a nice car :smiley:

Will add that!

Hmm with your previous GTE is was not possible. perhaps it is with the new one. Let’s check that!

As far as I know that’s the max/default value


If i missed something from you message let me know :smiley:
And if your are able to share your car with me then I can take a look at the response.

Or: enable debug in the device settings, do a force update and send a report after that

1 Like

I’ve installed it and will do some testing over the (long) weekend.

1 Like

@martijnpoppen, I’ve tested again with the test version (v1.15.7) but no improvement. Still having the same issues.

This is the diag report: 210a7862-914d-4dc0-b9e9-0dba11457f17

BR Jan

@Jan-Feijen as your using HP23 the report is really short. Is it possible to start an action and immediately send a report after that? :smiley:
Then maybe I can see what’s going on.

Already requested longer reports at Athom.

@martijnpoppen,

Of course.
Car was charging and I tried to stop via the app but it continued charging.
Also started climate, but same. Car didn’t do it.

This is the report: 17d0caa8-88cd-49ee-8216-490263484c19

Will check tomorrow @Jan-Feijen

1 Like

ee00e5f6-1e85-4ea5-9c15-2fd100d4fc1c

Don’t see much difference sadly.

I have a problem with my skoda plug in hybrid.

I have no flow active with the skoda app. Only notifications. Like when battery is fully charged and when car comes home.

I got some warning message in my regular Android skoda app that my climate request was denied . Too many requests in short time and it was denied to save the battery-life.

That happened two times and stopped when I removed it from homey. Can this problem be connected with homey?

@Johan_R In the library I;m using there’s much going on.

The best thing to do is to increase the interval in the device settings if you’re only using statusses.

As the library just calls multiple API’s it’ inevitable that it also calls climate info which add to the requests

1 Like

@JaccoH Sorry had some private priorities last days.

Checked your report, but you’re still on app version 1.1.5.6 and not the test version. Can you click this link and press the green install button? MyŠKODA | Homey

@Jan-Feijen checked you report too (sorry a bit later than promised, but had some other things going on :wink: )

The issue you have seems like an driver issue, is your car on the latest software?

I saw this before and then the solution was to choose the other car type in the pairing screen, but you already did that ofcourse…

So let’s check the version of your software in the car then we can maybe see which API is relevant for your car.
VW has a clear distinction between the 2, but unfortunately Audi doesn’t

Edit: for your info:

[debug] {"error":{"errorCode":"RS.security.9007","description":"The service: rheating_v1 for VIN: REDACTED could not be found."}}
This most of the time indicates that you have to use the new API