[APP][Pro] TuyAPI / Neo Coolcam wall plug WIFI app

Hi harryd,

Yes I added the devise to the Tua Smart Life app. When I drag down nothing happens in the console, just ‘Wating for request’.

Have you installed the certificate for use by apps?

No, just the grid powered ones, and those as listed in the app / or simular.

For support for different devices see my post above

Hi!

If you have done
4.1 Installed the certificate.
4.2 Updated the WiFi settings on the Android device with the proxy settings provided in the command prompt.

Then it should work. But it feels like the phone doesnt get connection to the proxy. Double check the settings.

Hi!

Oké I got a little bit futher. When I drag down to refresh th app I get a error. “In correct local timer, please correct it 50502” EDIT: I don’t get that error every time. I tried evertyhing from the beginning and no error. But also no key.

And yes I did installed the certificate en updates the WiFi settings on the Andorid device with the proxy settings.

I added the proxy like this https://youtu.be/oKqMwEP23Ak (with the IP and port from the command prompt)

I added the certificate like this https://support.google.com/nexus/answer/2844832?hl=nl and choice for WiFi

I noticed when I got the certificate link the poort is a other number. Is that a problem?

The error suggests that the date and/or time on your device aren’t correct.

Hello,
sorry for answering so late, but my brother got a heart surgery and the last two weeks I haven’t had time and mood to try out what you explained.
But as he is getting better now I managed to install the Tuya-API tool, get the device codes and keys and created a log.
The log was already sent via the app in Homey, but I’m not sure if it will reach you. So I send you the log as PN, cause I’m not sure if it is a good idea to publish that data here readable for everyone.

maybe this helps:
I had the same error on my Android mobile until I noticed that I had to install the certificate for “VPN and Apps” and not for “WLan”!
Only after doing it this way I could see the trusted certificate with name “Node MITM Proxy CA” under “Settings/Security/trusted Logindata/User” (sorry, path translated from my German phone, maybe English UI diplays a little bit different).

Sadly first try was not successfull. The shutters don’t react on any button presses in the app.
I sent you more info as PN.

I just tried it with 3 lamps (LSC Smart Filament LED) that I bought with the action. They work great in the tuya app and in google home, but unfortunately not yet in homey.

I have managed to find the key and all other information via the manual, only when I add the devices in homey the devices remain unreachable.
I have tried adding them as LSC Smart Filament LED and as LED strip but both the same result.

Can you help me with this?

I have same problem, any news? I bought (seller mistake) wifi PIR sensor, is any change pair it. Thx

No, battery powered devices are not supported by the api this app works with. These devices don’t stay active long enough to be controlled locally.

Would it be possible to add the ceiling light from the Action LSC series? If so, will the device by dimmable? Thanks you for putting all of your time in to help us all!!

Yes, follow instructions as discribed above

What type of device should i use when adding the LSC smart ceiling light ? i cant get it to work. I got the DeviceID and LocalKey in same time with other LSC smart devices and those are working (2x smart led bulb and 1x smart power plug)

Just to be curious. . You sure its supported by the app

Thanks for this app. I have purchased these lights: https://www.amazon.co.uk/gp/product/B07VPTV4LJ/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1
The instructions that come with them lead you to install the Smart Life app which looks identical to the TuyaSmart app but is not the same. So with a bit of help from the guys on Slack I got them working once I installed the TuyaSmart app on my phone and added the devices to that.
I have added them as the LED strip so I get the colour selection. The only thing that doesn’t work is the power On / Off button but dimming to 0 switches them off so not a major issue.
One thing the Tuya app supports for these is a scene mode where the colour can be animated so it would be great if that could be added to this app.

Hi Rens,

First of all compliments on your GREAT app.

I stumbled onto your app from my research for an alternative on the Ring video doorbell which is not capable opening a live video stream and has no possabilities for local video storage.

Guess what: aunt Ali has plenty clones for sale which do this perfectly. And most of them are Tuya connected.

Although i’ve read your statement that battery operated devices… i read in the doorbell spec’s that with the use of 18650 cells the devices keep continue connected…

I was wondering: is there any chance if we pick a nice tuya based video doorbell at aunt ali and i buy you one too… that we have a chance to make a API connection ?

In particular i need a simpel flowchart “someone rings the bell” so i can trigger an action on Homey to turn on the light.

Please let me know what you think.

I’m sure that implementing this would make a lot of people happy, on other Homey topics i’ve read Many people are looking for a decent video doorbell which does not force you into an abonnement like ring does. I think your tuya app could be the answer on that :blush::muscle:.

Thanks in advance for your answer and keep up the good work, it already is an GREAT app !

Thanks for making this app!

I have followed the installation process almost to the end, but can’t quite figure out how to change the proxy settings on my phone (Huawei P20 Pro). When I go to My_Network -> Change network and try to change the proxy, I am not allowed to save the settings after changing port to 8001 and IP to 192.168.0.12. Looks like I need to write something in Hostname before I’m allowed to save, but I’m not sure. Am I doing something wrong?

EDIT: I got it working by setting IP as Hostname

Hello all.

Got a couple of NEO 3600W devices, and found the id and key. They both works in TuyaSmart app, but it’s ‘dead’ in Homey…

What can possible go wrong ? I can ping the ip address of the device.

But generally I don’t like to have access to the device from internet, so to isolate it, maybe it’s better to flash it with tuya convert ? It seems like it’s supported

/bwa