[APP][Pro] Systemair

Yes, i can log in

Systemair has changed the backend API and security, so the Homey app for the IAM Cloud does not work right now.

It might be a chance that I get enough information from Systemair to be able to update the app so it will work again, but I can’t promise if and when.

Thanks for trying to fix this! This app is the reason i bought a Systemair unit. Why dont they provide an open API!?

Hi.

I am trying to connect my Systemair IAM Cloud to my Homey pro. Error code: Unexpected token < in JSON at position 0.

Any tip??

Please read my post above.

I’m looking at supporting the Systemair IAM in “Modbus TCP” converter mode.

The IAM must be set to Modbus TCP converter mode, ref chapter 4 in: https://shop.systemair.com/upload/assets/SYSTEMAIR_IAM_MANUAL_EN_SE_DE_NO_FI_20190429.PDF

This will disable the cloud connection, so the Systemair Saveconnect app and website (https://homesolutions.systemair.com/) won’t work after selecting Modbus TCP mode. You can always switch back to “Cloud” mode, if that’s preferred.

To test:

  1. Make sure you have the latest firmware for the Systemair unit (MB, HMI, IAM)
  2. Set the IAM to Modbus TCP converter mode
  3. Install the test-version of this app:
    Systemair | Homey
    If you are able to run the app from CLI and can help testing, here’s a link to the source: GitHub - balmli/com.systemair: Systemair app for Athom Homey
  4. Install the Systemair IAM Modbus device. The device should be found automatically.

NBNB! I can not guarantee that older unit types are supported, and install at your own risk!

Known issues / bugs:

  1. The Extract air temperature register always returns 0. (at least on my unit)
1 Like

Hi. You are the best, for digging into this change from Systemair.
I’ve followed your steps for the TCP mode, installed your new experimental APP.
I’ve only installed the app, no GitHub.
On step nr 4, no device found.
Tried restart Homey, but then i had to install your new APP again.
no device found.

What am i doing wrong?

Check that you can ping the IAM, and that Homey is on the same network

I can enter the IAM in browser

Thanks for your effort on this! I am also having problems finding the IAM.
I did set the IAM to Modbus mode. I am able to log in to the IAM using its IP-adress. Homey and the IAM are on the same network. I ran the app using CLI and got this line if that’s of any help.

[log] 2022-05-14 19:55:51 [ManagerDrivers] [Driver:SystemairIAMModbus] onPairListDevices {}

I have tried to connect the IAM using both WIFI and Cable with the same result (not found by the app)
The MAC-adress specified in the manifest for discovery is the same as printed on the back of my IAM and reported by command “arp -a” from my computer.

Not sure where to look further…

@Atle_Kristoffersen @Johan_Lindbom

I don’t know why MAC address discovery does not work for you.

@Atle_Kristoffersen Possible for you to check the MAC address of the IAM? Look on the back of the IAM (and it is normally visible in the Wi-Fi router). Now MAC addresses starting with 24:80:00: is supported.

In v. 1.4.1 I have added a possibility to manually update the IP address after pairing, if the MAC address discovery does not return any devices.

So:

  1. Install v. 1.4.1 from this link: Systemair | Homey
  2. Install the device. It will be unavailable until the IP address if set correctly in settings.
  3. Go to settings and set the IP address

@Atle_Kristoffersen @Johan_Lindbom Are you running Homey firmware 7.4.1 ?

Hello :grin:
I got it to work. Dont know if this was my problem but deleted 3 nodes that was unknown and unreceable. Found it and entered the IP :+1:
Flow works but not when manually adjust temp, it goes back to last state within 2-3 sec. But temp changes when useing flows.
And temp extraction air still not work.

Nice work, thank you alot.

But will there be any chance to go back to the same metod, no TCP mode in the future?

@balmli I am using Homey version 7.3.0.

But today, everything just seems to work using version 1.4.1. The IAM is found by MAC address discovery and the Device is added and I am able to communicate with the IAM again. As far as I know, no changes where made to my network or setup.

Thanks for your great work on this!

Any idea why the extract air temperature is not working?
I did notice that the extract air temperature is not reported in Systemairs official Android app either.

The extract air is not reported on my system either. Might be an issue with the Systemair firmware for the MB (motherboard). I don’t know.

BTW, here’s doc for the full list of Modbus registers, if you want to have a look at it:

Extract air temp is register 12105, AFAIK.

And you can debug by using the jsmodbus tool, from the Homey Systemair app source directory:

./node_modules/jsmodbus/bin/jsmodbus.js fc03 <IAM IP address> <unit-id> <from-reg>:<to-reg>

This command will check the 12105 - register:

./node_modules/jsmodbus/bin/jsmodbus.js fc03 192.168.3.6 1 12104:12105

It will respond like this:

Attempting to connect to 192.168.3.6:502 at unitId 1 ...
Connected
[ 0 ]

To fetch all registers from 12101 to 12110:

./node_modules/jsmodbus/bin/jsmodbus.js fc03 192.168.3.6 1 12100:12110

It should also be possible to access the IAM Modbus regsiters (unit id 2), but I haven’t found the register documentation for that.

Register 12544 REG_SENSOR_PDM_EAT_VALUE seems to be reporting the extract air temp.

Lost connection after update ro 1.4.2 here’s the log 1bc8ae1f-ca84-42c8-8be3-bdbc6ff0ee6e

Great work! Version 1.4.2 is reporting extract air temperature and from what i can see it is all looking good.

Thanks!

Seems like authentication with the iam module does not work after the latest system air updates.
Same error message when the pw is wrong as when it’s correct it seems.

Yes. Read posts above for more info :smile:

1 Like