[APP][Pro] Support for ONVIF compatible cameras (2.0.8 & test 2.0.9)

Thank you Adrian.

Would this below line make any difference?
If notification could be triggered using this line?

“$”: {
“Name”: “Rule”,
“Value”: “MyMotionDetectorRule”
}

Below redditor seem to be using that line for onvif detection.

No, as it is part of the same event message and appears every time for the “tns1:RuleEngine/CellMotionDetector/Motion”. If it only appeared in some of the events then maybe it could be used to filter them, but I’m not seeing that in the log.

can i help with testing in any way?

If you can find a way to generate a different event type or a different Rule then send the log showing that and I can find a way to use it.

Hi,
Im using a Axis M3065-V camera and it seems to work. i get picture but not motion.
have anyone tried this camera or another Axis camera and got the motion detection to work?
in Delveloper tools there are:
motion_enabled True
alarm_motion false
alarm_tamper false
could the alarm_motion and tamper be the problem? cause i cant set them to true

by the way
awesome APP!!!

I got motion to work finally after trying alot!

1 Like

Sorry I could get back sooner, but glad it is now working.

Anything that starts with alarm_ will be read only as these are set by the app when an alarm condition occurs.
You cans see a list of built in capabilities here Tutorial: Device Capabilities - Homey Apps SDK v3

No problem i gave you a full 7 min :rofl:
I found a setting inside the camera that wasnt tund on

1 Like

Hi
I have hust added my new Reolink RLC-820a but icannot get a snapshot. the logs says this:

SnapShot error (192.168.2.129): request to https://192.168.2.129/ failed, reason: self signed certificate

I have also send the log. what could be the issue?

1 Like

Can’t u use http:// instead of https://?
Then a certificate isn’t needed

Hi, I do have the same issue and don’t know how to solve it…

Self-signed certificates can’t be verified so the https library rejects them. There’s a global setting to ignore those errors but that compromises the overall security. I guess as ONVIF is only local that might not be an issue.

Thank you for your very quick answer. Do you know where is this setting ? I’m having this screen but don’t know what to put in :

I did find it but now I have the Econ issue

And did solve the issue, I don’t know why but disabling https also disabled http. So make sure to activate http and disable https. Now it works. I will now try to add these cameras to homeykit. Hope it works.

1 Like

I managed a workaround for my earlier problem with detection and motionsnapshot on my RLC-811A.
I created a webhook everytime Reolink app had a motion alert, requesting a motionsnapshot.

I bought a Reolink Duo Lens 2 hoping for the same workaround.

Unfortunately I get “unauthorized”.

I can add the camera using the correct credentials.
But once I have added the camera, I get unauthorized.
I have tried adding and removing the camera several times. I also tried the built in repair function.

I can always add the camera, and I can always access the web interface using the same credentials.

I have the same settings as my RLC-811A which works.

Can you send the log from the Configure App screen so I can hopefully see what’s causing the error.

The app is trying both basic authentication and Digest Authorization, which are both failing, so I’m not sure what it us expecting.
Are there any settings in the camera that might give a clue?

I’v gone through the settings several times.
It has the same settings as my RLC-811A.

I’m not sure if you did anything or if reolink did anything but it started working now…

I’v tried to get it to work the whole day and I haven’t made any changes the last two hours.

But now it works…

Thank you for taking the time to read and look at my case and as always, your swift response!