[APP][Pro] Somfy Tahoma & Connexoon (v3.0.35, test v4.0.2)

I have been out all day so I have spent too much time catching up. So sorry, I should have tried it myself first, as it seems I have broken it in the latest version.

No problem.

Time for me to get some sleep…:wink:

1 Like

I read above quote in a closed topic and then I saw my Connexoon also asks for an update. Is it smart to update? Probably it will change the login mechanism. I don’t trust Somfy anymore

@Adrian_Rockall you have build some alternatives (OAuth support) to still be able to login successful. So maybe the connexoon update is safe. It’s a pitty Connexoon doesn’t mention to which version it will update, so I could Google for some release notes.

Hello,
I had yesterday the same situation - Connexoon box asked for an update and I did it. Then, I was not able to coonect to it until I installed the Test version 2.0.7 (see the link in the conversation above). Simply it responded with error 401, so you have to use OAuth system. After installation I was able to successfully log in to Somfy API with saving the credentials, but next step - adding existing devices (my vertical blinds) was not possible until restart the application. So, now I am testing the latest version and it seems to be working… Thank you @Adrian_Rockall for your support!

This morning i’m not able to login anymore.
I’m using a Tahoma box but there is no way to login anymore.
I’ve tried al kInds of possibilities but when the app says successful the log says it’s not and when i try my shutters i get an 401 error even after restarting my app.

Thanks Adrian!

At the moment I’m not sure if anything. There seems to be so many random issues with logging in lately and I haven’t seen any common situations between the ones that work and the ones that fail.
Mine so far has had no problems logging in with either method. That’s good for me as it means all my devices and flows are working but it is not allowing me to track down the problems.

One thing has occurred to me this morning after seeing an error log that has been submitted. Now each device requests its own data asynchronously there could be a race condition when the token expires.
I will investigate further when I get home this evening.

1 Like

For the Dutch readers there is this one as well:"

I took the chance to update my connexoon with the update of yesterday and I am still able to login (Homey) without OAuth enabled. So it’s indeed kind of random.

1 Like

Would it be of some help to adjust this setting to avoid a Somfy ban?


And will this affect my consumer experience dramatically or hardly.

Do you have the KLF200? I’ve been looking into that, but there is so little information available online, even none regarding Homey. I’m still interested because I would lose the internet dependency of the stupid Connexoon.

If you have it, do you already have a way to connect it to Homey?

No i don’t but would like to buy one and get rid of the Connexoon.
As you said, Somfy sucks… :wink:

Let’s find someone who can make an App for the KLF200…

When i went to bed yesterday nothing was working…
When i woke up this morning it worked again!

Meabe Somfy had work in progress yesterday, there also was an firmware update of the Connexoon box.

It would be nice if someone could make an App for the KLF200 from Velux. Then we wouldn’t be dependent of Somfy anymore, it works “offline” and also supports Some products.

1 Like

Maybe add it to the right topic section: Homey community app requests

Hey guys so am I only one with lost scenarios in the app? The list in action flow is empty. I run 2.0.7. can normally login without oauth and i am able to operate blinds. :thinking:

After updating the Tahoma, my IO wall plugs, sun and temp sensors stopped working.
IO awning and rts curtains still work though…
:thinking::thinking::face_with_raised_eyebrow::face_with_raised_eyebrow:

Where can I find that update?
I’m far behind you.