[APP][Pro] SolarEdge

homey puts controls 1st , then sensors. also like to see this the other way around

What is the polling time set to? Can I change it?

cannot change it now , lets see if I can change, provide that

but becomes slower and then the time it takes goes over 45 seconds and the next run kicks in,

Hi,

I published a new version with a performance boost by not reading not used registers, meters(2,3) and battery(2).

now I can read it all in 5 seconds and can bring back polling to every 30 seconds for meters and battery.

Also it has now import limit control so you can make sure the battery is not supplying all the energy to your installation , always import when needed a certain amount from the grid and save some battery power for your peaks.

please try this.

thanks Edwin

1 Like

I’ve added my SolarEdge but I don’t get any data… I’ve checked the IP, port and ID.
I’ve waited about an hour and I’ve check the SolarEdge app (for iOS) and it gives me data.

sorry for that , probably there is some explanation.

did you enable modbus like on the 1st post of this forum. Are you using a lan cable ? I guess that is the main part ( I guess you don’t have some kind of firewall )

plus know your ip and modbus port? maybe also check modbus id

after that you can send me diagnostic report so I can the communication.

Also there can be only 1 device at the time using modbus, 1 can block other devices who like to read this data.

1 Like

I did this:

Go to the menu by the following steps:

  • Switch of the DC power
  • Long press the ‘OK’ button for a few seconds
  • Release the ‘OK’ button
  • The screen will ask a password, this is ‘12312312’ (the 2nd button from the left is ‘1’, the 3rd button is ‘2’, etc…)
  • Go to Communication → LAN Conf → Modbus TCP (the default port is 502).
  • To modify the TCP port, select Modbus TCP → TCP Port, set the port number and long-press Enter

I am using wifi. I do know my IP and port (502). I guess the ID is the site_id/installation_ide as shown in the web portal of SolarEdge?

I have no idea of Modbus devices.
Report: c2de89b8-de43-4a09-b603-2b0589f590b7

got it , you are lucky wifi works for you , I will make it more clearer it is the modbus id , mostly 1 and max 15 I think.

1 Like

I was a very happy user, but now it seems the fun is over. Went through all the settings in app and on the invertor. Searching online for all that I could find. That brought me to an update the SolarEdge invertor recieved late august/early september…

TCP Modbus connection is no longer available via WiFi. Can someone confirm this, before I start drilling holes in my walls to get an ethernet cable to my invertor

From the solar edge firmware file from September:

  • Modbus TCP over secured Wi-Fi is now officially supported for residential inverters
    • Modbus TCP over unsecured Wi-Fi is blocked
    • Modbus TCP over Wi-Fi for commercial inverters is blocked
    • Note: Modbus TCP over Ethernet and Modbus TCP over RS485 for all inverters are supported
2 Likes

nice

Anyone tried it yet?

Tried what?:innocent:

This

i have everything cabled so no sorry. :wink:

1 Like

Looks like it, great!