[App][Pro] PaperTrails Log - Advanced Logging and Log management (v0.6.3)

I use Papertrials to log to my ubuntuserver syslog but i see always a difference in time.
The logging from homey to syslog is always 1 hour early, GMT i think.
logging from other things to my ubuntuserver syslog has the correct time.
When logging to the local papertrials file i have the correct time.

Did also reboot of homey like you did but i see no difference.

Anyone able to download the logfile?

Try download from https://developer.athom.com/tools/app-settings
As it is not possible in the mobile app.
Don’t know if Athom will fix it but I will make a note in the settings that it doesn’t work from the mobile.

That works!!! Thanks a lot @Dijker

Hi Aart,
Sorry I missed your msg.
Question,
What is your Timezone (Where does your Homey Live) and what time do you see in:

I use internally and send the UTC/ Zulu time in my app ( var logDate = new Date(); )

For me it is in developer.athom.com/tools/system:

|date|“2019-03-05T20:43:20.533Z”|
|dateHuman|“dinsdag 5de maart 2019 21:43:20”|

and in Papertrails Log I see:

[2019-03-05T20:43:40.035Z] test 21:43

in my Syslog server PapertriailsApp.com configured for TimeZone Amsterdam (GMT+1) I see:

Mar 05 21:43:40 [PQR-HomeyV2.0] test 21:43

and although is sounds maybe strange but this is what I expect.

If I change my PapertrailsApp.com display setting to UTC (GMT+00:00) it displays as in the internal text log:

Mar 05 20:43:40 [PQR-HomeyV2.0]test 21:43

So I guess your other things log in GMT and not in UTC

It could have to do with the configuration of RFC5424 settings: (https://tools.ietf.org/html/rfc5424)

Hello Dijker,

So there is no problem.

I made a test flow which gives the time in the local papertrials log and also on my syslog server.
local (on the Homey)
[2019-03-06T14:42:02.239Z] Tijd is 15:42
syslog server:
Mar 6 14:42:02 Tijd is15:42

De syslog server is ubuntu 16.04 and is logging for 2 years also info from my router (draytek)
cat timezone
Europe/Amsterdam

router
Time Server pool.ntp.org
Time Zone (GMT +01:00) Europe/Amsterdam
Enable Daylight Saving V

In the Papertrials config i have Geek[zulu time], but normal seconds gives the same output

What do you think about this?

I guess your router logs the local time and Ubuntu doesn’t correct the logged time with the local time to display on your interface.

For me the most logical to configure is:

  • let everything operate on UTC
  • let everything communicate and log in UTC
  • for display/local operation configure the Timezone.
  • At my syslog I can choose to display everything in the Timezone I want.

For what I can see this works as expected for me.

Hey guys,

I am working on updating the PaperTrails App,
For Homey version 2.0 I have to remove some features that won’t work anymore.
These Feature have to be removed:

* Option to Import Z-Wave Log.
* Automatic Adding & Removing Logging to All Flows with a Prefix.
* Migrating Flows from Simple Log.

The option to Import from Z-wave will be removed anyway, please PM me if you used it…

The option to download your log file will only be available on the Developer dashboard ( https://developer.athom.com/tools/app-settings )

But before I work on it ans publish a update I have some Questions for current- and new users of Papertrails:

Have you Updated Homey: (All Votes are anonymous)

  • I Updated to v2.0
  • I wait, I am still on Homey v1.5

0 voters

Would you like to have a separate web dashboard to view the Log or will you use the mobile app and Homey developers?

  • Mobile App and Homey Developer works for me good enough
  • Please create a separate Dashboard (Website)

0 voters

Have you used the “Magic” to add Papertrails logging automagicaly to each flow and would you like it back in 2.0?

  • I used Add Papertrails to each Flow
  • I would like to have that function working in 2.0
  • I don’t care if the option to add to each flow wil not come back

0 voters

Thanks for your time and Answering!

This way of downloading does not work anymore. Something changed?

Just tested,
nothing changed and still works on my Chrome on Windows.

I’m a happy Papertrail Log user for a while now.
Since V2 I need my phone or iPad for checking the log. Different on a pc the front is quit big now and not much information is vissible on a page.
Is it possible to make a user defined font size for the log? Or a smaller font size in basic?

Well to be more precise: it shows the log but I can’t open the Config or Maintenance tab. If I try to open one of these tabs in a new tab in Chrome (Windows) it opens a tab “about:blank#blocked”.
Haven’t figured out what blocks it. Any suggestions?

EDIT: does not work in Chrome or Brave, but DOES work in Edge (!?!)

Updated the app and published:

Version 0.6.0 0.5.10 (Sorry, I can’t count :wink: )

  • several updates to Fix on Homey firmware v2.0
  • Removed option to import Z-wave logs (Not possible anymore on Homey 2.0)
  • Hide Download Button on Mobile Interface (pls Go to Developers site)
  • Temporary hide Maintenance panel (as it doesn’t work in 2.0)
  • Started migration to i18n and translating from en to nl and de.

Moved the following to a Web App Dashboard Behind the Community HomeyBackup Web App: https://homeybackup.web.app/login/ (as it is not possible from Homey V2 anymore)

  • Added Magic!
    • Automatic Adding & Removing Logging to All Flows with a Prefix.
    • Migrating Flows from Simple Log.
1 Like

Hi @Dijker,

I really like you app, a bit more than the Simplelog app. are you gonna add an action card: “add to limeline”? and “add to log and timeline” ?

Thats the only thing left, i’m using the simple log app.

Thanks!

Does the same here in Windows 10 (1903), Chrome 76 64-bit (tried both in normal mode and incognito mode to see if some addins may have been harassing).

In Edge it does work.

Usually I work in Vivaldi browser (Chrome engine) and that one also doesn’t work (can’t change tabs like described by @CorvanderNiet)

Hi @Dijker Found a glitch (maybe something I’m overlooking).

Today I configured my Synology NAS as a syslog server and configured it’s IP-address in Papertrails (v0.6.0)
Set the IP-address and checked the enable box
Chose UDP port 514

Enable syslog or all log additions => Application name: Paperrails
Severity: Informational
Facility: User

Now whenever I add something to papertrail a log is also written in syslog (which is expected) however, the application name is Papertrails [first word]
Or, to be more precise: the first word of the Papertrail log message gets added to the application name and the second word and further are in the message itself. I saw something about prefixing the first word with but that doesn't change anything (just the first word prefixed with is omitted completely). Also the category seems to be local0 while I did setup User in the settings.

Now when I use the send syslog line card, i can choose the type of message which seems to work (tested only a few) but the User is also not working; when choosing Audit I get “Console” in the syslog and also still the first word of the message gets added to the application name.

Maybe I’m overlooking something or maybe there’s a little issue with syslog logging (or the syslog implementation in Synology)…

Adding the papertrails cards to all flow with the community backup and restore tool isnt working for all flows in my case, some are added some are not.

any pointers or directions i can look at?

I only add it if the Flow does not have an Papertrails card already. and it must be a valid flow (not broken). pls try fixing or removing all broken flows first.

Tanks, ok, so i fixed all the broken flows and it did more flows, but not all.
so i went deeper, and fixed things like missing logic cards, wrong flow references and notifications to users that dont exist anymore.

but still not all flows are alterd. is there a way so see which flows are bottleneck?

Homey app shuts down in log view, latest iOS 13, iPhone 7