[APP][Pro] Netgear Router - Network control, Presence detection, Energy monitoring

I’m using this brilliant app for presence detection, i need my garage to open as i arrive. 20 secs of polling feels like years. I even extended my orbi with an outdoor ap/extender.

Any ideas how to make arrive work faster?

Hi @AvApsi,

Super that you like my app! :kissing_heart:

But using wifi presence it not really suited if you want to open doors with it. And 20s is about the minimum time it would take for your phone to connect to the wifi, and for the netgear app to detect that it is connected.

You could go for GPS based geofencing (a number of apps can do that, including the Homey app itself), but it might open your garage door too soon. Or go for bluetooth (BLE) beacons. But you would need a BLE receiver in range (max 5-10 meters). Or get a wireless (rf/zwave?) remote control :slight_smile: Or use a flow in your Homey app as remote control. Or use IFTTT widget to make a ‘open garage’ button on your smartphone. Or maybe someone else has a great idea :sunny:

V2.5.0 was just released in the appstore. It has some more internal optimizations and a fix for firmware check on certain router types.

Furthermore, Homey will now automatically try to switch on the traffic meter and access control. There is no need to do that manually anymore in the router.

Master Gruijter, you can add Orbi ac3000 and including Orbi outdoor extender to the list of devices that your app works with.

Reason why i dont use gps is that my house hold are only using android, and that doesnt work with homeys gps… well i cant get it to work at all.

With my orbi extender i jump on my network 30 meters away inside the car, and i just changed from extender mode into AP mode, i think that was causing the issue. Need to test and my neighbours might think im crazy… im driving back and forth to see when ure app picks my mac adresses up. I will get back to you with info… but im guessing that the extender mode didnt tricker ure app. :+1::ok_hand:

I think I remember someone mentioning that with orbi extender mode, the connected devices get virtual mac addresses that depend on the AP it is connected to. Is that true? If so, then that would definitely confuse any flows that look for a fixed mac address for presence :wink:

By the way, I made the app so you can actually add multiple AP’s as seperate Homey devices. So the AP on the driveway can produce seperate trigger flows. Maybe that helps in finding a solution.

It works!!! Besides a neighbour came out and said… are u playing pokemon from the car??

Okay here is the solution.

Do not use extender mode with orbi. Set it up in outdoor access point mode.

Bam! 30 meters away from my house samsung s8 and Huawei p20 jumps on the network… 20 secs after bam! Your genius app spots my mac adresses and my flow opens the garage just as im right infront of it!

Another helpfull tip for android users.

Battery savings might turn off wifi roaming! So turn em off or install a keep wifi alive app.

:+1::+1::+1::+1::+1: this app rocks!

1 Like

I am having issues with my flows for presence.
This flow is disabled after about 8 hours because it is executed too many times.
Is there something wrong with my way of thinking or is there something wrong with the App?

The flow looks ok. It will be triggered everytime a device goes offline. In the app logs you can check how often this happens, but in my home (with 25 devices, and around 10 wireless devices going offline every now and then) this only happens a few times per hour on average. I don’t see how Homey can think that ths flow is triggered too much, unless it would be triggered multiple times per second. And that is extremely unlikely. Is there no other flow that is causing this issue maybe?

I had the same with my general battery check flow.
After an update of Homey it suddenly stopt stopping the flow.
I’m running the latest firmware of Homey
I did mak a ticket too Athom by the way

I have now waited for the new stable FW and tried the presence again.
Still the same issue. I have attached the log from the app. From what I can see there is not really much trafic. Netgear logs.
I wonder why it’s still being disabled.

I think you should open an issue with Athom on this. The triggers are really not that many.

Yes I have opened an issue, but in the meanwhile I could do some testing. Would you mind showing your configuration for the app? It might be something that I’ve set up wrong. Or is there any deep runthrough for all the recommendations in the app? :slightly_smiling_face:

2 example flows I am using myself. As stated before the flow you showed before looks fine to me and should not give any problems. You might want to try to fully delete the app, and reinstall. Maybe something went wrong in Homey during the install. But that is wild speculation… I heard similar problems for other flows (using other apps) so I do think there is a bug in Homey somewhere.

I recently got a R6020. I can’t connect it to my Homey. All I get is this error message:

Any advice? I have tried restarting router + Homey but with no luck.

Does your router work with the Netgear Nighthawk app correctly? Is the router on the latest firmware? If both yes, then please create a issue on my Homey Netgear app github page, and paste the result of the test there (this can be found in the Homey Netgear app setings tab)

Thank you for the quick response.
It works fine with Nighthawk app (and routerlogin.net) and it is running on the latest firmware. I have created an issue on GitHub now.

Hi !

Since your latest update , which ran a few hours ago. The app reports socket hangup and I can’t control the router And my hue bridge is unreachable. The strange thing is I can connect to homey and some other devices.
The problem is I’m not home right now so I can’t do a reboot of the router . I tried rebooting the app which did not change anything to the situation.

It is a r7000 with the latest firmware btw :slight_smile:

Is there something the app could have changed in my settings with the update ? Or …

Because the First time I installed it a while back, it locked me out by enabling the access control :sweat_smile:. Maybe something similar ?

Hi Fabien, sounds like your R7000 locked itself up. A hardware reset of the router must be performed.

I noticed that the firmware of the R7000 is not very stable when the soap polling is too often. Did you maybe lower the time polling interval? If you set it longer the chance of a lock up decreases. Keep it at 60s or higher.

1 Like

Thank you for your quick response!
I does seem like it, but in general the firmware of the r7000 is not very stable…

I did not increase the interval , but i’ll Decrease it to 90s … maybe that will also increase overall stability.

I’ll let you know when I tried it!

1 Like

I decreased the interval and it seems to be running stable for now!

1 Like